summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/robot-detection/robot-detection-0.4.0.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/robot-detection/robot-detection-0.4.0.ebuild b/dev-python/robot-detection/robot-detection-0.4.0.ebuild
index a581ad559595..e43ccf957905 100644
--- a/dev-python/robot-detection/robot-detection-0.4.0.ebuild
+++ b/dev-python/robot-detection/robot-detection-0.4.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Module to detect if a given HTTP User Agent is a web crawler."
@@ -13,3 +13,5 @@ SRC_URI="https://github.com/rory/robot-detection/archive/v${PV}.tar.gz -> ${P}.t
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
+
+distutils_enable_tests unittest