summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/roswtf/roswtf-9999.ebuild')
-rw-r--r--dev-ros/roswtf/roswtf-9999.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-ros/roswtf/roswtf-9999.ebuild b/dev-ros/roswtf/roswtf-9999.ebuild
index c9baf4196f78..7de0715481df 100644
--- a/dev-ros/roswtf/roswtf-9999.ebuild
+++ b/dev-ros/roswtf/roswtf-9999.ebuild
@@ -26,3 +26,9 @@ DEPEND="${RDEPEND}
$(python_gen_cond_dep "dev-util/rosinstall[\${PYTHON_USEDEP}]")
$(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
)"
+
+src_test() {
+ # Needed for tests to find internal launch file
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}