summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/sparklines/sparklines-0.5.2-r5.ebuild')
-rw-r--r--dev-ruby/sparklines/sparklines-0.5.2-r5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/sparklines/sparklines-0.5.2-r5.ebuild b/dev-ruby/sparklines/sparklines-0.5.2-r5.ebuild
new file mode 100644
index 000000000000..95469a2a1277
--- /dev/null
+++ b/dev-ruby/sparklines/sparklines-0.5.2-r5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Create sparklines, small graphs to be used inline in texts"
+HOMEPAGE="http://sparklines.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-macos"
+IUSE=""
+
+RDEPEND="dev-ruby/rmagick"
+
+ruby_add_bdepend test "dev-ruby/tidy_table dev-ruby/dust"
+
+each_ruby_test() {
+ ${RUBY} -I. test/test_all.rb || die
+}