summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/guile-lzlib/guile-lzlib-0.0.2-r2.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/dev-scheme/guile-lzlib/guile-lzlib-0.0.2-r2.ebuild b/dev-scheme/guile-lzlib/guile-lzlib-0.0.2-r2.ebuild
deleted file mode 100644
index 228c3c646d40..000000000000
--- a/dev-scheme/guile-lzlib/guile-lzlib-0.0.2-r2.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools
-
-DESCRIPTION="GNU Guile library providing bindings to lzlib"
-HOMEPAGE="https://notabug.org/guile-lzlib/guile-lzlib/"
-
-if [[ "${PV}" == *9999* ]] ; then
- inherit git-r3
-
- EGIT_REPO_URI="https://notabug.org/${PN}/${PN}.git"
-else
- SRC_URI="https://notabug.org/${PN}/${PN}/archive/${PV}.tar.gz
- -> ${P}.tar.gz"
- S="${WORKDIR}/${PN}"
-
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-3+"
-SLOT="0"
-
-RDEPEND="
- >=dev-scheme/guile-2.0.0:=
- app-arch/lzlib
-"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="
- virtual/pkgconfig
-"
-
-DOCS=( AUTHORS ChangeLog HACKING NEWS README.org )
-
-# guile generates ELF files without use of C or machine code
-# It's a portage's false positive. bug #677600
-QA_PREBUILT='*[.]go'
-
-src_prepare() {
- default
- eautoreconf
-
- # http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
- find "${S}" -name "*.scm" -exec touch {} + || die
-}
-
-src_install() {
- default
-
- # Workaround llvm-strip problem of mangling guile ELF debug
- # sections: https://bugs.gentoo.org/905898
- dostrip -x "/usr/$(get_libdir)/guile"
-}