summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/ddd/ddd-3.3.12-r4.ebuild')
-rw-r--r--dev-util/ddd/ddd-3.3.12-r4.ebuild18
1 files changed, 7 insertions, 11 deletions
diff --git a/dev-util/ddd/ddd-3.3.12-r4.ebuild b/dev-util/ddd/ddd-3.3.12-r4.ebuild
index 8ca2724f7f5d..b0279808edf4 100644
--- a/dev-util/ddd/ddd-3.3.12-r4.ebuild
+++ b/dev-util/ddd/ddd-3.3.12-r4.ebuild
@@ -3,7 +3,7 @@
EAPI="6"
-inherit autotools eutils
+inherit autotools eutils optfeature
DESCRIPTION="Graphical front-end for command-line debuggers"
HOMEPAGE="https://www.gnu.org/software/ddd"
@@ -74,19 +74,15 @@ src_install() {
}
pkg_postinst() {
- if ! has_version sci-visualization/gnuplot; then
- echo
- elog "To enable data visualization in DDD, install sci-visualization/gnuplot."
- fi
+ optfeature "Data visualisation" sci-visualization/gnuplot
+ optfeature "Java debugging" virtual/jdk
+ optfeature "Bash debugging" app-shells/bashdb
+ optfeature "Perl debugging" dev-lang/perl
+ optfeature "Python debugging" dev-python/pydb
+
echo
elog "Important notice: if you encounter DDD crashes during visualization, you might"
elog "have hit bug #459324. Try switching to plotting in external window:"
elog "Select Edit|Preferences|Helpers and switch 'plot window' to 'external'"
- elog
- elog "To be able to debug java, bash, perl or python scripts within DDD, install respectively:"
- elog " virtual/jdk"
- elog " app-shells/bashdb"
- elog " dev-lang/perl"
- elog " dev-python/pydb"
echo
}