summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/hg-fast-export/hg-fast-export-20140328.ebuild')
-rw-r--r--dev-vcs/hg-fast-export/hg-fast-export-20140328.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-vcs/hg-fast-export/hg-fast-export-20140328.ebuild b/dev-vcs/hg-fast-export/hg-fast-export-20140328.ebuild
new file mode 100644
index 000000000000..d773433d5955
--- /dev/null
+++ b/dev-vcs/hg-fast-export/hg-fast-export-20140328.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1 vcs-snapshot
+
+COMMIT="779e2f6da887729fc513f5efceaa3a3083858c9b"
+DESCRIPTION="mercurial to git converter using git-fast-import"
+HOMEPAGE="https://github.com/frej/fast-export"
+SRC_URI="${HOMEPAGE}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-vcs/git
+ dev-vcs/mercurial
+ ${PYTHON_DEPS}"
+
+src_prepare() {
+ sed -e '/^PYTHON/s/python/&2/' \
+ -e 's/PYTHON/E&/g' \
+ -i "${PN}".sh || die
+ rm Makefile || die #don't compile old svn2git code
+}
+
+src_install() {
+ newbin "${PN}".sh "${PN}"
+ python_foreach_impl python_doexe "${PN}".py
+ python_foreach_impl python_domodule hg2git.py
+}