summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/blobby/blobby-1.0.ebuild')
-rw-r--r--games-arcade/blobby/blobby-1.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-arcade/blobby/blobby-1.0.ebuild b/games-arcade/blobby/blobby-1.0.ebuild
new file mode 100644
index 000000000000..bbc43bc519a9
--- /dev/null
+++ b/games-arcade/blobby/blobby-1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils cmake-utils
+
+DESCRIPTION="A beach ball game with blobs of goo"
+HOMEPAGE="https://sourceforge.net/projects/blobby/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}2-linux-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-games/physfs-2[zip]
+ media-libs/libsdl[sound,joystick,opengl,video,X]
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ virtual/pkgconfig
+ app-arch/zip" #406667
+
+DOCS=( AUTHORS ChangeLog README TODO )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-compile.patch
+ "${FILESDIR}"/${P}-paths.patch
+ "${FILESDIR}"/${P}-install.patch
+)
+
+src_install() {
+ cmake-utils_src_install
+
+ newicon data/Icon.bmp ${PN}.bmp
+ make_desktop_entry ${PN} "Blobby Volley" /usr/share/pixmaps/${PN}.bmp
+}