summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-wm/hyprland/hyprland-0.42.0-r2.ebuild')
-rw-r--r--gui-wm/hyprland/hyprland-0.42.0-r2.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/gui-wm/hyprland/hyprland-0.42.0-r2.ebuild b/gui-wm/hyprland/hyprland-0.42.0-r2.ebuild
index 80b20b8987e8..d5bca569354e 100644
--- a/gui-wm/hyprland/hyprland-0.42.0-r2.ebuild
+++ b/gui-wm/hyprland/hyprland-0.42.0-r2.ebuild
@@ -62,7 +62,7 @@ DEPEND="
>=gui-libs/hyprutils-0.2.1
"
BDEPEND="
- || ( >=sys-devel/gcc-13:* >=sys-devel/clang-16:* )
+ || ( >=sys-devel/gcc-13:* >=llvm-core/clang-16:* )
app-misc/jq
dev-build/cmake
>=dev-util/hyprwayland-scanner-0.3.8
@@ -81,8 +81,8 @@ pkg_setup() {
eerror "Please upgrade GCC: emerge -v1 sys-devel/gcc"
die "GCC version is too old to compile Hyprland!"
elif tc-is-clang && ver_test $(clang-version) -lt 16 ; then
- eerror "Hyprland requires >=sys-devel/clang-16 to build"
- eerror "Please upgrade Clang: emerge -v1 sys-devel/clang"
+ eerror "Hyprland requires >=llvm-core/clang-16 to build"
+ eerror "Please upgrade Clang: emerge -v1 llvm-core/clang"
die "Clang version is too old to compile Hyprland!"
fi
}