summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/cthumb/cthumb-4.2.ebuild')
-rw-r--r--media-gfx/cthumb/cthumb-4.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-gfx/cthumb/cthumb-4.2.ebuild b/media-gfx/cthumb/cthumb-4.2.ebuild
new file mode 100644
index 000000000000..9c2fcdd4a633
--- /dev/null
+++ b/media-gfx/cthumb/cthumb-4.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Create a statical HTML Image gallery with captions for each image"
+
+HOMEPAGE="http://cthumb.sourceforge.net"
+SRC_URI="mirror://sourceforge/cthumb/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha ~amd64 ppc ~sparc x86"
+IUSE=""
+
+DEPEND="dev-perl/URI
+ dev-perl/HTML-Parser
+ media-libs/netpbm"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+}