summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libmediaart')
-rw-r--r--media-libs/libmediaart/Manifest3
-rw-r--r--media-libs/libmediaart/files/libmediaart-0.7.0-qt5.patch47
-rw-r--r--media-libs/libmediaart/libmediaart-0.4.0.ebuild60
-rw-r--r--media-libs/libmediaart/libmediaart-0.7.0.ebuild64
-rw-r--r--media-libs/libmediaart/libmediaart-1.9.0.ebuild80
-rw-r--r--media-libs/libmediaart/metadata.xml8
6 files changed, 262 insertions, 0 deletions
diff --git a/media-libs/libmediaart/Manifest b/media-libs/libmediaart/Manifest
new file mode 100644
index 000000000000..704e638996cd
--- /dev/null
+++ b/media-libs/libmediaart/Manifest
@@ -0,0 +1,3 @@
+DIST libmediaart-0.4.0.tar.xz 270220 SHA256 e8ec92a642f4df7f988364f6451adf89e1611d7379a636d8c7eff4ca21a0fd1c SHA512 7d3870b47f53a52597126a2f691b89eca9800bb82d7723601756fae57ba32b348b10135ffbabe1922de5dd4400fd41d69eac923d3df0de744a3a600c84dd46c7 WHIRLPOOL 59102f907d0702cd5ddc580b3d2878138bac82a5bfda4a3e30eee6ea8f2cfe36d2278a1158e586a11d9e72689429018229069632d5108168e0b902b2ccadf932
+DIST libmediaart-0.7.0.tar.xz 5811244 SHA256 3a9dffcad862aed7c0921579b93080d694b8a66f3676bfee8037867f653a1cd3 SHA512 94ca38ca2ec2bdd7f3a6f39c7f658053d8c46caba8bad97d004663da027c0308a305ce791b33af3d07e3fe8647a967b1ee1c6f808bbe1b4839844aa10cb0891a WHIRLPOOL 781237cff0511b937408f8f3cf72b336c32b84ec38f08d598e2eba56c89ce2b76deafb8705d41e5bc73f2f39833966dbd67f62bcb28e67108499d6d1bb72897b
+DIST libmediaart-1.9.0.tar.xz 5814844 SHA256 94668adb29d4dc3115b0fd105942ebd5ca6f5f9dbb2afa8a191a73a747dd506f SHA512 fcfdad1d62710a39ea21daf23b13eb0b6d64a521f359153bb79247bae8e91fde3d879f807ed2528f3476425f5214cae755b117b4d06d78ee3af41bcc9a3b3ab4 WHIRLPOOL a78cf905853873d5f778b7ae157b2b260a55e3b07ff59d93fa7f95efb53f2b2adb918bb1a5eecc8a66e6d59ee172e9dea04bbadca4bdc20766d710127b1fef79
diff --git a/media-libs/libmediaart/files/libmediaart-0.7.0-qt5.patch b/media-libs/libmediaart/files/libmediaart-0.7.0-qt5.patch
new file mode 100644
index 000000000000..ecf9de908cfd
--- /dev/null
+++ b/media-libs/libmediaart/files/libmediaart-0.7.0-qt5.patch
@@ -0,0 +1,47 @@
+Solves automagic selection of Qt version.
+
+https://bugs.gentoo.org/show_bug.cgi?id=523122
+https://bugzilla.gnome.org/show_bug.cgi?id=737174
+
+diff --git a/configure.ac b/configure.ac
+index e9ead09..3ee710a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -206,6 +206,10 @@ AC_ARG_ENABLE(qt,
+ AS_HELP_STRING([--enable-qt],
+ [enable Qt support, (MP3 album art) [[default=auto]]]),,
+ [enable_qt=auto])
++AC_ARG_WITH(qt-version,
++ AS_HELP_STRING([--with-qt-version=major],
++ [Force specific Qt version [[default=auto]]]),,
++ [with_qt_version=auto])
+
+ selected_for_media_art="no (disabled)"
+
+@@ -218,14 +222,18 @@ if test "x$enable_qt" == "xyes" && test "x$enable_gdkpixbuf" == "xyes"; then
+ fi
+
+ if test "x$enable_qt" != "xno" && test "x$enable_gdkpixbuf" != "xyes"; then
+- PKG_CHECK_MODULES(QT5,
+- [Qt5Gui >= $QT5_REQUIRED],
+- [have_qt5=yes],
+- [have_qt5=no])
+- PKG_CHECK_MODULES(QT4,
+- [QtGui >= $QT4_REQUIRED],
+- [have_qt4=yes],
+- [have_qt4=no])
++ if test "x$with_qt_version" == "xauto" || test "x$with_qt_version" == "x5"; then
++ PKG_CHECK_MODULES(QT5,
++ [Qt5Gui >= $QT5_REQUIRED],
++ [have_qt5=yes],
++ [have_qt5=no])
++ fi
++ if test "x$with_qt_version" == "xauto" || test "x$with_qt_version" == "x4"; then
++ PKG_CHECK_MODULES(QT4,
++ [QtGui >= $QT4_REQUIRED],
++ [have_qt4=yes],
++ [have_qt4=no])
++ fi
+
+ if test "x$have_qt5" = "xyes"; then
+ BACKEND_CFLAGS="$QT5_CFLAGS -fPIC"
diff --git a/media-libs/libmediaart/libmediaart-0.4.0.ebuild b/media-libs/libmediaart/libmediaart-0.4.0.ebuild
new file mode 100644
index 000000000000..3000d0485b97
--- /dev/null
+++ b/media-libs/libmediaart/libmediaart-0.4.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_USE_DEPEND="vapigen"
+VALA_MIN_API_VERSION="0.16"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="Manages, extracts and handles media art caches"
+HOMEPAGE="https://github.com/curlybeast/libmediaart"
+
+LICENSE="LGPL-2.1+"
+SLOT="1.0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
+IUSE="gtk +introspection qt4 qt5 vala"
+REQUIRED_USE="
+ ?? ( gtk qt4 qt5 )
+ vala? ( introspection )
+"
+
+RDEPEND="
+ >=dev-libs/glib-2.35.1:2
+ gtk? ( >=x11-libs/gdk-pixbuf-2.12:2 )
+ introspection? ( >=dev-libs/gobject-introspection-1.30 )
+ qt4? ( dev-qt/qtgui:4 )
+ qt5? ( dev-qt/qtgui:5 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local myconf=""
+ if use qt4 -o use qt5 ; then
+ myconf="${myconf} --enable-qt"
+ else
+ myconf="${myconf} --disable-qt"
+ fi
+
+ gnome2_src_configure \
+ --enable-unit-tests \
+ $(use_enable gtk gdkpixbuf) \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ ${myconf}
+}
+
+src_test() {
+ dbus-launch Xemake check #513502
+}
diff --git a/media-libs/libmediaart/libmediaart-0.7.0.ebuild b/media-libs/libmediaart/libmediaart-0.7.0.ebuild
new file mode 100644
index 000000000000..1cc7ae1e5c8f
--- /dev/null
+++ b/media-libs/libmediaart/libmediaart-0.7.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_USE_DEPEND="vapigen"
+VALA_MIN_API_VERSION="0.16"
+
+inherit autotools gnome2 vala virtualx
+
+DESCRIPTION="Manages, extracts and handles media art caches"
+HOMEPAGE="https://github.com/GNOME/libmediaart"
+
+LICENSE="LGPL-2.1+"
+SLOT="1.0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
+IUSE="gtk +introspection qt4 qt5 vala"
+REQUIRED_USE="
+ ?? ( gtk qt4 qt5 )
+ vala? ( introspection )
+"
+
+RDEPEND="
+ >=dev-libs/glib-2.38.0:2
+ gtk? ( >=x11-libs/gdk-pixbuf-2.12:2 )
+ introspection? ( >=dev-libs/gobject-introspection-1.30 )
+ qt4? ( dev-qt/qtgui:4 )
+ qt5? ( dev-qt/qtgui:5 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ epatch "${FILESDIR}/${P}-qt5.patch" #523122
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local myconf=""
+ if use qt4 ; then
+ myconf="${myconf} --enable-qt --with-qt-version=4"
+ elif use qt5 ; then
+ myconf="${myconf} --enable-qt --with-qt-version=5"
+ else
+ myconf="${myconf} --disable-qt"
+ fi
+
+ gnome2_src_configure \
+ --enable-unit-tests \
+ $(use_enable gtk gdkpixbuf) \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ ${myconf}
+}
+
+src_test() {
+ dbus-launch Xemake check #513502
+}
diff --git a/media-libs/libmediaart/libmediaart-1.9.0.ebuild b/media-libs/libmediaart/libmediaart-1.9.0.ebuild
new file mode 100644
index 000000000000..3a6ffe2e4e4d
--- /dev/null
+++ b/media-libs/libmediaart/libmediaart-1.9.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_USE_DEPEND="vapigen"
+VALA_MIN_API_VERSION="0.16"
+
+inherit autotools eutils gnome2 vala virtualx
+
+DESCRIPTION="Manages, extracts and handles media art caches"
+HOMEPAGE="https://github.com/GNOME/libmediaart"
+
+LICENSE="LGPL-2.1+"
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gtk +introspection qt4 qt5 vala"
+REQUIRED_USE="
+ ?? ( gtk qt4 qt5 )
+ vala? ( introspection )
+"
+
+RDEPEND="
+ >=dev-libs/glib-2.38.0:2
+ gtk? ( >=x11-libs/gdk-pixbuf-2.12:2 )
+ introspection? ( >=dev-libs/gobject-introspection-1.30 )
+ qt4? ( dev-qt/qtgui:4 )
+ qt5? ( dev-qt/qtgui:5 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ # Fix QT automagic selection, bug #523122
+ epatch "${FILESDIR}"/${PN}-0.7.0-qt5.patch
+
+ # Make doc parallel installable
+ cd "${S}"/docs/reference/${PN}
+ sed -e "s/\(DOC_MODULE.*=\).*/\1${PN}-${SLOT}/" \
+ -e "s/\(DOC_MAIN_SGML_FILE.*=\).*/\1${PN}-docs-${SLOT}.sgml/" \
+ -i Makefile.am Makefile.in || die
+ sed -e "s/\(<book.*name=\"\)libmediaart/\1${PN}-${SLOT}/" \
+ -i html/libmediaart.devhelp2 || die
+ mv libmediaart-docs{,-${SLOT}}.sgml || die
+ mv libmediaart-overrides{,-${SLOT}}.txt || die
+ mv libmediaart-sections{,-${SLOT}}.txt || die
+ mv html/libmediaart{,-${SLOT}}.devhelp2
+ cd "${S}"
+
+ eautoreconf
+
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local myconf=""
+ if use qt4 ; then
+ myconf="${myconf} --enable-qt --with-qt-version=4"
+ elif use qt5 ; then
+ myconf="${myconf} --enable-qt --with-qt-version=5"
+ else
+ myconf="${myconf} --disable-qt"
+ fi
+
+ gnome2_src_configure \
+ --enable-unit-tests \
+ $(use_enable gtk gdkpixbuf) \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ ${myconf}
+}
+
+src_test() {
+ dbus-launch Xemake check #513502
+}
diff --git a/media-libs/libmediaart/metadata.xml b/media-libs/libmediaart/metadata.xml
new file mode 100644
index 000000000000..defff19a494b
--- /dev/null
+++ b/media-libs/libmediaart/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <upstream>
+ <remote-id type="github">GNOME/libmediaart</remote-id>
+ </upstream>
+</pkgmetadata>