summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libogg')
-rw-r--r--media-libs/libogg/Manifest3
-rw-r--r--media-libs/libogg/libogg-1.3.0.ebuild26
-rw-r--r--media-libs/libogg/libogg-1.3.1.ebuild32
-rw-r--r--media-libs/libogg/libogg-1.3.2.ebuild32
-rw-r--r--media-libs/libogg/metadata.xml5
5 files changed, 98 insertions, 0 deletions
diff --git a/media-libs/libogg/Manifest b/media-libs/libogg/Manifest
new file mode 100644
index 000000000000..76e51cd90d21
--- /dev/null
+++ b/media-libs/libogg/Manifest
@@ -0,0 +1,3 @@
+DIST libogg-1.3.0.tar.xz 289384 SHA256 231725029c843492914f24e74085e734bca6f1d6446ac72df39b0c3a9d4bc74b SHA512 d99f7285d1d92940e5e82778f208afe615ff44384b373d81186a57a77d57a8c7f5e3347ea9ad99dc87cd6091e41ed8f47f0c3277e6a113dbb157c6aa6dd0f357 WHIRLPOOL 75954c92b475686f23d3da9d2970f04271865c2617a53e4e0f38336991bcc0a8171ed394b48048b4bf91aff85951381a7360ffb0509158788688666c395a3c6b
+DIST libogg-1.3.1.tar.xz 406840 SHA256 3a5bad78d81afb78908326d11761c0fb1a0662ee7150b6ad587cc586838cdcfa SHA512 980d8916b5d6bf22376105869a9b9d5312cee81f0ff1f6aa9f34359e92a93b7b34555a4c4f124922d87ef7e48a4b9451e35d9b536929b9144fcc22bcf6debbf0 WHIRLPOOL 474dd64231cfe39198a90a3c06ce2075e31fe2eaa72bf924586e34fbd505c3b21e1c57c86f12bc9a2e30f2a124665487592174ca5ffc63e01fd9f65dafff94fa
+DIST libogg-1.3.2.tar.xz 407324 SHA256 3f687ccdd5ac8b52d76328fbbfebc70c459a40ea891dbf3dccb74a210826e79b SHA512 dc9552b15ceccd7e12bff39a6670120ae53af74ce97254d047c28f49ba6a320f55059ed509ec1d8758a972c72514f2866634d829f3cb528c2f595cb056e9bca6 WHIRLPOOL 9ba9408aaac9f1207543383ccc90868c7122bef7137421e84e46eb590c09cb832ec0a18a8aa75258d94529733ae413c472db50d5f1b78a08ded198b26b8748a6
diff --git a/media-libs/libogg/libogg-1.3.0.ebuild b/media-libs/libogg/libogg-1.3.0.ebuild
new file mode 100644
index 000000000000..ffc036d08693
--- /dev/null
+++ b/media-libs/libogg/libogg-1.3.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="the Ogg media file format library"
+HOMEPAGE="http://xiph.org/ogg/"
+SRC_URI="http://downloads.xiph.org/releases/ogg/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ # docdir, http://trac.xiph.org/ticket/1758
+ emake DESTDIR="${D}" docdir=/usr/share/doc/${PF}/ogg install
+ dodoc AUTHORS CHANGES
+ prune_libtool_files --all
+}
diff --git a/media-libs/libogg/libogg-1.3.1.ebuild b/media-libs/libogg/libogg-1.3.1.ebuild
new file mode 100644
index 000000000000..8278d7b43e0b
--- /dev/null
+++ b/media-libs/libogg/libogg-1.3.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools-multilib
+
+DESCRIPTION="the Ogg media file format library"
+HOMEPAGE="http://xiph.org/ogg/"
+SRC_URI="http://downloads.xiph.org/releases/ogg/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND="
+ abi_x86_32? ( !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )"
+
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+DOCS=( AUTHORS CHANGES )
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/ogg/config_types.h
+)
+
+src_configure() {
+ local myeconfargs=(
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+ autotools-multilib_src_configure
+}
diff --git a/media-libs/libogg/libogg-1.3.2.ebuild b/media-libs/libogg/libogg-1.3.2.ebuild
new file mode 100644
index 000000000000..91c822cdbc67
--- /dev/null
+++ b/media-libs/libogg/libogg-1.3.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools-multilib
+
+DESCRIPTION="the Ogg media file format library"
+HOMEPAGE="http://xiph.org/ogg/"
+SRC_URI="http://downloads.xiph.org/releases/ogg/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND="
+ abi_x86_32? ( !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )"
+
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+DOCS=( AUTHORS CHANGES )
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/ogg/config_types.h
+)
+
+src_configure() {
+ local myeconfargs=(
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+ autotools-multilib_src_configure
+}
diff --git a/media-libs/libogg/metadata.xml b/media-libs/libogg/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-libs/libogg/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>