summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/mesa/mesa-24.2.5-r1.ebuild')
-rw-r--r--media-libs/mesa/mesa-24.2.5-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/media-libs/mesa/mesa-24.2.5-r1.ebuild b/media-libs/mesa/mesa-24.2.5-r1.ebuild
index 5c33234f9ba3..c3075d910f97 100644
--- a/media-libs/mesa/mesa-24.2.5-r1.ebuild
+++ b/media-libs/mesa/mesa-24.2.5-r1.ebuild
@@ -98,7 +98,7 @@ RDEPEND="
unwind? ( sys-libs/libunwind[${MULTILIB_USEDEP}] )
llvm? (
$(llvm_gen_dep "
- sys-devel/llvm:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
+ llvm-core/llvm:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
opencl? (
dev-util/spirv-llvm-translator:\${LLVM_SLOT}
llvm-core/clang:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
@@ -277,8 +277,8 @@ python_check_deps() {
pkg_setup() {
# warning message for bug 459306
- if use llvm && has_version sys-devel/llvm[!debug=]; then
- ewarn "Mismatch between debug USE flags in media-libs/mesa and sys-devel/llvm"
+ if use llvm && has_version llvm-core/llvm[!debug=]; then
+ ewarn "Mismatch between debug USE flags in media-libs/mesa and llvm-core/llvm"
ewarn "detected! This can cause problems. For details, see bug 459306."
fi