summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/simage/simage-1.7.0-r1.ebuild7
-rw-r--r--media-libs/simage/simage-1.7.1a_beta_pre20180312.ebuild7
2 files changed, 6 insertions, 8 deletions
diff --git a/media-libs/simage/simage-1.7.0-r1.ebuild b/media-libs/simage/simage-1.7.0-r1.ebuild
index 88bffba3a7b5..f491e59cb38b 100644
--- a/media-libs/simage/simage-1.7.0-r1.ebuild
+++ b/media-libs/simage/simage-1.7.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -10,13 +10,12 @@ SRC_URI="https://bitbucket.org/Coin3D/coin/downloads/${P}.tar.gz"
LICENSE="public-domain mpeg2enc"
KEYWORDS="amd64 ~arm ~hppa ~ia64 ppc ppc64 ~sparc x86"
SLOT="0"
-IUSE="debug gif jpeg jpeg2k png sndfile static-libs tiff vorbis zlib"
+IUSE="debug gif jpeg png sndfile static-libs tiff vorbis zlib"
RESTRICT="mirror bindist" #465086
RDEPEND="
gif? ( media-libs/giflib )
jpeg? ( virtual/jpeg:0= )
- jpeg2k? ( media-libs/jasper )
png? ( media-libs/libpng:0= )
sndfile? ( media-libs/libsndfile )
tiff? ( media-libs/tiff:0= )
@@ -54,7 +53,7 @@ src_configure() {
$(use_enable debug) \
$(use_enable debug symbols) \
$(use_with jpeg) \
- $(use_with jpeg2k jasper) \
+ --without-jasper \
$(use_with png) \
$(use_with sndfile libsndfile) \
$(use_enable static-libs static) \
diff --git a/media-libs/simage/simage-1.7.1a_beta_pre20180312.ebuild b/media-libs/simage/simage-1.7.1a_beta_pre20180312.ebuild
index 01635618aef0..4ced5ba29613 100644
--- a/media-libs/simage/simage-1.7.1a_beta_pre20180312.ebuild
+++ b/media-libs/simage/simage-1.7.1a_beta_pre20180312.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -14,12 +14,11 @@ SRC_URI="https://dev.gentoo.org/~reavertm/${MY_P}.tar.bz2"
LICENSE="public-domain mpeg2enc"
KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
SLOT="0"
-IUSE="debug gif jpeg jpeg2k png qt5 sndfile tiff vorbis"
+IUSE="debug gif jpeg png qt5 sndfile tiff vorbis"
RDEPEND="
gif? ( media-libs/giflib )
jpeg? ( virtual/jpeg:0= )
- jpeg2k? ( media-libs/jasper )
png? ( media-libs/libpng:0= )
qt5? (
dev-qt/qtcore:5
@@ -52,7 +51,7 @@ src_configure() {
-DSIMAGE_EPS_SUPPORT=ON
-DSIMAGE_GDIPLUS_SUPPORT=OFF # Windows only
-DSIMAGE_GIF_SUPPORT=$(usex gif)
- -DSIMAGE_JASPER_SUPPORT=$(usex jpeg2k)
+ -DSIMAGE_JASPER_SUPPORT=OFF
-DSIMAGE_JPEG_SUPPORT=$(usex jpeg)
-DSIMAGE_LIBSNDFILE_SUPPORT=$(usex sndfile)
-DSIMAGE_MPEG2ENC_SUPPORT=ON