summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libnids/libnids-1.24-r6.ebuild')
-rw-r--r--net-libs/libnids/libnids-1.24-r6.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/net-libs/libnids/libnids-1.24-r6.ebuild b/net-libs/libnids/libnids-1.24-r6.ebuild
deleted file mode 100644
index d4a4fe94a92d..000000000000
--- a/net-libs/libnids/libnids-1.24-r6.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="an implementation of an E-component of Network Intrusion Detection System"
-HOMEPAGE="http://libnids.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="1.2"
-KEYWORDS="amd64 ppc x86"
-IUSE="+glib +libnet static-libs"
-
-RDEPEND="
- !net-libs/libnids:1.1
- glib? ( dev-libs/glib:2 )
- libnet? ( >=net-libs/libnet-1.1.0-r3 )
- net-libs/libpcap
-"
-DEPEND="
- ${RDEPEND}
- glib? ( virtual/pkgconfig )
-"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-ldflags.patch"
- epatch "${FILESDIR}/${P}-static-libs.patch"
-}
-
-src_configure() {
- tc-export AR
- append-flags -fno-strict-aliasing
-
- econf \
- --enable-shared \
- $(usex glib '' --disable-libglib) \
- $(use_enable libnet)
-}
-
-src_compile() {
- emake shared $(usex static-libs static '')
-}
-
-src_install() {
- local tgt
- for tgt in _installshared $(usex static-libs _install ''); do
- emake install_prefix="${D}" ${tgt}
- done
-
- dodoc CHANGES CREDITS MISC README doc/*
-}