summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/rsync/rsync-9999.ebuild')
-rw-r--r--net-misc/rsync/rsync-9999.ebuild11
1 files changed, 3 insertions, 8 deletions
diff --git a/net-misc/rsync/rsync-9999.ebuild b/net-misc/rsync/rsync-9999.ebuild
index 0e776b6ee27c..370fd32ffd2b 100644
--- a/net-misc/rsync/rsync-9999.ebuild
+++ b/net-misc/rsync/rsync-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit prefix systemd
+inherit prefix systemd toolchain-funcs
DESCRIPTION="File transfer program to keep remote files into sync"
HOMEPAGE="https://rsync.samba.org/"
@@ -24,9 +24,7 @@ fi
LICENSE="GPL-3"
SLOT="0"
-IUSE_CPU_FLAGS_X86=" sse2"
IUSE="acl examples iconv ipv6 libressl lz4 ssl stunnel system-zlib xattr xxhash zstd"
-IUSE+=" ${IUSE_CPU_FLAGS_X86// / cpu_flags_x86_}"
RDEPEND="acl? ( virtual/acl )
lz4? ( app-arch/lz4 )
@@ -78,11 +76,8 @@ src_configure() {
$(use_enable zstd)
)
- if use elibc_glibc && [[ "${ARCH}" == "amd64" ]] ; then
- # SIMD is only available for x86_64 right now
- # and only on glibc (#728868)
- myeconfargs+=( $(use_enable cpu_flags_x86_sse2 simd) )
- else
+ if tc-is-cross-compiler; then
+ # configure check is broken when cross-compiling.
myeconfargs+=( --disable-simd )
fi