summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/amap')
-rw-r--r--sci-biology/amap/amap-2.2-r5.ebuild (renamed from sci-biology/amap/amap-2.2-r4.ebuild)19
-rw-r--r--sci-biology/amap/files/amap-2.2-makefile.patch23
2 files changed, 21 insertions, 21 deletions
diff --git a/sci-biology/amap/amap-2.2-r4.ebuild b/sci-biology/amap/amap-2.2-r5.ebuild
index df3b16efba30..949749969c27 100644
--- a/sci-biology/amap/amap-2.2-r4.ebuild
+++ b/sci-biology/amap/amap-2.2-r5.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit java-pkg-opt-2 java-ant-2 toolchain-funcs
@@ -10,6 +10,7 @@ MY_P=${PN}.${PV}
DESCRIPTION="Protein multiple-alignment-based sequence annealing"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
SRC_URI="http://baboon.math.berkeley.edu/${PN}/download/${MY_P}.tar.gz"
+S="${WORKDIR}/${PN}-align"
LICENSE="GPL-2"
SLOT="0"
@@ -17,9 +18,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="java"
RDEPEND="java? ( >=virtual/jre-1.8:* )"
-DEPEND="java? ( >=virtual/jdk-1.8:* )"
-
-S=${WORKDIR}/${PN}-align
+BDEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-makefile.patch
@@ -31,8 +30,12 @@ src_prepare() {
java-pkg-opt-2_src_prepare
}
+src_configure() {
+ tc-export CXX
+}
+
src_compile() {
- emake -C align CXX="$(tc-getCXX)" OPT_CXXFLAGS="${CXXFLAGS}"
+ emake -C align
if use java; then
pushd display >/dev/null || die
@@ -46,8 +49,8 @@ src_install() {
dodoc align/{README,PROBCONS.README}
- insinto /usr/share/${PN}/examples
- doins -r examples/.
+ insinto /usr/share/${PN}
+ doins -r examples
if use java; then
java-pkg_newjar display/AmapDisplay.jar amapdisplay.jar
diff --git a/sci-biology/amap/files/amap-2.2-makefile.patch b/sci-biology/amap/files/amap-2.2-makefile.patch
index 5a9841c98255..3749fa58682c 100644
--- a/sci-biology/amap/files/amap-2.2-makefile.patch
+++ b/sci-biology/amap/files/amap-2.2-makefile.patch
@@ -2,28 +2,25 @@ Respect {CXX,LD}FLAGS
http://bugs.gentoo.org/332009
---- amap-align/align/Makefile
-+++ amap-align/align/Makefile
-@@ -15,6 +15,8 @@
- # c) RELEASE mode
+--- a/align/Makefile
++++ b/align/Makefile
+@@ -6,7 +6,6 @@
+ # 1) Choose C++ compiler.
################################################################################
-+OPT_CXXFLAGS = -O3 -W -Wall -pedantic -funroll-loops
-+
- OTHERFLAGS = -DNumInsertStates=1 -DVERSION='"AMAP.2.2"'
+-CXX = g++
- # debug mode
-@@ -26,8 +28,7 @@
+ ################################################################################
+ # 2) Set C++ flags.
+@@ -26,7 +25,7 @@
# release mode
#CXXFLAGS = -O3 -W -Wall -pedantic -DNDEBUG $(OTHERFLAGS) -mmmx -msse -msse2 -mfpmath=sse -march=pentium4 -mcpu=pentium4 -funroll-loops -fomit-frame-pointer
-CXXFLAGS = -O3 -W -Wall -pedantic -DNDEBUG $(OTHERFLAGS) -funroll-loops
--
-+CXXFLAGS = $(OPT_CXXFLAGS) -DNDEBUG $(OTHERFLAGS)
++CXXFLAGS += -W -Wall -pedantic -DNDEBUG $(OTHERFLAGS)
+
################################################################################
# 3) Dependencies
- ################################################################################
-
@@ -38,7 +37,7 @@
all : $(TARGETS)