summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/transfac/transfac-3.2-r1.ebuild (renamed from sci-biology/transfac/transfac-3.2.ebuild)27
1 files changed, 15 insertions, 12 deletions
diff --git a/sci-biology/transfac/transfac-3.2.ebuild b/sci-biology/transfac/transfac-3.2-r1.ebuild
index 9b6e76ce877b..7c98be79edae 100644
--- a/sci-biology/transfac/transfac-3.2.ebuild
+++ b/sci-biology/transfac/transfac-3.2-r1.ebuild
@@ -2,40 +2,43 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
+EAPI=6
+
DESCRIPTION="A database of eucaryotic transcription factors"
HOMEPAGE="http://www.gene-regulation.com/pub/databases.html"
SRC_URI="ftp://ftp.ebi.ac.uk/pub/databases/${PN}/${PN}32.tar.Z"
-LICENSE="public-domain"
+LICENSE="public-domain"
SLOT="3"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="emboss minimal"
# Minimal build keeps only the indexed files (if applicable) and the documentation.
# The non-indexed database is not installed.
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="emboss minimal"
DEPEND="emboss? ( sci-biology/emboss )"
-
RDEPEND="${DEPEND}"
-S="${WORKDIR}"
+S=${WORKDIR}
src_compile() {
if use emboss; then
- echo
- einfo "Indexing TRANSFAC for usage with EMBOSS."
- EMBOSS_DATA=. tfextract -auto -infile class.dat || die \
- "Indexing TRANSFAC failed."
- echo
+ einfo
+ einfo "Indexing TRANSFAC for usage with EMBOSS"
+ EMBOSS_DATA="." tfextract -auto -infile class.dat || die "Indexing TRANSFAC failed"
+ einfo
fi
}
src_install() {
+ newdoc readme.txt README
+
if ! use minimal; then
insinto /usr/share/${PN}-${SLOT}
- doins *.dat || die
+ doins *.dat
fi
+
if use emboss; then
insinto /usr/share/EMBOSS/data
- doins tf* || die
+ doins tf*
fi
}