summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/why3-for-spark/files')
-rw-r--r--sci-mathematics/why3-for-spark/files/why3-for-spark-2023.12.13-flags.patch28
-rw-r--r--sci-mathematics/why3-for-spark/files/why3-for-spark-2023.12.13-spark.patch11
2 files changed, 39 insertions, 0 deletions
diff --git a/sci-mathematics/why3-for-spark/files/why3-for-spark-2023.12.13-flags.patch b/sci-mathematics/why3-for-spark/files/why3-for-spark-2023.12.13-flags.patch
new file mode 100644
index 000000000000..ec8d74745789
--- /dev/null
+++ b/sci-mathematics/why3-for-spark/files/why3-for-spark-2023.12.13-flags.patch
@@ -0,0 +1,28 @@
+--- a/Makefile.in 2020-06-12 21:03:33.375534124 +0200
++++ b/Makefile.in 2020-06-12 21:03:48.623283408 +0200
+@@ -129,7 +129,7 @@
+
+ WARNINGS = A-4-9-41-42-44-45-52@5@8@14@48@50
+
+-FLAGS = -w $(WARNINGS) -safe-string -keep-locs -bin-annot -dtypes -g -thread $(INCLUDES)
++FLAGS = -w $(WARNINGS) -safe-string -keep-locs -bin-annot -dtypes -g -thread $(INCLUDES) -cclib "$(LDFLAGS)" -ccopt "$(CFLAGS)"
+ OFLAGS = $(FLAGS)
+ BFLAGS = $(FLAGS)
+
+@@ -807,13 +807,13 @@
+ all: $(TOOLS)
+
+ lib/why3server$(EXE): $(SERVER_O)
+- $(CC) -Wall -o $@ $^
++ $(CC) -Wall $(CFLAGS) -o $@ $^ $(LDFLAGS)
+
+ lib/why3cpulimit$(EXE): $(CPULIM_O)
+- $(CC) -Wall -o $@ $^
++ $(CC) -Wall $(CFLAGS) -o $@ $^ $(LDFLAGS)
+
+ %.o: %.c
+- $(CC) -Wall -O -g -o $@ -c $<
++ $(CC) -Wall $(CFLAGS) -O -g -o $@ -c $<
+
+ uninstall-bin::
+ rm -f $(LIBDIR)/why3/why3server$(EXE) $(LIBDIR)/why3/why3cpulimit$(EXE)
diff --git a/sci-mathematics/why3-for-spark/files/why3-for-spark-2023.12.13-spark.patch b/sci-mathematics/why3-for-spark/files/why3-for-spark-2023.12.13-spark.patch
new file mode 100644
index 000000000000..e61b8606c5fb
--- /dev/null
+++ b/sci-mathematics/why3-for-spark/files/why3-for-spark-2023.12.13-spark.patch
@@ -0,0 +1,11 @@
+--- a/src/gnat/gnat_util.ml 2025-02-10 23:34:07.591622078 +0100
++++ b/src/gnat/gnat_util.ml 2025-02-10 23:34:21.920445321 +0100
+@@ -41,7 +41,7 @@
+ let why3_prefix =
+ Filename.dirname (Filename.dirname Sys.executable_name)
+ let spark_prefix =
+- Filename.dirname (Filename.dirname why3_prefix)
++ why3_prefix
+
+ let gnatprove_why3conf_file = "why3.conf"
+