summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/sanlock/sanlock-3.8.5.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/sys-cluster/sanlock/sanlock-3.8.5.ebuild b/sys-cluster/sanlock/sanlock-3.8.5.ebuild
index 74db35ff3d2c..1c3de529c26b 100644
--- a/sys-cluster/sanlock/sanlock-3.8.5.ebuild
+++ b/sys-cluster/sanlock/sanlock-3.8.5.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
-inherit linux-info python-r1 systemd
+inherit flag-o-matic linux-info python-r1 systemd
DESCRIPTION="shared storage lock manager"
HOMEPAGE="https://pagure.io/sanlock"
@@ -35,6 +35,11 @@ PATCHES=(
CONFIG_CHECK="~SOFT_WATCHDOG"
src_compile() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/863734
+ # https://pagure.io/sanlock/issue/10
+ filter-lto
+
for d in wdmd src fence_sanlock reset; do
emake -C ${d}
done