summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gdb/gdb-9999.ebuild')
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index 4572453219d5..914409b673aa 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -136,7 +136,7 @@ src_configure() {
if use server && ! use client ; then
# just configure+build in the gdbserver subdir to speed things up
- cd gdb/gdbserver
+ cd gdbserver
myconf+=( --program-transform-name='' )
else
# gdbserver only works for native targets (CHOST==CTARGET).
@@ -189,13 +189,12 @@ src_configure() {
src_install() {
if use server && ! use client; then
- cd gdb/gdbserver || die
+ cd gdbserver || die
fi
default
if use client; then
find "${ED}"/usr -name libiberty.a -delete || die
fi
- cd "${S}" || die
# Delete translations that conflict with binutils-libs. #528088
# Note: Should figure out how to store these in an internal gdb dir.
@@ -220,7 +219,7 @@ src_install() {
# https://sourceware.org/ml/gdb-patches/2011-12/msg00915.html
# Only install if it exists due to the twisted behavior (see
# notes in src_configure above).
- [[ -e gdb/gdbserver/gdbreplay ]] && dobin gdb/gdbserver/gdbreplay
+ [[ -e gdbserver/gdbreplay ]] && dobin gdbserver/gdbreplay
if use client ; then
docinto gdb
@@ -231,7 +230,7 @@ src_install() {
dodoc sim/{ChangeLog,MAINTAINERS,README-HACKING}
if use server ; then
docinto gdbserver
- dodoc gdb/gdbserver/{ChangeLog,README}
+ dodoc gdbserver/{ChangeLog,README}
fi
if [[ -n ${PATCH_VER} ]] ; then