summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/dumb-init/dumb-init-1.2.0.ebuild')
-rw-r--r--sys-process/dumb-init/dumb-init-1.2.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-process/dumb-init/dumb-init-1.2.0.ebuild b/sys-process/dumb-init/dumb-init-1.2.0.ebuild
new file mode 100644
index 000000000000..47da8479f0bd
--- /dev/null
+++ b/sys-process/dumb-init/dumb-init-1.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="A minimal init system for Linux containers"
+HOMEPAGE="https://github.com/Yelp/${PN}"
+SRC_URI="https://github.com/Yelp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static"
+RESTRICT="test"
+
+src_prepare() {
+ eapply_user
+ use static && append-cflags -static
+ sed -e "s|^CFLAGS=.*|CFLAGS=-std=gnu99 ${CFLAGS}|" -i Makefile || die
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README.md
+}