summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/firefox')
-rw-r--r--www-client/firefox/firefox-128.1.0.ebuild2
-rw-r--r--www-client/firefox/firefox-129.0.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/www-client/firefox/firefox-128.1.0.ebuild b/www-client/firefox/firefox-128.1.0.ebuild
index 8ca5d7c119b7..1d88b262baa5 100644
--- a/www-client/firefox/firefox-128.1.0.ebuild
+++ b/www-client/firefox/firefox-128.1.0.ebuild
@@ -637,6 +637,8 @@ src_prepare() {
export RUST_TARGET="i686-unknown-linux-musl"
elif use arm64 ; then
export RUST_TARGET="aarch64-unknown-linux-musl"
+ elif use ppc64 ; then
+ export RUST_TARGET="powerpc64le-unknown-linux-musl"
else
die "Unknown musl chost, please post your rustc -vV along with emerge --info on Gentoo's bug #915651"
fi
diff --git a/www-client/firefox/firefox-129.0.ebuild b/www-client/firefox/firefox-129.0.ebuild
index 8e9069b7db01..57a2736fb5c1 100644
--- a/www-client/firefox/firefox-129.0.ebuild
+++ b/www-client/firefox/firefox-129.0.ebuild
@@ -630,6 +630,8 @@ src_prepare() {
export RUST_TARGET="i686-unknown-linux-musl"
elif use arm64 ; then
export RUST_TARGET="aarch64-unknown-linux-musl"
+ elif use ppc64 ; then
+ export RUST_TARGET="powerpc64le-unknown-linux-musl"
else
die "Unknown musl chost, please post your rustc -vV along with emerge --info on Gentoo's bug #915651"
fi