summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Bainbridge <chrb@gentoo.org>2005-11-22 22:09:34 +0000
committerChris Bainbridge <chrb@gentoo.org>2005-11-22 22:09:34 +0000
commit0319b1a4d970ade8845fcb1b99cf1c93d9e183e3 (patch)
tree22249e57b7aed2be0b60d2311515404fa72739e6
parent2.3.2 version bump (diff)
downloadhistorical-0319b1a4d970ade8845fcb1b99cf1c93d9e183e3.tar.gz
historical-0319b1a4d970ade8845fcb1b99cf1c93d9e183e3.tar.bz2
historical-0319b1a4d970ade8845fcb1b99cf1c93d9e183e3.zip
version bump
Package-Manager: portage-2.0.51.22-r3
-rw-r--r--app-emulation/xen/ChangeLog7
-rw-r--r--app-emulation/xen/Manifest4
-rw-r--r--app-emulation/xen/files/digest-xen-3.0.0_pre200511221
-rw-r--r--app-emulation/xen/xen-3.0.0_pre20051122.ebuild84
4 files changed, 94 insertions, 2 deletions
diff --git a/app-emulation/xen/ChangeLog b/app-emulation/xen/ChangeLog
index e5eb54083918..0f4b7075e6ad 100644
--- a/app-emulation/xen/ChangeLog
+++ b/app-emulation/xen/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/xen
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.12 2005/11/03 19:00:27 chrb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.13 2005/11/22 22:09:34 chrb Exp $
+
+*xen-3.0.0_pre20051122 (22 Nov 2005)
+
+ 22 Nov 2005; <chrb@gentoo.org> +xen-3.0.0_pre20051122.ebuild:
+ version bump
03 Nov 2005; <chrb@gentoo.org> -xen-3.0.0_pre20051010.ebuild,
-xen-3.0.0_pre20051010-r1.ebuild:
diff --git a/app-emulation/xen/Manifest b/app-emulation/xen/Manifest
index 64a9925ab0f6..77842c6fe767 100644
--- a/app-emulation/xen/Manifest
+++ b/app-emulation/xen/Manifest
@@ -1,10 +1,12 @@
-MD5 abb06afbe46ae60b5dbd82de79afcb13 ChangeLog 2305
+MD5 c2904330c51519a138f8b72afb537129 ChangeLog 2423
MD5 23ec60d5040f966fda250a47d8903428 metadata.xml 252
MD5 b25e5ad259e28bab5d8d3b4c0a62d278 xen-2.0.7.ebuild 2853
MD5 3d185e164d3d5963aa0a4e4aea9ec626 xen-3.0.0_pre20051027.ebuild 2029
+MD5 3e8f1dfa962c8806582268ef861d9879 xen-3.0.0_pre20051122.ebuild 2029
MD5 16d372298e94a8eef72c1943b1ed5561 files/xend-conf 347
MD5 b659e1e802207d647698236ddbc2e7a3 files/xend-init 838
MD5 11ef318e35fcfed12931f182fc01955a files/xendomains-conf 180
MD5 f13640a07af78a60cfb562fa1d2088f3 files/xendomains-init 1659
MD5 2e39cb335339f213e3daac1e0ff12598 files/digest-xen-3.0.0_pre20051027 75
+MD5 6bda4cc8b2c6066f4d83b2fd65b4dc53 files/digest-xen-3.0.0_pre20051122 75
MD5 6eaea330ed78459069eb5ba608e654dd files/digest-xen-2.0.7 63
diff --git a/app-emulation/xen/files/digest-xen-3.0.0_pre20051122 b/app-emulation/xen/files/digest-xen-3.0.0_pre20051122
new file mode 100644
index 000000000000..c2a4442a4e5f
--- /dev/null
+++ b/app-emulation/xen/files/digest-xen-3.0.0_pre20051122
@@ -0,0 +1 @@
+MD5 38bf7a5c9aa2c14582b8c5d16612f28d xen-unstable-20051122.tar.bz2 3510661
diff --git a/app-emulation/xen/xen-3.0.0_pre20051122.ebuild b/app-emulation/xen/xen-3.0.0_pre20051122.ebuild
new file mode 100644
index 000000000000..d288062c1443
--- /dev/null
+++ b/app-emulation/xen/xen-3.0.0_pre20051122.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-3.0.0_pre20051122.ebuild,v 1.1 2005/11/22 22:09:34 chrb Exp $
+
+inherit mount-boot
+
+DESCRIPTION="The Xen virtual machine monitor and Xend daemon"
+HOMEPAGE="http://xen.sourceforge.net"
+DATE="20051122"
+SRC_URI="mirror://gentoo/xen-unstable-${DATE}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc debug screen"
+
+DEPEND="sys-apps/iproute2
+ net-misc/bridge-utils
+ dev-lang/python
+ net-misc/curl
+ sys-libs/zlib
+ doc? (
+ dev-tex/latex2html
+ media-gfx/transfig
+ )
+ screen? (
+ app-misc/screen
+ app-admin/logrotate
+ )
+ sys-devel/dev86"
+
+S="${WORKDIR}/xen-unstable-${DATE}"
+
+src_compile() {
+ local myopt
+ if use debug; then
+ myopt="${myopt} debug=y"
+ fi
+
+ unset CFLAGS
+ make ${myopt} -C xen || die "compiling xen failed"
+ make ${myopt} -C tools || die "compiling tools failed"
+
+ if use doc; then
+ sh ./docs/check_pkgs || die "package check failed"
+ make ${myopt} -C docs || die "compiling docs failed"
+ fi
+
+}
+
+src_install() {
+ make DESTDIR=${D} -C xen install || die "installing xen failed"
+
+ make DESTDIR=${D} XEN_PYTHON_NATIVE_INSTALL=1 -C tools install \
+ || die "installing tools failed"
+
+ if use doc; then
+ make DESTDIR=${D} -C docs install \
+ || die "installing docs failed"
+ # Rename doc/xen to the Gentoo-style doc/xen-x.y
+ mv ${D}/usr/share/doc/{${PN},${PF}}
+ fi
+
+ # bind xend to localhost per default
+ sed -i -e "s/\((xend-address *\)'')/\1\'localhost\')/" \
+ ${D}/etc/xen/xend-config.sxp
+
+ newinitd ${FILESDIR}/xend-init xend
+ newconfd ${FILESDIR}/xend-conf xend
+ newconfd ${FILESDIR}/xendomains-conf xendomains
+ newinitd ${FILESDIR}/xendomains-init xendomains
+
+ # for upstream change tracking
+ dodoc ${S}/XEN-VERSION
+
+ if use screen; then
+ sed -i -e 's/SCREEN="no"/SCREEN="yes"/' ${D}/etc/init.d/xendomains
+ fi
+}
+
+pkg_postinst() {
+ einfo "Please visit the Xen and Gentoo wiki:"
+ einfo "http://gentoo-wiki.com/HOWTO_Xen_and_Gentoo"
+}