summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2005-12-16 20:54:31 +0000
committerTony Vroon <chainsaw@gentoo.org>2005-12-16 20:54:31 +0000
commit052685269116de523073571083e5c752ce0aa767 (patch)
treeab41acf9a8cc011457170fd80bc9cb14f8fad9b5
parentVersion bump, modified bristuff 0.3.0-PRE1c patch to apply. (diff)
downloadhistorical-052685269116de523073571083e5c752ce0aa767.tar.gz
historical-052685269116de523073571083e5c752ce0aa767.tar.bz2
historical-052685269116de523073571083e5c752ce0aa767.zip
Version bump, ebuild changes for theora depend as suggested by Marcin Lewandowski <www@saepia.net>. Closes bugs #105367 & #107043.
Package-Manager: portage-2.0.53
-rw-r--r--net-misc/icecast/ChangeLog8
-rw-r--r--net-misc/icecast/Manifest10
-rw-r--r--net-misc/icecast/files/digest-icecast-2.3.11
-rw-r--r--net-misc/icecast/icecast-2.3.1.ebuild43
4 files changed, 61 insertions, 1 deletions
diff --git a/net-misc/icecast/ChangeLog b/net-misc/icecast/ChangeLog
index 95544fe9438f..7880d91c3c13 100644
--- a/net-misc/icecast/ChangeLog
+++ b/net-misc/icecast/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/icecast
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/ChangeLog,v 1.52 2005/09/01 23:56:55 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/ChangeLog,v 1.53 2005/12/16 20:54:31 chainsaw Exp $
+
+*icecast-2.3.1 (16 Dec 2005)
+
+ 16 Dec 2005; <chainsaw@gentoo.org> +icecast-2.3.1.ebuild:
+ Version bump, ebuild changes for theora depend as suggested by Marcin
+ Lewandowski <www@saepia.net>. Closes bugs #105367 & #107043.
01 Sep 2005; Diego Pettenò <flameeyes@gentoo.org> icecast-2.2.0.ebuild:
Remove doc useflag, always install user docs, fixes #95653. Install man page
diff --git a/net-misc/icecast/Manifest b/net-misc/icecast/Manifest
index d2b22fae213a..d6c135bc3a91 100644
--- a/net-misc/icecast/Manifest
+++ b/net-misc/icecast/Manifest
@@ -1,3 +1,6 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 e38adcc9a1fbb28c8dcfac8132b2ee74 ChangeLog 7456
MD5 a5f4b4836da859fb3b50704c437e2ba9 files/1.3.12-errno.patch 1732
MD5 7fea29ea3b0c1cd4cda72553db01dfa9 files/2.2.0-gentoo.patch 15011
@@ -13,3 +16,10 @@ MD5 f0d6c4a492be7ed7ef6f3ee6a49cb2e0 icecast-2.1.0.ebuild 1068
MD5 2c2b3c9ebae24f5549c6bf6b7b71a3db icecast-2.2.0.ebuild 1152
MD5 ce7087d4df80d089969608a5e68a8acb icecast-2.3.1.ebuild 1108
MD5 d0d7ea03e238a808414b4426394c100f metadata.xml 221
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2-ecc0.1.6 (GNU/Linux)
+
+iD8DBQFDoyl7p5vW4rUFj5oRAs1OAJ48Df6Nu2X7Fj239uqOiLLliK2qowCfQiZu
+i+VWkibV5h0z1oscCicLCNA=
+=vbTI
+-----END PGP SIGNATURE-----
diff --git a/net-misc/icecast/files/digest-icecast-2.3.1 b/net-misc/icecast/files/digest-icecast-2.3.1
new file mode 100644
index 000000000000..3d8f5cc5211c
--- /dev/null
+++ b/net-misc/icecast/files/digest-icecast-2.3.1
@@ -0,0 +1 @@
+MD5 2d80a249fa8529f82d018c6216108ea8 icecast-2.3.1.tar.gz 1094154
diff --git a/net-misc/icecast/icecast-2.3.1.ebuild b/net-misc/icecast/icecast-2.3.1.ebuild
new file mode 100644
index 000000000000..be7c9e730c9c
--- /dev/null
+++ b/net-misc/icecast/icecast-2.3.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/icecast-2.3.1.ebuild,v 1.1 2005/12/16 20:54:31 chainsaw Exp $
+
+IUSE="yp theora"
+
+inherit eutils
+
+DESCRIPTION="An opensource alternative to shoutcast that supports mp3, ogg (vorbis/theora) and aac streaming"
+HOMEPAGE="http://www.icecast.org/"
+SRC_URI="http://downloads.xiph.org/releases/icecast/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="dev-libs/libxslt
+ media-libs/libogg
+ media-libs/libvorbis
+ theora? ( media-libs/libtheora )
+ yp? ( >=net-misc/curl-7.10.0 )"
+
+src_compile() {
+ econf \
+ --sysconfdir=/etc/icecast2 \
+ $(use_enable yp) \
+ ${myconf} || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README TODO HACKING NEWS conf/icecast.xml.dist
+ dohtml -A chm,hhc,hhp doc/*
+ doman ${S}/debian/icecast2.1
+
+ newinitd ${FILESDIR}/init.d.icecast icecast
+
+ fperms 600 /etc/icecast2/icecast.xml
+
+ rm -rf ${D}/usr/share/doc/icecast
+}