summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-01-13 20:04:41 +0000
committerAchim Gottinger <achim@gentoo.org>2001-01-13 20:04:41 +0000
commit13f10282c0929d9e15ffdcf2bc13f9e6ef533b36 (patch)
treebe3f6ad44ab66679c7f92212d1e60d9664dcd032
parentHere are the actuall kernel sources (diff)
downloadhistorical-13f10282c0929d9e15ffdcf2bc13f9e6ef533b36.tar.gz
historical-13f10282c0929d9e15ffdcf2bc13f9e6ef533b36.tar.bz2
historical-13f10282c0929d9e15ffdcf2bc13f9e6ef533b36.zip
*** empty log message ***
-rw-r--r--sys-kernel/linux-bootdisk/files/digest-linux-bootdisk-2.4.0.34
-rw-r--r--sys-kernel/linux-bootdisk/linux-bootdisk-2.4.0_rc10-r7.ebuild3
-rw-r--r--sys-kernel/linux/files/digest-linux-2.4.0.8-r18
-rw-r--r--sys-kernel/linux/linux-2.4.0.8-r1.ebuild240
-rw-r--r--sys-kernel/linux/linux-2.4.0.8.ebuild61
5 files changed, 258 insertions, 58 deletions
diff --git a/sys-kernel/linux-bootdisk/files/digest-linux-bootdisk-2.4.0.3 b/sys-kernel/linux-bootdisk/files/digest-linux-bootdisk-2.4.0.3
new file mode 100644
index 000000000000..c8e89e7154d2
--- /dev/null
+++ b/sys-kernel/linux-bootdisk/files/digest-linux-bootdisk-2.4.0.3
@@ -0,0 +1,4 @@
+MD5 18278baa4c54387b1c29f0edba55ab14 linux-2.4.0.tar.bz2
+MD5 5e5b1b170dd0267df1deb843ec3995a1 patch-2.4.0-ac3.bz2
+MD5 c34e0e36883640ec06b972d85e6252a8 linux-2.4.0-reiserfs-3.6.25-patch.gz
+MD5 3e20d89a759dac0c43f3a39570116e49 lvm_0.9.tar.gz
diff --git a/sys-kernel/linux-bootdisk/linux-bootdisk-2.4.0_rc10-r7.ebuild b/sys-kernel/linux-bootdisk/linux-bootdisk-2.4.0_rc10-r7.ebuild
index 0a5e2c0307b1..134adfde38b6 100644
--- a/sys-kernel/linux-bootdisk/linux-bootdisk-2.4.0_rc10-r7.ebuild
+++ b/sys-kernel/linux-bootdisk/linux-bootdisk-2.4.0_rc10-r7.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-bootdisk/linux-bootdisk-2.4.0_rc10-r7.ebuild,v 1.1 2001/01/08 10:07:29 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-bootdisk/linux-bootdisk-2.4.0_rc10-r7.ebuild,v 1.2 2001/01/13 20:03:23 achim Exp $
S=${WORKDIR}/linux
KV=2.4.0-test10
@@ -88,6 +88,7 @@ src_install() {
doins arch/i386/boot/bzImage
#grab modules
+ dodir /lib/modules/`uname -r`
try make INSTALL_MOD_PATH=${D} modules_install
#fix symlink
diff --git a/sys-kernel/linux/files/digest-linux-2.4.0.8-r1 b/sys-kernel/linux/files/digest-linux-2.4.0.8-r1
new file mode 100644
index 000000000000..2f761a110bcb
--- /dev/null
+++ b/sys-kernel/linux/files/digest-linux-2.4.0.8-r1
@@ -0,0 +1,8 @@
+MD5 18278baa4c54387b1c29f0edba55ab14 linux-2.4.0.tar.bz2
+MD5 9ab8b7b8c6fea2ddf7d8155608b46734 patch-2.4.0-ac8.bz2
+MD5 c16f3df6b5f9e56b146071edfa5ec5d4 lm_sensors-2.5.4.tar.gz
+MD5 039fb223e361d343e8d40c54f0a317e6 i2c-2.5.4.tar.gz
+MD5 14d88343fb8897c4aeddb4920d1542c3 jfs-0.1.2-patch.tar.gz
+MD5 20917ea363d9ccea983689cc27e7d813 alsa-driver-0.5.10.tar.bz2
+MD5 130d1e7bf56eda1a93a831189b4c6420 NVIDIA_kernel-0.9-5.tar.gz
+MD5 3e20d89a759dac0c43f3a39570116e49 lvm_0.9.tar.gz
diff --git a/sys-kernel/linux/linux-2.4.0.8-r1.ebuild b/sys-kernel/linux/linux-2.4.0.8-r1.ebuild
new file mode 100644
index 000000000000..9138360fa144
--- /dev/null
+++ b/sys-kernel/linux/linux-2.4.0.8-r1.ebuild
@@ -0,0 +1,240 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux/linux-2.4.0.8-r1.ebuild,v 1.1 2001/01/13 20:04:41 achim Exp $
+
+S=${WORKDIR}/linux
+KV=2.4.0-ac8
+if [ "$PN" = "linux" ]
+then
+ DESCRIPTION="Linux kernel, including modules, binary tools, libraries and includes"
+else
+ DESCRIPTION="Kernel source package, including full sources, binary tools and libraries"
+fi
+SRC_URI="
+http://www.de.kernel.org/pub/linux/kernel/v2.4/linux-2.4.0.tar.bz2
+http://www.de.kernel.org/pub/linux/kernel/people/alan/2.4/patch-2.4.0-ac8.bz2
+http://www.netroedge.com/~lm78/archive/lm_sensors-2.5.4.tar.gz
+http://www.netroedge.com/~lm78/archive/i2c-2.5.4.tar.gz
+http://oss.software.ibm.com/developerworks/opensource/jfs/project/pub/jfs-0.1.2-patch.tar.gz
+ftp://ftp.alsa-project.org/pub/driver/alsa-driver-0.5.10.tar.bz2
+ftp://ftp1.detonator.nvidia.com/pub/drivers/english/XFree86_40/0.9-5/NVIDIA_kernel-0.9-5.tar.gz
+ftp://ftp.sistina.com/pub/LVM/0.9/lvm_0.9.tar.gz"
+
+HOMEPAGE="http://www.kernel.org/
+ http://www.netroedge.com/~lm78/
+ http://www.namesys.com
+ http://www.sistina.com/lvm/
+ http://www.alsa-project.org
+ http://www.nvidia.com"
+
+
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-2.4.0.tar.bz2
+ cd ${S}
+ echo "Applying ac7 patch..."
+ bzip2 -dc ${DISTDIR}/patch-2.4.0-ac8.bz2 | patch -p1
+
+ echo "Applying ReiserFS patch..."
+ gzip -dc ${FILESDIR}/${PV}/linux-2.4.0-ac6-reiserfs-3.6.25-maxbytes.diff.gz | patch -p1
+
+ echo "Applying reiser-nfs patch..."
+ gzip -dc ${FILESDIR}/${PV}/linux-2.4.0-ac8-reiserfs-3.6.25-nfs.diff.gz | patch -p1
+
+ mkdir extras
+ if [ "`use jfs`" ]
+ then
+ echo "Applying IBM JFS patch..."
+ cd extras
+ mkdir jfs
+ cd jfs
+ unpack jfs-0.1.2-patch.tar.gz
+ cd ${S}
+ patch -p1 < extras/jfs/jfs-common-v0.1.2-patch
+ patch -p1 < extras/jfs/jfs-2.4.0-v0.1.2-patch
+ fi
+ cd ${S}/extras
+ echo "Unpacking LVM..."
+ unpack lvm_0.9.tar.gz
+ echo "Unpacking ALSA drivers..."
+ unpack alsa-driver-0.5.10.tar.bz2
+# echo "Unpacking NVidia drivers..."
+# unpack NVIDIA_kernel-0.9-5.tar.gz
+# cd NVIDIA_kernel-0.9-5
+# # this is a little fix to make the NVidia drivers compile right with test12
+# mv nv.c nv.c.orig
+# echo '#define mem_map_inc_count(p) atomic_inc(&(p->count))' > nv.c
+# echo '#define mem_map_dec_count(p) atomic_dec(&(p->count))' >> nv.c
+# cat nv.c.orig >> nv.c
+# This does not work with 2.4.0 daniel can you fix this
+ cd ${S}/extras
+
+ #lm_sensors buggy mkpatch.pl in 2.5.4!
+ for x in i2c
+ do
+ echo "Unpacking and applying $x patch..."
+ cd ${S}/extras
+ unpack ${x}-2.5.4.tar.gz
+ cd ${x}-2.5.4
+ mkpatch/mkpatch.pl . ${S} > ${S}/${x}-patch
+ cd ${S}
+ patch -p1 < ${x}-patch
+ done
+
+ echo "Preparing for compilation..."
+ cd ${S}
+ #this is the configuration for the bootdisk/cd
+ cp ${FILESDIR}/${PV}/config .config
+ cp ${FILESDIR}/${PV}/autoconf.h include/linux/autoconf.h
+ try make include/linux/version.h
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R root.root linux
+}
+
+src_compile() {
+
+ cd ${S}
+ try make symlinks
+ try make dep
+
+ cd ${S}/fs/reiserfs/utils
+ try make
+
+# cd ${S}/lm_sensors-2.5.4
+# try make
+
+ if [ "`use jfs`" ]
+ then
+ cd ${S}/fs/jfs/utils
+ try make
+ fi
+
+ if [ "$PN" = "linux" ]
+ then
+ cd ${S}
+ try make bzImage
+ try make modules
+# cd ${S}/extras/NVIDIA_kernel-0.9-5
+# make NVdriver
+
+ cd ${S}/extras/LVM/0.9
+ try ./configure --prefix=/
+ try make
+
+ cd ${S}/extras/alsa-driver-0.5.10
+ try ./configure --with-kernel=${S} --with-isapnp=yes --with-sequencer=yes --with-oss=yes \
+ --with-cards=share,dummy,virmidi,interwave,interwave-stb,gusmax,gusextreme,gusclassic,es1688,es18xx,sb8,sb16,sbawe,emu10k1,opl3sa2,mozart,sonicvibes,ens1370,ens1371,ad1816a,ad1848,als100,als4000,azt2320,cs4231,cs4232,cs4236,cs4281,cs461x,cs4281,es968,dt0197h,fm801,es1938,es1968,opti92x-ad1848,opti92x-cs4231,opti93x,serial,trident,sgalaxy,hal2,cmi8330,mtpav,rme96,rme9652,ice1712,intel8x0,via686a,cmipci,ymfpci,maestro3
+ # "wavefront" is buggy in 0.5.10
+ try make
+ fi
+}
+src_install() {
+
+ cd ${S}/fs/reiserfs/utils
+ dodir /usr/man/man8 /sbin
+ try make install SBIN=${D}/sbin MANDIR=${D}/usr/man/man8
+
+ cd ${S}/extras/LVM/0.9
+ make install prefix=${D} MAN8DIR=${D}/usr/man/man8 LIBDIR=${D}/lib
+
+ if [ "`use jfs`" ]
+ then
+ cd ${S}/fs/jfs/utils
+ cp output/* ${D}/sbin
+ local x
+ for x in `find -iname *.1`
+ do
+ doman $x
+ done
+ for x in `find -iname *.8`
+ do
+ doman $x
+ done
+ fi
+
+ dodir /usr/src
+
+ if [ "$PN" = "linux" ]
+ then
+
+ dodir /usr/src/linux-${KV}
+ cd ${D}/usr/src
+ ln -sf linux-${KV} linux
+ ln -sf linux-${KV} linux-2.4
+
+ #grab includes and documentation only
+ dodir /usr/src/linux-${KV}/include/linux
+ dodir /usr/src/linux-${KV}/include/asm-i386
+ cp -ax ${S}/include ${D}/usr/src/linux-${KV}
+ cp -ax ${S}/Documentation ${D}/usr/src/linux-${KV}
+ dodir /usr/include
+ dosym /usr/src/linux/include/linux /usr/include/linux
+ dosym /usr/src/linux/include/asm-i386 /usr/include/asm
+
+ #grab compiled kernel
+ dodir /boot/boot
+ insinto /boot/boot
+ cd ${S}
+ doins arch/i386/boot/bzImage
+
+ #grab modules
+ dodir /lib/modules/${KV}
+ dodir /lib/modules/`uname -r`
+ dodir ${D}/lib/modules/${KV}
+ try make INSTALL_MOD_PATH=${D} modules_install
+
+ #install ALSA modules
+ cd ${S}/extras/alsa-driver-0.5.10
+ dodir /lib/modules/${KV}/misc
+ cp modules/*.o ${D}/lib/modules/${KV}/misc
+ into /usr
+ dosbin snddevices
+ dodir /usr/include/linux
+ insinto /usr/src/linux-${KV}/include/linux
+ cd include
+ doins asound.h asoundid.h asequencer.h ainstr_*.h
+
+ #install nvidia driver
+# cd ${S}/extras/NVIDIA_kernel-0.9-5
+# insinto /lib/modules/${KV}/video
+# doins NVdriver
+
+ #fix symlink
+ cd ${D}/lib/modules/${KV}
+ rm build
+ ln -sf /usr/src/linux-${KV} build
+
+ else
+
+ #grab all the sources
+ cd ${WORKDIR}
+ mv linux ${D}/usr/src/linux-${KV}
+ cd ${D}/usr/src
+ ln -sf linux-${KV} linux
+
+ #remove workdir since our install was dirty and modified ${S}
+ #this will cause an unpack to be done next time
+ rm -rf ${WORKDIR}
+ fi
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = "/" ]
+ then
+ if [ "${PN}" = "linux" ] ; then
+ echo "Creating sounddevices..."
+ /usr/sbin/snddevices
+ fi
+ fi
+}
+
+
+
+
+
+
+
+
diff --git a/sys-kernel/linux/linux-2.4.0.8.ebuild b/sys-kernel/linux/linux-2.4.0.8.ebuild
index a37618405470..bc3f6e4498e3 100644
--- a/sys-kernel/linux/linux-2.4.0.8.ebuild
+++ b/sys-kernel/linux/linux-2.4.0.8.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux/linux-2.4.0.8.ebuild,v 1.1 2001/01/13 16:29:39 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux/linux-2.4.0.8.ebuild,v 1.2 2001/01/13 20:03:23 achim Exp $
S=${WORKDIR}/linux
KV=2.4.0-ac8
@@ -40,42 +40,14 @@ src_unpack() {
echo "Applying ReiserFS patch..."
gzip -dc ${FILESDIR}/${PV}/linux-2.4.0-ac6-reiserfs-3.6.25-maxbytes.diff.gz | patch -p1
-# echo "Applying ReiserFS fixes patch..."
-# gzip -dc ${FILESDIR}/${PV}/linux-2.4.0-ac3-reiserfs-3.6.25-fixes.patch.gz | patch -p1
-
-# echo "Applying ReiserFS ac4 fixes..."
-# gzip -dc ${FILESDIR}/${PV}/2.4.0-ac4+reiserfs-max_bytes.patch.gz | patch -p1
-
-# echo "Applying reiser-nfs patch..."
-# gzip -dc ${FILESDIR}/${PV}/linux-2.4.0-ac3-reiserfs-3.6.24-nfs.diff.gz | patch -p1
mkdir extras
- if [ "`use jfs`" ]
- then
- echo "Applying IBM JFS patch..."
- cd extras
- mkdir jfs
- cd jfs
- unpack jfs-0.1.2-patch.tar.gz
- cd ${S}
- patch -p1 < extras/jfs/jfs-common-v0.1.2-patch
- patch -p1 < extras/jfs/jfs-2.4.0-test12-v0.1.1-patch
- fi
+
cd ${S}/extras
echo "Unpacking LVM..."
unpack lvm_0.9.tar.gz
echo "Unpacking ALSA drivers..."
unpack alsa-driver-0.5.10.tar.bz2
-# echo "Unpacking NVidia drivers..."
-# unpack NVIDIA_kernel-0.9-5.tar.gz
-# cd NVIDIA_kernel-0.9-5
-# # this is a little fix to make the NVidia drivers compile right with test12
-# mv nv.c nv.c.orig
-# echo '#define mem_map_inc_count(p) atomic_inc(&(p->count))' > nv.c
-# echo '#define mem_map_dec_count(p) atomic_dec(&(p->count))' >> nv.c
-# cat nv.c.orig >> nv.c
-# This does not work with 2.4.0 daniel can you fix thisOB
- cd ${S}/extras
#lm_sensors buggy mkpatch.pl in 2.5.4!
for x in i2c
@@ -112,19 +84,12 @@ src_compile() {
# cd ${S}/lm_sensors-2.5.4
# try make
- if [ "`use jfs`" ]
- then
- cd ${S}/fs/jfs/utils
- try make
- fi
if [ "$PN" = "linux" ]
then
cd ${S}
try make bzImage
try make modules
-# cd ${S}/extras/NVIDIA_kernel-0.9-5
-# make NVdriver
cd ${S}/extras/LVM/0.9
try ./configure --prefix=/
@@ -146,21 +111,6 @@ src_install() {
cd ${S}/extras/LVM/0.9
make install prefix=${D} MAN8DIR=${D}/usr/man/man8 LIBDIR=${D}/lib
- if [ "`use jfs`" ]
- then
- cd ${S}/fs/jfs/utils
- cp output/* ${D}/sbin
- local x
- for x in `find -iname *.1`
- do
- doman $x
- done
- for x in `find -iname *.8`
- do
- doman $x
- done
- fi
-
dodir /usr/src
if [ "$PN" = "linux" ]
@@ -187,6 +137,8 @@ src_install() {
doins arch/i386/boot/bzImage
#grab modules
+ # Do we have a bug in modutils ?
+ # Meanwhile we use this quick fix (achim)
dodir /lib/modules/${KV}
dodir /lib/modules/`uname -r`
dodir ${D}/lib/modules/${KV}
@@ -203,11 +155,6 @@ src_install() {
cd include
doins asound.h asoundid.h asequencer.h ainstr_*.h
- #install nvidia driver
-# cd ${S}/extras/NVIDIA_kernel-0.9-5
-# insinto /lib/modules/${KV}/video
-# doins NVdriver
-
#fix symlink
cd ${D}/lib/modules/${KV}
rm build