summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-09-09 22:58:27 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-09-09 22:58:27 +0000
commit34780053f6c327ed6d92cb7a5ad03183abf3567b (patch)
tree945fed4f39658c7f6e4060328ccb08d71a7b4e5a
parentVersion bump (diff)
downloadhistorical-34780053f6c327ed6d92cb7a5ad03183abf3567b.tar.gz
historical-34780053f6c327ed6d92cb7a5ad03183abf3567b.tar.bz2
historical-34780053f6c327ed6d92cb7a5ad03183abf3567b.zip
Bump to 8.0.22
Package-Manager: portage-2.2_rc40/cvs/Linux x86_64
-rw-r--r--dev-db/postgresql-base/ChangeLog8
-rw-r--r--dev-db/postgresql-base/postgresql-base-8.0.22.ebuild143
-rw-r--r--dev-db/postgresql-docs/ChangeLog8
-rw-r--r--dev-db/postgresql-docs/postgresql-docs-8.0.22.ebuild43
-rw-r--r--dev-db/postgresql-server/ChangeLog8
-rw-r--r--dev-db/postgresql-server/postgresql-server-8.0.22.ebuild240
6 files changed, 447 insertions, 3 deletions
diff --git a/dev-db/postgresql-base/ChangeLog b/dev-db/postgresql-base/ChangeLog
index 6fb344f64b2a..6d31747a7f10 100644
--- a/dev-db/postgresql-base/ChangeLog
+++ b/dev-db/postgresql-base/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/postgresql-base
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-base/ChangeLog,v 1.22 2009/09/09 22:33:47 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-base/ChangeLog,v 1.23 2009/09/09 22:57:31 patrick Exp $
+
+*postgresql-base-8.0.22 (09 Sep 2009)
+
+ 09 Sep 2009; Patrick Lauer <patrick@gentoo.org>
+ +postgresql-base-8.0.22.ebuild:
+ Bump to 8.0.22
*postgresql-base-8.2.14 (09 Sep 2009)
*postgresql-base-8.1.18 (09 Sep 2009)
diff --git a/dev-db/postgresql-base/postgresql-base-8.0.22.ebuild b/dev-db/postgresql-base/postgresql-base-8.0.22.ebuild
new file mode 100644
index 000000000000..1392d31a6598
--- /dev/null
+++ b/dev-db/postgresql-base/postgresql-base-8.0.22.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-base/postgresql-base-8.0.22.ebuild,v 1.1 2009/09/09 22:57:31 patrick Exp $
+
+EAPI="1"
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="none"
+
+inherit eutils multilib toolchain-funcs versionator autotools
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PostgreSQL libraries and clients"
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+LICENSE="POSTGRESQL"
+SLOT="$(get_version_component_range 1-2)"
+IUSE_LINGUAS="
+ linguas_af linguas_cs linguas_de linguas_es linguas_fa linguas_fr
+ linguas_hr linguas_hu linguas_it linguas_ko linguas_nb linguas_pl
+ linguas_pt_BR linguas_ro linguas_ru linguas_sk linguas_sl linguas_sv
+ linguas_tr linguas_zh_CN linguas_zh_TW"
+IUSE="doc kerberos nls pam pg-intdatetime readline ssl threads zlib ${IUSE_LINGUAS}"
+RESTRICT="test"
+
+wanted_languages() {
+ for u in ${IUSE_LINGUAS} ; do
+ use $u && echo -n "${u#linguas_} "
+ done
+}
+
+RDEPEND="kerberos? ( virtual/krb5 )
+ pam? ( virtual/pam )
+ readline? ( >=sys-libs/readline-4.1 )
+ ssl? ( >=dev-libs/openssl-0.9.6-r1 )
+ zlib? ( >=sys-libs/zlib-1.1.3 )
+ >=app-admin/eselect-postgresql-0.3
+ !dev-db/postgresql-libs
+ !dev-db/postgresql-client
+ !dev-db/libpq
+ !dev-db/postgresql"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ >=sys-devel/bison-1.875
+ nls? ( sys-devel/gettext )"
+PDEPEND="doc? ( dev-db/postgresql-docs:${SLOT} )"
+
+S="${WORKDIR}/postgresql-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/postgresql-${SLOT}-common.patch" \
+ "${FILESDIR}/postgresql-${SLOT}-base.patch" \
+ "${FILESDIR}/postgresql-8.x-relax_ssl_perms.patch"
+
+ # to avoid collision - it only should be installed by server
+ rm "${S}/src/backend/nls.mk"
+
+ # because psql/help.c includes the file
+ ln -s "${S}/src/include/libpq/pqsignal.h" "${S}/src/bin/psql/"
+
+ eautoconf
+}
+
+src_compile() {
+ econf --prefix=/usr/$(get_libdir)/postgresql-${SLOT} \
+ --datadir=/usr/share/postgresql-${SLOT} \
+ --sysconfdir=/etc/postgresql-${SLOT} \
+ --includedir=/usr/include/postgresql-${SLOT} \
+ --with-locale-dir=/usr/share/postgresql-${SLOT}/locale \
+ --mandir=/usr/share/postgresql-${SLOT}/man \
+ --without-docdir \
+ --without-tcl \
+ --without-perl \
+ --without-python \
+ $(use_with kerberos krb5) \
+ "$(use_enable nls nls "$(wanted_languages)")" \
+ $(use_with pam) \
+ $(use_enable pg-intdatetime integer-datetimes ) \
+ $(use_with readline) \
+ $(use_with ssl openssl) \
+ $(use_enable threads thread-safety) \
+ $(use_enable threads thread-safety-force) \
+ $(use_with zlib) \
+ || die "configure failed"
+
+ emake LD="$(tc-getLD) $(get_abi_LDFLAGS)" || die "emake failed"
+
+ cd "${S}/contrib"
+ emake LD="$(tc-getLD) $(get_abi_LDFLAGS)" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ insinto /usr/include/postgresql-${SLOT}/postmaster
+ doins "${S}"/src/include/postmaster/*.h
+ dodir /usr/share/postgresql-${SLOT}/man/man1
+ tar -zxf "${S}/doc/man.tar.gz" -C "${D}"/usr/share/postgresql-${SLOT}/man man1/{ecpg,pg_config}.1
+
+ rm "${D}/usr/share/postgresql-${SLOT}/man/man1"/{initdb,ipcclean,pg_controldata,pg_ctl,pg_resetxlog,pg_restore,postgres,postmaster}.1
+ dodoc README HISTORY doc/{README.*,TODO,bug.template}
+
+ cd "${S}/contrib"
+ emake DESTDIR="${D}" install || die "emake install failed"
+ cd "${S}"
+
+ dodir /etc/eselect/postgresql/slots/${SLOT}
+
+ IDIR="/usr/include/postgresql-${SLOT}"
+ cat > "${D}/etc/eselect/postgresql/slots/${SLOT}/base" <<-__EOF__
+postgres_ebuilds="\${postgres_ebuilds} ${PF}"
+postgres_prefix=/usr/$(get_libdir)/postgresql-${SLOT}
+postgres_datadir=/usr/share/postgresql-${SLOT}
+postgres_bindir=/usr/$(get_libdir)/postgresql-${SLOT}/bin
+postgres_symlinks=(
+ ${IDIR} /usr/include/postgresql
+ ${IDIR}/libpq-fe.h /usr/include/libpq-fe.h
+ ${IDIR}/libpq /usr/include/libpq
+ ${IDIR}/postgres_ext.h /usr/include/postgres_ext.h
+)
+__EOF__
+
+ cat >"${T}/50postgresql-97-${SLOT}" <<-__EOF__
+ LDPATH=/usr/$(get_libdir)/postgresql-${SLOT}/$(get_libdir)
+ MANPATH=/usr/share/postgresql-${SLOT}/man
+ __EOF__
+ doenvd "${T}/50postgresql-97-${SLOT}"
+
+ keepdir /etc/postgresql-${SLOT}
+}
+
+pkg_postinst() {
+ eselect postgresql update
+ [[ "$(eselect postgresql show)" = "(none)" ]] && eselect postgresql set ${SLOT}
+ elog "If you need a global psqlrc-file, you can place it in '${ROOT}/etc/postgresql-${SLOT}/'."
+}
+
+pkg_postrm() {
+ eselect postgresql update
+}
diff --git a/dev-db/postgresql-docs/ChangeLog b/dev-db/postgresql-docs/ChangeLog
index 1c48cbc38185..07df3d0eb28a 100644
--- a/dev-db/postgresql-docs/ChangeLog
+++ b/dev-db/postgresql-docs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/postgresql-docs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/ChangeLog,v 1.17 2009/09/09 22:34:13 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/ChangeLog,v 1.18 2009/09/09 22:57:58 patrick Exp $
+
+*postgresql-docs-8.0.22 (09 Sep 2009)
+
+ 09 Sep 2009; Patrick Lauer <patrick@gentoo.org>
+ +postgresql-docs-8.0.22.ebuild:
+ Bump to 8.0.22
*postgresql-docs-8.2.14 (09 Sep 2009)
*postgresql-docs-8.1.18 (09 Sep 2009)
diff --git a/dev-db/postgresql-docs/postgresql-docs-8.0.22.ebuild b/dev-db/postgresql-docs/postgresql-docs-8.0.22.ebuild
new file mode 100644
index 000000000000..45ce9d28d1ec
--- /dev/null
+++ b/dev-db/postgresql-docs/postgresql-docs-8.0.22.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/postgresql-docs-8.0.22.ebuild,v 1.1 2009/09/09 22:57:58 patrick Exp $
+
+inherit versionator
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PostgreSQL documentation"
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+LICENSE="POSTGRESQL"
+SLOT="$(get_version_component_range 1-2)"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+RESTRICT="test"
+
+S="${WORKDIR}/postgresql-${PV}"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dodir /usr/share/doc/${PF}/html
+ tar -zxf "${S}/doc/postgres.tar.gz" -C "${D}/usr/share/doc/${PF}/html"
+ cd "${S}/doc"
+ docinto FAQ_html
+ dodoc src/FAQ/*
+ docinto sgml
+ dodoc src/sgml/*.{sgml,dsl}
+ docinto sgml/ref
+ dodoc src/sgml/ref/*.sgml
+ docinto TODO.detail
+ dodoc TODO.detail/*
+
+ dodir /etc/eselect/postgresql/slots/${SLOT}
+ {
+ echo "postgres_ebuilds=\"\${postgres_ebuilds} ${PF}\""
+ } >"${D}/etc/eselect/postgresql/slots/${SLOT}/docs"
+}
diff --git a/dev-db/postgresql-server/ChangeLog b/dev-db/postgresql-server/ChangeLog
index 9444b6e0a251..d87cd3de30b2 100644
--- a/dev-db/postgresql-server/ChangeLog
+++ b/dev-db/postgresql-server/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/postgresql-server
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-server/ChangeLog,v 1.20 2009/09/09 22:34:45 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-server/ChangeLog,v 1.21 2009/09/09 22:58:27 patrick Exp $
+
+*postgresql-server-8.0.22 (09 Sep 2009)
+
+ 09 Sep 2009; Patrick Lauer <patrick@gentoo.org>
+ +postgresql-server-8.0.22.ebuild:
+ Bump to 8.0.22
*postgresql-server-8.2.14 (09 Sep 2009)
*postgresql-server-8.1.18 (09 Sep 2009)
diff --git a/dev-db/postgresql-server/postgresql-server-8.0.22.ebuild b/dev-db/postgresql-server/postgresql-server-8.0.22.ebuild
new file mode 100644
index 000000000000..852f0013574c
--- /dev/null
+++ b/dev-db/postgresql-server/postgresql-server-8.0.22.ebuild
@@ -0,0 +1,240 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-server/postgresql-server-8.0.22.ebuild,v 1.1 2009/09/09 22:58:27 patrick Exp $
+
+EAPI="1"
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="none"
+inherit eutils multilib toolchain-funcs versionator autotools
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PostgreSQL server"
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+LICENSE="POSTGRESQL"
+SLOT="$(get_version_component_range 1-2)"
+IUSE_LINGUAS="
+ linguas_af linguas_cs linguas_de linguas_es linguas_fa linguas_fr
+ linguas_hr linguas_hu linguas_it linguas_ko linguas_nb linguas_pl
+ linguas_pt_BR linguas_ro linguas_ru linguas_sk linguas_sl linguas_sv
+ linguas_tr linguas_zh_CN linguas_zh_TW"
+IUSE="doc perl python selinux tcl xml nls kernel_linux ${IUSE_LINGUAS}"
+
+wanted_languages() {
+ for u in ${IUSE_LINGUAS} ; do
+ use $u && echo -n "${u#linguas_} "
+ done
+}
+
+RDEPEND="~dev-db/postgresql-base-${PV}:${SLOT}
+ perl? ( >=dev-lang/perl-5.6.1-r2 )
+ python? ( >=dev-lang/python-2.2 dev-python/egenix-mx-base )
+ selinux? ( sec-policy/selinux-postgresql )
+ tcl? ( >=dev-lang/tcl-8 )
+ xml? ( dev-libs/libxml2 dev-libs/libxslt )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ xml? ( dev-util/pkgconfig )"
+PDEPEND="doc? ( dev-db/postgresql-docs:${SLOT} )"
+
+S="${WORKDIR}/postgresql-${PV}"
+
+pkg_setup() {
+ enewgroup postgres 70
+ enewuser postgres 70 /bin/bash /var/lib/postgresql postgres
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/postgresql-${SLOT}-common.patch" \
+ "${FILESDIR}/postgresql-${SLOT}-server.patch"
+
+ if hasq test ${FEATURES}; then
+ sed -e "s|/no/such/location|${S}/src/test/regress/tmp_check/no/such/location|g" -i src/test/regress/{input,output}/tablespace.source
+ fi
+
+ eautoconf
+}
+
+src_compile() {
+ # TODO: test if PPC really cannot work with other CFLAGS settings
+ # use ppc && CFLAGS="-pipe -fsigned-char"
+
+ # eval is needed to get along with pg_config quotation of space-rich entities.
+ eval econf "$(/usr/$(get_libdir)/postgresql-${SLOT}/bin/pg_config --configure)" \
+ $(use_with perl) \
+ $(use_with python) \
+ $(use_with tcl) \
+ --with-includes="/usr/include/postgresql-${SLOT}/" \
+ "$(built_with_use ~dev-db/postgresql-base-${PV} nls && use_enable nls nls "$(wanted_languages)")" \
+ || die "configure failed"
+
+ for bd in . contrib $(use xml && echo contrib/xml2) ; do
+ PATH="/usr/$(get_libdir)/postgresql-${SLOT}/bin:${PATH}" \
+ emake -C $bd -j1 LD="$(tc-getLD) $(get_abi_LDFLAGS)" \
+ PGXS=$(/usr/$(get_libdir)/postgresql-${SLOT}/bin/pg_config --pgxs) \
+ NO_PGXS=0 USE_PGXS=1 docdir=/usr/share/doc/${PF} || die "emake in $bd failed"
+ done
+}
+
+src_install() {
+ if use perl ; then
+ mv -f "${S}/src/pl/plperl/GNUmakefile" "${S}/src/pl/plperl/GNUmakefile_orig"
+ sed -e "s:\$(DESTDIR)\$(plperl_installdir):\$(plperl_installdir):" \
+ "${S}/src/pl/plperl/GNUmakefile_orig" > "${S}/src/pl/plperl/GNUmakefile"
+ fi
+
+ for bd in . contrib $(use xml && echo contrib/xml2) ; do
+ PATH="/usr/$(get_libdir)/postgresql-${SLOT}/bin:${PATH}" \
+ emake install -C $bd -j1 DESTDIR="${D}" \
+ PGXS=$(/usr/$(get_libdir)/postgresql-${SLOT}/bin/pg_config --pgxs) \
+ NO_PGXS=0 USE_PGXS=1 docdir=/usr/share/doc/${PF} || die "emake install in $bd failed"
+ done
+
+ rm -rf "${D}/usr/share/postgresql-${SLOT}/man/man7/" "${D}/usr/share/doc/${PF}/html"
+ rm "${D}"/usr/share/postgresql-${SLOT}/man/man1/{clusterdb,create{db,lang,user},drop{db,lang,user},ecpg,pg_{config,dump,dumpall,restore},psql,vacuumdb}.1
+
+ dodoc README HISTORY doc/{README.*,TODO,bug.template}
+
+ dodir /etc/eselect/postgresql/slots/${SLOT}
+ cat >"${D}/etc/eselect/postgresql/slots/${SLOT}/service" <<-__EOF__
+ postgres_ebuilds="\${postgres_ebuilds} ${PF}"
+ postgres_service="postgresql-${SLOT}"
+ __EOF__
+
+ newinitd "${FILESDIR}/postgresql.init-${SLOT}" postgresql-${SLOT} || die "Inserting init.d-file failed"
+ newconfd "${FILESDIR}/postgresql.conf-${SLOT}" postgresql-${SLOT} || die "Inserting conf.d-file failed"
+
+ keepdir /var/run/postgresql
+ fperms 0770 /var/run/postgresql
+ fowners postgres:postgres /var/run/postgresql
+}
+
+pkg_postinst() {
+ eselect postgresql update
+ [[ "$(eselect postgresql show)" = "(none)" ]] && eselect postgresql set ${SLOT}
+ [[ "$(eselect postgresql show-service)" = "(none)" ]] && eselect postgresql set-service ${SLOT}
+
+ ewarn "Please note that the standard location of the socket has changed from /tmp"
+ ewarn "to /var/run/postgresql and you have to be in the 'postgres' group to access"
+ ewarn "the socket."
+ ewarn "This can break applications which have the standard location hard-coded."
+ ewarn "If such an application links against the libpq, please re-emerge it,"
+ ewarn "if that doesn't help or the application accesses the socket without using libpq,"
+ ewarn "please file a bug-report."
+ ewarn "You can set PGOPTS='-k /tmp' in /etc/conf.d/postgresql-${SLOT} to restore the original location."
+
+ elog "Execute the following command to setup the initial database environment:"
+ elog
+ elog "emerge --config =${CATEGORY}/${PF}"
+ elog
+}
+
+pkg_postrm() {
+ eselect postgresql update
+}
+
+pkg_config() {
+ [[ -z "${PGDATA}" ]] && PGDATA="/var/lib/postgresql/${SLOT}/data"
+
+ einfo "You can pass options to initdb by setting the PG_INITDB_OPTS variable."
+ einfo "More information can be found here:"
+ einfo " http://www.postgresql.org/docs/${SLOT}/static/creating-cluster.html"
+ einfo " http://www.postgresql.org/docs/${SLOT}/static/app-initdb.html"
+ einfo "Simply add the options you would have added to initdb to the PG_INITDB_OPTS variable."
+ einfo
+ einfo "You can change the directory where the database cluster is being created by setting"
+ einfo "the PGDATA variable."
+ einfo
+ einfo "PG_INITDB_OPTS is currently set to:"
+ einfo " \"${PG_INITDB_OPTS}\""
+ einfo "and the database cluster will be created in:"
+ einfo " \"${PGDATA}\""
+ einfo "Are you ready to continue? (Y/n)"
+ read answer
+ [ -z $answer ] && answer=Y
+ [ "$answer" == "Y" ] || [ "$answer" == "y" ] || die "aborted"
+
+ if [[ -f "${PGDATA}/PG_VERSION" ]] ; then
+ eerror "The given directory \"${PGDATA}\" already contains a database cluster."
+ die "cluster already exists"
+ fi
+
+ [ -z "${PG_MAX_CONNECTIONS}" ] && PG_MAX_CONNECTIONS="128"
+ einfo "Checking system parameters..."
+
+ if ! use kernel_linux ; then
+ SKIP_SYSTEM_TESTS=yes
+ einfo " Tests not supported on this OS (yet)"
+ fi
+
+ if [ -z ${SKIP_SYSTEM_TESTS} ] ; then
+ einfo "Checking whether your system supports at least ${PG_MAX_CONNECTIONS} connections..."
+
+ local SEMMSL=$(sysctl -n kernel.sem | cut -f1)
+ local SEMMNS=$(sysctl -n kernel.sem | cut -f2)
+ local SEMMNI=$(sysctl -n kernel.sem | cut -f4)
+ local SHMMAX=$(sysctl -n kernel.shmmax)
+
+ local SEMMSL_MIN=17
+ local SEMMNS_MIN=$(( ( ${PG_MAX_CONNECTIONS}/16 ) * 17 ))
+ local SEMMNI_MIN=$(( ( ${PG_MAX_CONNECTIONS}+15 ) / 16 ))
+ local SHMMAX_MIN=$(( 500000 + ( 30600 * ${PG_MAX_CONNECTIONS} ) ))
+
+ for p in SEMMSL SEMMNS SEMMNI SHMMAX ; do
+ if [ $(eval echo \$$p) -lt $(eval echo \$${p}_MIN) ] ; then
+ eerror "The value for ${p} $(eval echo \$$p) is below the recommended value $(eval echo \$${p}_MIN)"
+ eerror "You have now several options:"
+ eerror " - Change the mentioned system parameter"
+ eerror " - Lower the number of max.connections by setting PG_MAX_CONNECTIONS to a value lower than ${PG_MAX_CONNECTIONS}"
+ eerror " - Set SKIP_SYSTEM_TESTS in case you want to ignore this test completely"
+ eerror "More information can be found here:"
+ eerror " http://www.postgresql.org/docs/${SLOT}/static/kernel-resources.html"
+ die "system test failed"
+ fi
+ done
+ einfo "Passed."
+ else
+ einfo "Skipped."
+ fi
+
+ einfo "Creating the data directory ..."
+ mkdir -p "${PGDATA}"
+ chown -Rf postgres:postgres "${PGDATA}"
+ chmod 0700 "${PGDATA}"
+
+ einfo "Initializing the database ..."
+
+ su postgres -c "/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb --pgdata \"${PGDATA}\" ${PG_INITDB_OPTS}"
+
+ einfo
+ einfo "You can use the '${ROOT}/etc/init.d/postgresql-${SLOT}' script to run PostgreSQL instead of 'pg_ctl'."
+ einfo
+
+ if [ "${PGDATA}" != "/var/lib/postgresql/${SLOT}/data" ] ; then
+ ewarn "You didn't install the database cluster in the standard location, please make sure that you set"
+ ewarn "PGDATA=\"${PGDATA}\" in the appropriate conf.d file (probably /etc/conf.d/postgresql-${SLOT})"
+ fi
+}
+
+src_test() {
+ sed -i \
+ -e '/test: horology/d' \
+ src/test/regress/{parallel_schedule,serial_schedule} || die "sed failed"
+
+ einfo ">>> Test phase [check]: ${CATEGORY}/${PF}"
+ PATH="/usr/$(get_libdir)/postgresql-${SLOT}/bin:${PATH}" \
+ emake -j1 check \
+ PGXS=$(/usr/$(get_libdir)/postgresql-${SLOT}/bin/pg_config --pgxs) \
+ NO_PGXS=0 USE_PGXS=1 SLOT=${SLOT} || die "Make check failed. See above for details."
+
+ einfo "Yes, there are other tests which could be run."
+ einfo "... and no, we don't plan to add/support them."
+ einfo "For now, the main regressions tests will suffice."
+ einfo "If you think other tests are necessary, please submit a"
+ einfo "bug including a patch for this ebuild to enable them."
+}