summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-07-29 06:17:43 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-07-29 06:17:43 +0000
commit3d44b0e7050f0897505f1d2462a5c9c554dc5aa4 (patch)
tree5faa735513a70f2cd19bd8f596fa783b05432aa8
parentFix media-libs/raptor depend to use old SLOTs; no raptor2 support in 2.6.51 (diff)
downloadhistorical-3d44b0e7050f0897505f1d2462a5c9c554dc5aa4.tar.gz
historical-3d44b0e7050f0897505f1d2462a5c9c554dc5aa4.tar.bz2
historical-3d44b0e7050f0897505f1d2462a5c9c554dc5aa4.zip
Version bump
Package-Manager: portage-2.1.10.7/cvs/Linux x86_64
-rw-r--r--sci-misc/apertium/ChangeLog10
-rw-r--r--sci-misc/apertium/apertium-3.2.0.ebuild36
-rw-r--r--sci-misc/apertium/files/3.2.0-datadir.patch35
-rw-r--r--sci-misc/apertium/files/3.2.0-flags.patch72
-rw-r--r--sci-misc/lttoolbox/ChangeLog8
-rw-r--r--sci-misc/lttoolbox/files/3.2.0-flags.patch43
-rw-r--r--sci-misc/lttoolbox/lttoolbox-3.1.0.ebuild14
-rw-r--r--sci-misc/lttoolbox/lttoolbox-3.2.0.ebuild28
-rw-r--r--sci-misc/vitables/ChangeLog8
-rw-r--r--sci-misc/vitables/metadata.xml3
-rw-r--r--sci-misc/vitables/vitables-2.1.ebuild42
11 files changed, 282 insertions, 17 deletions
diff --git a/sci-misc/apertium/ChangeLog b/sci-misc/apertium/ChangeLog
index b4ebae7789f5..0bec5343f456 100644
--- a/sci-misc/apertium/ChangeLog
+++ b/sci-misc/apertium/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-misc/apertium
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/apertium/ChangeLog,v 1.3 2009/08/23 12:25:51 flameeyes Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/apertium/ChangeLog,v 1.4 2011/07/29 06:13:10 bicatali Exp $
+
+*apertium-3.2.0 (29 Jul 2011)
+
+ 29 Jul 2011; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/3.2.0-datadir.patch, +files/3.2.0-flags.patch, +apertium-3.2.0.ebuild:
+ Version bump
23 Aug 2009; Diego E. Pettenò <flameeyes@gentoo.org>
apertium-3.1.0.ebuild:
diff --git a/sci-misc/apertium/apertium-3.2.0.ebuild b/sci-misc/apertium/apertium-3.2.0.ebuild
new file mode 100644
index 000000000000..b5f4c1625cb1
--- /dev/null
+++ b/sci-misc/apertium/apertium-3.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/apertium/apertium-3.2.0.ebuild,v 1.1 2011/07/29 06:13:10 bicatali Exp $
+
+EAPI=4
+inherit eutils autotools
+
+DESCRIPTION="Shallow-transfer machine Translation engine and toolbox"
+HOMEPAGE="http://apertium.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="virtual/libiconv
+ dev-libs/libxslt
+ dev-libs/libpcre[cxx]
+ >=sci-misc/lttoolbox-3.2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-flags.patch
+ epatch "${FILESDIR}"/${PV}-datadir.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_compile() {
+ # nasty to fix, be my guest, see apertium/Makefile.am
+ emake -j1
+}
diff --git a/sci-misc/apertium/files/3.2.0-datadir.patch b/sci-misc/apertium/files/3.2.0-datadir.patch
new file mode 100644
index 000000000000..d081cd50bc79
--- /dev/null
+++ b/sci-misc/apertium/files/3.2.0-datadir.patch
@@ -0,0 +1,35 @@
+diff -Nur apertium-3.2.0.orig/apertium/Makefile.am apertium-3.2.0/apertium/Makefile.am
+--- apertium-3.2.0.orig/apertium/Makefile.am 2011-07-29 06:55:49.000000000 +0100
++++ apertium-3.2.0/apertium/Makefile.am 2011-07-29 07:03:58.000000000 +0100
+@@ -66,10 +66,10 @@
+
+ instdir = apertium
+
+-apertiumdir = $(prefix)/share/apertium
++apertiumdir = $(datadir)/
+ apertiuminclude = $(prefix)/include/apertium-$(GENERIC_API_VERSION)
+ apertiumlib = $(prefix)/lib
+-apertiumsysconf = $(prefix)/etc/apertium
++apertiumsysconf = $(sysconfdir)/apertium
+
+ apertium_DATA = deformat.xsl reformat.xsl new2old.xsl lexchoice.xsl \
+ lexchoicebil.xsl tagger.dtd interchunk.dtd format.dtd \
+diff -Nur apertium-3.2.0.orig/Makefile.am apertium-3.2.0/Makefile.am
+--- apertium-3.2.0.orig/Makefile.am 2011-07-29 06:55:49.000000000 +0100
++++ apertium-3.2.0/Makefile.am 2011-07-29 07:08:39.000000000 +0100
+@@ -1,13 +1,10 @@
+ SUBDIRS = $(GENERIC_LIBRARY_NAME)
+ DIST_SUBDIRS = $(GENERIC_LIBRARY_NAME)
+
+-modesdir=$(prefix)/share/apertium/modes
++modesdir = $(datadir)/apertium/modes
++modes_DATA = README-MODES
+
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = apertium-$(GENERIC_RELEASE).pc
+
+ EXTRA_DIST=autogen.sh README-MODES
+-
+-install-data-local:
+- mkdir -p $(modesdir)
+- $(INSTALL_DATA) README-MODES $(modesdir)/README
diff --git a/sci-misc/apertium/files/3.2.0-flags.patch b/sci-misc/apertium/files/3.2.0-flags.patch
new file mode 100644
index 000000000000..9bdc4a34c117
--- /dev/null
+++ b/sci-misc/apertium/files/3.2.0-flags.patch
@@ -0,0 +1,72 @@
+diff -Nur apertium-3.2.0.orig/configure.ac apertium-3.2.0/configure.ac
+--- apertium-3.2.0.orig/configure.ac 2011-07-29 06:43:38.000000000 +0100
++++ apertium-3.2.0/configure.ac 2011-07-29 06:46:26.000000000 +0100
+@@ -54,68 +54,6 @@
+
+ # Checks for programs.
+
+-AC_MSG_CHECKING([Compilation architecture: PPC, i686, x86_64, Other])
+-if test x$(which arch) = x
+-then ARCH=$($(which uname) -m)
+-else ARCH=$($(which arch))
+-fi
+-
+-case "${target_os}" in
+- mingw*)
+- MinGW=yes
+- ;;
+- cygwin*)
+- Cygwin=yes
+- ;;
+-esac
+-
+-if test x$ARCH = xppc
+-then
+- AC_MSG_RESULT([PowerPC])
+- CFLAGS="$CFLAGS -Wall -ansi -fomit-frame-pointer"
+- CXXFLAGS="$CXXFLAGS -Wall -ansi -fomit-frame-pointer"
+-else
+- if test x$MinGW = xyes
+- then
+- AC_MSG_RESULT([MinGW])
+- CFLAGS="$CFLAGS -Wall -march=i686 -O3 -DMINGW -fomit-frame-pointer \
+- -funroll-loops -I/include -L/lib"
+- CXXFLAGS="$CXXFLAGS -Wall -march=i686 -O3 \
+- -fomit-frame-pointer -funroll-loops -I/include -L/lib"
+- CPPFLAGS="$CPPFLAGS -I/include"
+- else
+- if test x$Cygwin = xyes
+- then
+- AC_MSG_RESULT([Cygwin])
+- CFLAGS="$CFLAGS -Wall -march=i686 -O3 -fomit-frame-pointer \
+- -funroll-loops"
+- CXXFLAGS="$CXXFLAGS -Wall -march=i686 -O3 \
+- -fomit-frame-pointer -funroll-loops"
+- CPPFLAGS="$CPPFLAGS"
+- else
+- if test x$ARCH = xi686
+- then
+- AC_MSG_RESULT([i686])
+- CFLAGS="$CFLAGS -Wall -ansi -march=i686 -O3 -fomit-frame-pointer -funroll-loops"
+- CXXFLAGS="$CXXFLAGS -Wall -ansi -march=i686 -O3 \
+- -fomit-frame-pointer -funroll-loops"
+- else
+- if test x$ARCH = xx86_64
+- then
+- AC_MSG_RESULT([x86_64])
+- CFLAGS="-Wall -ansi -O3 -mtune=nocona -fomit-frame-pointer -funroll-loops $CFLAGS"
+- CXXFLAGS="-Wall -ansi -O3 -mtune=nocona \
+- -fomit-frame-pointer -funroll-loops $CXXFLAGS"
+- else
+- AC_MSG_RESULT([Other])
+- CFLAGS="-Wall -ansi -O3 $CFLAGS"
+- CXXFLAGS="-Wall -ansi -O3 $CXXFLAGS"
+- fi
+- fi
+- fi
+- fi
+-fi
+-
+ AC_PROG_CXX
+ AC_PROG_LIBTOOL
+ AM_SANITY_CHECK
diff --git a/sci-misc/lttoolbox/ChangeLog b/sci-misc/lttoolbox/ChangeLog
index 0f29a1694884..adec2e471584 100644
--- a/sci-misc/lttoolbox/ChangeLog
+++ b/sci-misc/lttoolbox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-misc/lttoolbox
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/lttoolbox/ChangeLog,v 1.4 2011/03/02 21:12:47 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/lttoolbox/ChangeLog,v 1.5 2011/07/29 06:11:09 bicatali Exp $
+
+*lttoolbox-3.2.0 (29 Jul 2011)
+
+ 29 Jul 2011; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/3.2.0-flags.patch, lttoolbox-3.1.0.ebuild, +lttoolbox-3.2.0.ebuild:
+ Version bump
02 Mar 2011; Justin Lecher <jlec@gentoo.org> lttoolbox-3.1.0.ebuild:
Correct Slots for gtk 3 introduction to tree
diff --git a/sci-misc/lttoolbox/files/3.2.0-flags.patch b/sci-misc/lttoolbox/files/3.2.0-flags.patch
new file mode 100644
index 000000000000..a6a56bf42c0d
--- /dev/null
+++ b/sci-misc/lttoolbox/files/3.2.0-flags.patch
@@ -0,0 +1,43 @@
+diff -Nur lttoolbox-3.2.0.orig/configure.ac lttoolbox-3.2.0/configure.ac
+--- lttoolbox-3.2.0.orig/configure.ac 2011-07-29 06:36:44.000000000 +0100
++++ lttoolbox-3.2.0/configure.ac 2011-07-29 06:38:04.000000000 +0100
+@@ -51,39 +51,6 @@
+
+ # Checks for programs.
+
+-AC_MSG_CHECKING([Compilation architecture: PPC, i686, x86_64, Other])
+-if test x$(which arch) = x
+-then ARCH=$($(which uname) -m)
+-else ARCH=$($(which arch))
+-fi
+-
+-if test x$ARCH = xppc
+-then
+- AC_MSG_RESULT([PowerPC])
+- CFLAGS="-Wall -fomit-frame-pointer $CFLAGS"
+- CXXFLAGS="-Wall -fomit-frame-pointer $CXXFLAGS"
+-else
+- if test x$ARCH = xi686
+- then
+- AC_MSG_RESULT([i686])
+- CFLAGS="-Wall -march=i686 -O3 -fomit-frame-pointer -funroll-loops $CFLAGS"
+- CXXFLAGS="-Wall -march=i686 -O3 \
+- -fomit-frame-pointer -funroll-loops $CXXFLAGS"
+-
+- else
+- if test x$ARCH = xx86_64
+- then
+- AC_MSG_RESULT([x86_64])
+- CFLAGS="-Wall -O3 -mtune=nocona -fomit-frame-pointer -funroll-loops $CFLAGS"
+- CXXFLAGS="-Wall -O3 -mtune=nocona \
+- -fomit-frame-pointer -funroll-loops $CXXFLAGS"
+- else
+- AC_MSG_RESULT([Other])
+- CFLAGS="-Wall -O3 $CFLAGS"
+- CXXFLAGS="-Wall -O3 $CXXFLAGS"
+- fi
+- fi
+-fi
+
+ AC_CANONICAL_HOST
+
diff --git a/sci-misc/lttoolbox/lttoolbox-3.1.0.ebuild b/sci-misc/lttoolbox/lttoolbox-3.1.0.ebuild
index 6f458441470d..eabc0dcf5f41 100644
--- a/sci-misc/lttoolbox/lttoolbox-3.1.0.ebuild
+++ b/sci-misc/lttoolbox/lttoolbox-3.1.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/lttoolbox/lttoolbox-3.1.0.ebuild,v 1.3 2011/03/02 21:12:47 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/lttoolbox/lttoolbox-3.1.0.ebuild,v 1.4 2011/07/29 06:11:09 bicatali Exp $
-EAPI="1"
+EAPI=4
DESCRIPTION="Toolbox for lexical processing, morphological analysis and generation of words"
HOMEPAGE="http://apertium.sourceforge.net"
@@ -10,17 +10,11 @@ SRC_URI="mirror://sourceforge/apertium/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="
- dev-libs/libxml2:2
+DEPEND="dev-libs/libxml2:2
dev-libs/libxslt
dev-libs/libpcre
sys-libs/libunwind"
RDEPEND="${DEPEND}"
-
-src_install() {
- emake install DESTDIR="${D}" || die "emake install failed"
- dodoc README AUTHORS ChangeLog || die "dodoc failed"
-}
diff --git a/sci-misc/lttoolbox/lttoolbox-3.2.0.ebuild b/sci-misc/lttoolbox/lttoolbox-3.2.0.ebuild
new file mode 100644
index 000000000000..1784feaae8bd
--- /dev/null
+++ b/sci-misc/lttoolbox/lttoolbox-3.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/lttoolbox/lttoolbox-3.2.0.ebuild,v 1.1 2011/07/29 06:11:09 bicatali Exp $
+
+EAPI=4
+inherit eutils autotools
+
+DESCRIPTION="Toolbox for lexical processing, morphological analysis and generation of words"
+HOMEPAGE="http://apertium.sourceforge.net"
+SRC_URI="mirror://sourceforge/apertium/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="dev-libs/libxml2:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-flags.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
diff --git a/sci-misc/vitables/ChangeLog b/sci-misc/vitables/ChangeLog
index c765873cc468..ef73aa50a467 100644
--- a/sci-misc/vitables/ChangeLog
+++ b/sci-misc/vitables/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-misc/vitables
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/vitables/ChangeLog,v 1.6 2011/06/18 17:16:53 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/vitables/ChangeLog,v 1.7 2011/07/29 06:17:43 bicatali Exp $
+
+*vitables-2.1 (29 Jul 2011)
+
+ 29 Jul 2011; Sébastien Fabbro <bicatali@gentoo.org> +vitables-2.1.ebuild,
+ metadata.xml:
+ Version bump
18 Jun 2011; Michał Januszewski <spock@gentoo.org> metadata.xml:
Reassigning to maintainer-needed.
diff --git a/sci-misc/vitables/metadata.xml b/sci-misc/vitables/metadata.xml
index 9044ac493c0e..b229aec85b8f 100644
--- a/sci-misc/vitables/metadata.xml
+++ b/sci-misc/vitables/metadata.xml
@@ -2,7 +2,4 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci</herd>
-<maintainer>
- <email>maintainer-needed@gentoo.org</email>
-</maintainer>
</pkgmetadata>
diff --git a/sci-misc/vitables/vitables-2.1.ebuild b/sci-misc/vitables/vitables-2.1.ebuild
new file mode 100644
index 000000000000..814c8a895166
--- /dev/null
+++ b/sci-misc/vitables/vitables-2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/vitables/vitables-2.1.ebuild,v 1.1 2011/07/29 06:17:43 bicatali Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
+
+DESCRIPTION="A graphical tool for browsing and editing files in both PyTables and HDF5 formats"
+HOMEPAGE="http://vitables.berlios.de/"
+SRC_URI="mirror://berlios/vitables/ViTables-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc examples"
+
+DEPEND="
+ >=dev-python/pytables-2.0
+ dev-python/PyQt4[X]" # FIXME: check if any other useflags are needed
+RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/ViTables-${PV}"
+
+src_install() {
+ dodir /usr/share/icons/hicolor/scalable/apps
+ dodir /usr/share/applications
+ XDG_DATA_DIRS="${D}/usr/share" distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${P}/examples
+ doins -r examples/* || die
+ fi
+
+ if use doc; then
+ dodoc doc/* || die
+ fi
+}