summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-06-14 20:40:37 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-06-14 20:40:37 +0000
commit40e58c3cc997787ea781b13dfa8820074e7c87f6 (patch)
treed63ed2de8a5becfa03dc4341bc5992477873aa52
parentMasked new postgresql for testing (diff)
downloadhistorical-40e58c3cc997787ea781b13dfa8820074e7c87f6.tar.gz
historical-40e58c3cc997787ea781b13dfa8820074e7c87f6.tar.bz2
historical-40e58c3cc997787ea781b13dfa8820074e7c87f6.zip
new revision
-rw-r--r--net-analyzer/ntop/ChangeLog8
-rw-r--r--net-analyzer/ntop/files/digest-ntop-2.0.99_rc21
-rw-r--r--net-analyzer/ntop/ntop-2.0.99_rc2.ebuild90
3 files changed, 98 insertions, 1 deletions
diff --git a/net-analyzer/ntop/ChangeLog b/net-analyzer/ntop/ChangeLog
index 8ed66b99cc3f..d1da6ef3d492 100644
--- a/net-analyzer/ntop/ChangeLog
+++ b/net-analyzer/ntop/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/ntop
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.2 2002/04/25 22:26:49 tutor Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.3 2002/06/14 20:40:37 rphillips Exp $
+
+*ntop-2.0.99_rc2 (14 Jun 2002)
+
+ 14 Jun 2002; Ryan Phillips <rphillips@gentoo.org> :
+
+ updated revision
*ntop-2.0 (1 Feb 2002)
diff --git a/net-analyzer/ntop/files/digest-ntop-2.0.99_rc2 b/net-analyzer/ntop/files/digest-ntop-2.0.99_rc2
new file mode 100644
index 000000000000..82665b332343
--- /dev/null
+++ b/net-analyzer/ntop/files/digest-ntop-2.0.99_rc2
@@ -0,0 +1 @@
+MD5 d2eebe53b21c954abd44f8b96483bf8c ntop-2.0.99-rc2.tgz 1828895
diff --git a/net-analyzer/ntop/ntop-2.0.99_rc2.ebuild b/net-analyzer/ntop/ntop-2.0.99_rc2.ebuild
new file mode 100644
index 000000000000..3cce6c5838c4
--- /dev/null
+++ b/net-analyzer/ntop/ntop-2.0.99_rc2.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>, Bruce A. Locke <blocke@shivan.org>
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-2.0.99_rc2.ebuild,v 1.1 2002/06/14 20:40:37 rphillips Exp $
+
+A=ntop-2.0.99-rc2.tgz
+S=${WORKDIR}/RC2/ntop
+DESCRIPTION="ntop is a unix tool that shows network usage like top"
+SRC_URI="http://luca.ntop.org/${A}"
+HOMEPAGE="http://www.ntop.org/ntop.html"
+DEPEND="virtual/glibc sys-devel/gcc
+ >=sys-libs/gdbm-1.8.0
+ >=net-libs/libpcap-0.5.2
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ mysql? ( dev-db/mysql )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ readline? ( >=sys-libs/readline-4.1 )"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use ssl`" ] ; then
+ myconf="--disable-ssl"
+ else
+ cp configure configure.orig
+ sed -e "s:/usr/local/ssl:/usr:" configure.orig > configure
+ export CFLAGS="$CFLAGS -I/usr/include/openssl"
+ fi
+
+ use mysql || myconf="${myconf} --disable-mysql"
+ use readline || myconf="${myconf} --disable-readline"
+ use tcpd || myconf="${myconf} --enable-tcpwrap"
+
+ # ntop 2.0 ships with its own version of gdchart... gdchart should
+ # get its own package but ntop should be built with the version it
+ # shipped with just in case future versions are incompatible -- blocke
+
+ # compile gdchart
+ cd ../gdchart0.94c
+ ./configure || die
+
+ # subtree #1
+ cd gd-1.8.3/libpng-1.2.1
+ make -f scripts/makefile.linux || die
+
+ # subtree #2
+ cd ../../zlib-1.1.4/
+ ./configure || die
+ make || die
+
+ # gdchart make
+ cd ../
+ make || die
+
+ # now ntop itself...
+ cd ../ntop
+ econf ${myconf} || die
+ make || die
+
+}
+
+src_install () {
+
+ # slight issue with man file installation
+ mv Makefile Makefile.orig
+ sed 's/man_MANS = ntop.8 intop\/intop.1//g' Makefile.orig > Makefile
+
+ make \
+ prefix=${D}/usr \
+ sysconfdir=/${D}/etc \
+ mandir=${D}/usr/share/man \
+ datadir=${D}/usr/share \
+ DATAFILE_DIR=${D}/usr/share/ntop \
+ CONFIGFILE_DIR=${D}/etc/ntop \
+ install || die
+
+ # fixme: bad handling of plugins (in /usr/lib with unsuggestive names)
+ # (don't know if there is a clean way to handle it)
+
+ doman ntop-rules.8 ntop.8
+
+ dodoc AUTHORS CONTENTS COPYING ChangeLog INSTALL MANIFESTO NEWS
+ dodoc PORTING README SUPPORT_NTOP.txt THANKS
+
+ dohtml ntop.html
+
+ dodir /var/lib/ntop
+}