summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Dawson <pkdawson@gentoo.org>2004-09-29 22:29:36 +0000
committerPatrick Dawson <pkdawson@gentoo.org>2004-09-29 22:29:36 +0000
commit4cfc5b05e9bedb07d4576105a196808d8ea3ae0b (patch)
treebfcce36c20557ac4ad77878caf22d3abb0de4f8d
parentgcc-3.4 fix, take 2 (diff)
downloadhistorical-4cfc5b05e9bedb07d4576105a196808d8ea3ae0b.tar.gz
historical-4cfc5b05e9bedb07d4576105a196808d8ea3ae0b.tar.bz2
historical-4cfc5b05e9bedb07d4576105a196808d8ea3ae0b.zip
gcc-3.4 fix, take 3, because I'm an idiot
-rw-r--r--media-video/mpgtx/Manifest8
-rw-r--r--media-video/mpgtx/mpgtx-1.3.ebuild8
2 files changed, 9 insertions, 7 deletions
diff --git a/media-video/mpgtx/Manifest b/media-video/mpgtx/Manifest
index 63be3a93c259..d3abdc129f6d 100644
--- a/media-video/mpgtx/Manifest
+++ b/media-video/mpgtx/Manifest
@@ -3,13 +3,13 @@ Hash: SHA1
MD5 4cb2b3474b6f1579f96f899b54e9912b ChangeLog 636
MD5 31018765c8c65a239dba78a98c405543 metadata.xml 224
-MD5 e319b297fdd0a11316056f20edb5ea59 mpgtx-1.3.ebuild 1370
+MD5 5c95fe8ab90e34edd844f8545786dd96 mpgtx-1.3.ebuild 1458
MD5 a3dbfa95d33bc0878275c94e9e6e8fe9 files/mpgtx-1.3-gcc34.patch 288
MD5 2f7766f539f18c11a67ea4d0ceaaadda files/digest-mpgtx-1.3 57
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)
-iD8DBQFBWzYHE67gNkjlZFIRAhixAKCeZozOWt93xfu7I7bNWPct87irkwCdFbU/
-+THmnra0yIlSzOkypTC8XuY=
-=iMCs
+iD8DBQFBWzdFE67gNkjlZFIRAvDHAJ9Ti4be9aGYR7mTBoB31mm/EbAYXgCghT2I
+cAopf/sCwnd+RH7mc+t0JDs=
+=Qx58
-----END PGP SIGNATURE-----
diff --git a/media-video/mpgtx/mpgtx-1.3.ebuild b/media-video/mpgtx/mpgtx-1.3.ebuild
index ed42a6a13a1c..4170598b2bcd 100644
--- a/media-video/mpgtx/mpgtx-1.3.ebuild
+++ b/media-video/mpgtx/mpgtx-1.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mpgtx/mpgtx-1.3.ebuild,v 1.8 2004/09/29 22:24:02 pkdawson Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mpgtx/mpgtx-1.3.ebuild,v 1.9 2004/09/29 22:29:36 pkdawson Exp $
-inherit eutils
+inherit eutils gcc
DESCRIPTION="mpgtx a command line MPEG audio/video/system file toolbox"
SRC_URI="mirror://sourceforge/mpgtx/${P}.tgz"
@@ -22,7 +22,9 @@ src_unpack() {
src_compile() {
./configure --parachute --prefix=/usr
- sed -i "s:-O3:-O3 -fno-unit-at-a-time:" Makefile
+ if [ "$(gcc-major-version)" -ge "3" -a "$(gcc-minor-version)" -ge "4" ]; then
+ sed -i "s:-O3:-O3 -fno-unit-at-a-time:" Makefile
+ fi
emake || die "emake failed"
}