summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-24 10:42:17 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-24 10:42:17 +0000
commit5057cc0643c70ec8c536834c059d386c8b47205e (patch)
tree2d6fff413d92e7c11baf03511bab31b3aa109c9f
parentmake warnings less dramatic (#134169) (diff)
downloadhistorical-5057cc0643c70ec8c536834c059d386c8b47205e.tar.gz
historical-5057cc0643c70ec8c536834c059d386c8b47205e.tar.bz2
historical-5057cc0643c70ec8c536834c059d386c8b47205e.zip
Nightlie bump.
Package-Manager: portage-2.1_rc2-r1
-rw-r--r--media-sound/mt-daapd/ChangeLog8
-rw-r--r--media-sound/mt-daapd/files/digest-mt-daapd-0.3.0_pre10823
-rw-r--r--media-sound/mt-daapd/mt-daapd-0.3.0_pre1082.ebuild140
3 files changed, 150 insertions, 1 deletions
diff --git a/media-sound/mt-daapd/ChangeLog b/media-sound/mt-daapd/ChangeLog
index 3152eb841f3a..c46c084ea28e 100644
--- a/media-sound/mt-daapd/ChangeLog
+++ b/media-sound/mt-daapd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/mt-daapd
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/ChangeLog,v 1.28 2006/05/22 00:08:29 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/ChangeLog,v 1.29 2006/05/24 10:42:17 flameeyes Exp $
+
+*mt-daapd-0.3.0_pre1082 (24 May 2006)
+
+ 24 May 2006; Diego Pettenò <flameeyes@gentoo.org>
+ -mt-daapd-0.3.0_pre1050.ebuild, +mt-daapd-0.3.0_pre1082.ebuild:
+ Nightlie bump.
*mt-daapd-0.3.0_pre1050 (22 May 2006)
diff --git a/media-sound/mt-daapd/files/digest-mt-daapd-0.3.0_pre1082 b/media-sound/mt-daapd/files/digest-mt-daapd-0.3.0_pre1082
new file mode 100644
index 000000000000..d78615a884df
--- /dev/null
+++ b/media-sound/mt-daapd/files/digest-mt-daapd-0.3.0_pre1082
@@ -0,0 +1,3 @@
+MD5 db81c999d01ef63305c25581a7cb482d mt-daapd-svn-1082.tar.gz 1126466
+RMD160 e175baa84431459fcb4b2a04f1b06ee926e779e7 mt-daapd-svn-1082.tar.gz 1126466
+SHA256 084c8eab2934b07bba1733a549cb5adc3f4cb33301a339e55f57e5c8699d01cb mt-daapd-svn-1082.tar.gz 1126466
diff --git a/media-sound/mt-daapd/mt-daapd-0.3.0_pre1082.ebuild b/media-sound/mt-daapd/mt-daapd-0.3.0_pre1082.ebuild
new file mode 100644
index 000000000000..8c0ed961c388
--- /dev/null
+++ b/media-sound/mt-daapd/mt-daapd-0.3.0_pre1082.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/mt-daapd-0.3.0_pre1082.ebuild,v 1.1 2006/05/24 10:42:17 flameeyes Exp $
+
+inherit eutils flag-o-matic base
+
+SVN="${PV#*pre}"
+
+if [[ -n ${SVN} ]] ; then
+ MY_P="${PN}-svn-${SVN}"
+ SRC_URI="http://nightlies.mt-daapd.org/${MY_P}.tar.gz"
+else
+ MY_P="${P/_/-}"
+ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+fi
+
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A multi-threaded implementation of Apple's DAAP server"
+HOMEPAGE="http://www.mt-daapd.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~sh ~sparc ~x86"
+IUSE="howl vorbis avahi sqlite3 flac"
+
+DEPEND="sys-libs/zlib
+ media-libs/libid3tag
+ !sqlite3? ( =dev-db/sqlite-2* )
+ sqlite3? ( =dev-db/sqlite-3* )
+ howl? ( !avahi? ( >=net-misc/howl-0.9.2 )
+ avahi? ( net-dns/avahi ) )
+ vorbis? ( media-libs/libvorbis )
+ flac? ( media-libs/flac )"
+
+pkg_setup() {
+ if use howl && use avahi && ! built_with_use net-dns/avahi howl-compat; then
+ eerror "You requested avahi support, but this package requires"
+ eerror "the howl-compat support enabled in net-dns/avahi to work"
+ eerror "with it."
+ eerror
+ eerror "Please recompile net-dns/avahi with +howl-compat."
+ die "Missing howl-compat support in avahi."
+ fi
+}
+
+src_compile() {
+ local myconf=""
+ local howlincludes
+
+ append-flags -fno-strict-aliasing
+
+ # howl support?
+ if use howl; then
+ use avahi && \
+ howlincludes="/usr/include/avahi-compat-howl" || \
+ howlincludes="/usr/include/howl"
+
+ myconf="${myconf}
+ --enable-howl
+ --with-howl-libs=/usr/$(get_libdir)
+ --with-howl-includes=${howlincludes}"
+ fi
+
+ # Bug 65723
+ if use vorbis; then
+ myconf="${myconf} --enable-oggvorbis"
+ fi
+
+ econf \
+ $(use_enable vorbis oggvorbis) \
+ $(use_enable flac) \
+ $(use_enable !sqlite3 sqlite) \
+ $(use_enable sqlite3) \
+ ${myconf} || die "configure failed"
+ emake || die "make failed"
+
+ cp ${FILESDIR}/${PN}.init.2 ${WORKDIR}/initd
+ if ! use howl; then
+ sed -i -e '/#USEHOWL/d' ${WORKDIR}/initd
+ elif ! use avahi; then
+ sed -i -e 's:#USEHOWL ::' ${WORKDIR}/initd
+ else
+ sed -i -e 's:#USEHOWL ::; s:mDNSResponder:avahi-daemon:' ${WORKDIR}/initd
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+
+ insinto /etc
+ newins ${FILESDIR}/mt-daapd.conf.example mt-daapd.conf.example
+ doins contrib/mt-daapd.playlist
+
+ newinitd ${WORKDIR}/initd ${PN}
+
+ keepdir /var/cache/mt-daapd /etc/mt-daapd.d
+
+ dodoc AUTHORS CREDITS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You have to configure your mt-daapd.conf following"
+ einfo "/etc/mt-daapd.conf.example file."
+ einfo
+
+ if use howl; then
+ use avahi && \
+ howlservice="avahi-daemon" || \
+ howlservice="mDNSResponder"
+
+ einfo
+ einfo "Since you want to use howl instead of the internal mdnsd"
+ einfo "you need to make sure that you have ${howlservice} configured"
+ einfo "and running to use mt-daapd."
+ einfo
+
+ if use avahi; then
+ einfo "Avahi support is currently experimental, it does not work"
+ einfo "as intended when using more than one mt-daapd instance."
+ einfo "If you want to run more than one mt-daapd, just use the"
+ einfo "internal mdnsd by building with -howl flag."
+ fi
+ fi
+
+ if use vorbis; then
+ einfo
+ einfo "You need to edit you extensions list in /etc/mt-daapd.conf"
+ einfo "if you want your mt-daapd to serve ogg files."
+ einfo
+ fi
+
+ einfo
+ einfo "If you want to start more than one ${PN} service, symlink"
+ einfo "/etc/init.d/${PN} to /etc/init.d/${PN}.<name>, and it will"
+ einfo "load the data from /etc/${PN}.d/<name>.conf."
+ einfo "Make sure that you have different cache directories for them."
+ einfo
+}