summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-13 12:10:49 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-13 12:10:49 +0000
commit5107d3cbff6bc9dd1c94287666b1d199b280c0fa (patch)
tree7376f68792343a7a73db9dbd504b7db1fe5bc1c9
parent*** empty log message *** (diff)
downloadhistorical-5107d3cbff6bc9dd1c94287666b1d199b280c0fa.tar.gz
historical-5107d3cbff6bc9dd1c94287666b1d199b280c0fa.tar.bz2
historical-5107d3cbff6bc9dd1c94287666b1d199b280c0fa.zip
*** empty log message ***
-rw-r--r--app-cdr/cdrecord/files/digest1
-rw-r--r--app-editors/joe/joe-2.8-r1.ebuild5
-rw-r--r--app-shells/ccsh/ccsh-0.0.4-r1.ebuild32
-rw-r--r--app-shells/ccsh/files/digest1
-rw-r--r--app-shells/esh/esh-0.8-r1.ebuild40
-rw-r--r--app-shells/esh/files/digest1
-rw-r--r--app-shells/sash/files/digest1
-rw-r--r--app-shells/sash/sash-3.4-r1.ebuild34
-rwxr-xr-xdev-db/mysql/files/mysql6
-rw-r--r--dev-db/mysql/mysql-3.22.32-r1.ebuild12
-rw-r--r--dev-util/yacc/files/digest1
-rw-r--r--dev-util/yacc/yacc-1.9.1-r1.ebuild34
12 files changed, 157 insertions, 11 deletions
diff --git a/app-cdr/cdrecord/files/digest b/app-cdr/cdrecord/files/digest
new file mode 100644
index 000000000000..b9745b46e2f9
--- /dev/null
+++ b/app-cdr/cdrecord/files/digest
@@ -0,0 +1 @@
+MD5 0fa360d9280d16370d7738ec0b62affb cdrecord-1.9.tar.gz
diff --git a/app-editors/joe/joe-2.8-r1.ebuild b/app-editors/joe/joe-2.8-r1.ebuild
index 0676a04a73eb..6430484723de 100644
--- a/app-editors/joe/joe-2.8-r1.ebuild
+++ b/app-editors/joe/joe-2.8-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-2.8-r1.ebuild,v 1.2 2000/08/07 11:29:13 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-2.8-r1.ebuild,v 1.3 2000/08/13 12:10:49 achim Exp $
P=joe-2.8
A=joe2.8.tar.Z
S=${WORKDIR}/joe
-CATEGORY="app-misc"
+CATEGORY="app-editors"
DESCRIPTION="A free ASCII-Text Screen Editor for UNIX"
SRC_URI="ftp://ftp.std.com/src/editors/"${A}
@@ -47,3 +47,4 @@ src_install() {
+
diff --git a/app-shells/ccsh/ccsh-0.0.4-r1.ebuild b/app-shells/ccsh/ccsh-0.0.4-r1.ebuild
new file mode 100644
index 000000000000..41aefb19ce84
--- /dev/null
+++ b/app-shells/ccsh/ccsh-0.0.4-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ccsh/ccsh-0.0.4-r1.ebuild,v 1.1 2000/08/13 12:10:49 achim Exp $
+
+P=ccsh-0.0.4
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="UNIX Shell for people already familiar with the C language"
+SRC_URI="http://download.sourceforge.net/ccsh/"${A}
+HOMEPAGE="http://ccsh.sourceforge.net"
+CATEGORY="app-shells"
+
+src_compile() {
+ cd ${S}
+
+ make CFLAGS="${CFLAGS}" all
+}
+
+src_install() {
+ cd ${S}
+ into /
+ dobin ccsh
+ into /usr
+ newman ccsh.man ccsh.1
+ dodoc ChangeLog COPYING README TODO
+}
+
+
+
+
+
diff --git a/app-shells/ccsh/files/digest b/app-shells/ccsh/files/digest
new file mode 100644
index 000000000000..25a513ed0f28
--- /dev/null
+++ b/app-shells/ccsh/files/digest
@@ -0,0 +1 @@
+MD5 042a8596065e49dccf154b661e2444a9 ccsh-0.0.4.tar.gz
diff --git a/app-shells/esh/esh-0.8-r1.ebuild b/app-shells/esh/esh-0.8-r1.ebuild
new file mode 100644
index 000000000000..fc751fcdf00e
--- /dev/null
+++ b/app-shells/esh/esh-0.8-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-shells/esh/esh-0.8-r1.ebuild,v 1.1 2000/08/13 12:10:49 achim Exp $
+
+P=esh-0.8
+A=${P}.tar.gz
+S=${WORKDIR}/esh
+DESCRIPTION="A UNIX Shell with a simplified Scheme syntax"
+SRC_URI="http://esh.netpedia.net/"${A}
+HOMEPAGE="http://esh.netpedia.net/"
+CATEGORY="app-shells"
+
+src_compile() {
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed -e "s:^CFLAGS=:CFLAGS=${CFLAGS} :" \
+ -e "s:^LIB=:LIB=-lncurses :" Makefile.orig > Makefile
+ make
+}
+
+src_install() {
+ cd ${S}
+ into /
+ dobin esh
+ into /usr
+ doinfo doc/esh.info
+ dodoc CHANGELOG CREDITS GC_README HEADER LICENSE READLNE-HACKS TODO
+ docinto html
+ dodoc doc/*.html
+ docinto examples
+ dodoc examples/*
+ insinto /usr/share/emacs/site-lisp/
+ doins emacs/esh-mode.el
+}
+
+
+
+
+
diff --git a/app-shells/esh/files/digest b/app-shells/esh/files/digest
new file mode 100644
index 000000000000..4ea7be5f1d42
--- /dev/null
+++ b/app-shells/esh/files/digest
@@ -0,0 +1 @@
+MD5 b59022b88bae24420156d25869b8be54 esh-0.8.tar.gz
diff --git a/app-shells/sash/files/digest b/app-shells/sash/files/digest
new file mode 100644
index 000000000000..d8d6a75468ab
--- /dev/null
+++ b/app-shells/sash/files/digest
@@ -0,0 +1 @@
+MD5 9c631eb171371b69276ff6692100beb6 sash-3.4.tar.gz
diff --git a/app-shells/sash/sash-3.4-r1.ebuild b/app-shells/sash/sash-3.4-r1.ebuild
new file mode 100644
index 000000000000..71049560c8d0
--- /dev/null
+++ b/app-shells/sash/sash-3.4-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.4-r1.ebuild,v 1.1 2000/08/13 12:10:49 achim Exp $
+
+P=sash-3.4
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A small UNIX Shell"
+SRC_URI="http://www.canb.auug.org.au/~dbell/programs/"${A}
+HOMEPAGE="http://www.canb.auug.org.au/~dbell/"
+CATEGORY="app-shells"
+
+src_compile() {
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed -e "s:-O3:${CFLAGS}:" Makefile.orig > Makefile
+ make
+}
+
+src_install() {
+ cd ${S}
+ into /
+ dobin sash
+ into /usr
+ doman sash.1
+ dodoc README
+
+}
+
+
+
+
+
diff --git a/dev-db/mysql/files/mysql b/dev-db/mysql/files/mysql
index f0a6ea019a13..4aef25c9a38c 100755
--- a/dev-db/mysql/files/mysql
+++ b/dev-db/mysql/files/mysql
@@ -74,6 +74,11 @@ fi
cd $basedir
start() {
+ # Create db on first start
+ if [ ! -d /var/mysql/mysql ]
+ then
+ /usr/bin/mysql_install_db
+ fi
# Start daemon
if test -x $bindir/safe_mysqld
@@ -112,3 +117,4 @@ restart () {
doservice ${@}
+
diff --git a/dev-db/mysql/mysql-3.22.32-r1.ebuild b/dev-db/mysql/mysql-3.22.32-r1.ebuild
index 6398927d779a..cfe34c3979cb 100644
--- a/dev-db/mysql/mysql-3.22.32-r1.ebuild
+++ b/dev-db/mysql/mysql-3.22.32-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.22.32-r1.ebuild,v 1.2 2000/08/13 05:28:48 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.22.32-r1.ebuild,v 1.3 2000/08/13 12:10:49 achim Exp $
A=${P}.tar.gz
DESCRIPTION="The MySQL Database"
@@ -81,17 +81,11 @@ src_install() {
}
-pkg_postinst () {
+pkg_config () {
- . ${ROOT}/var/lib/packages/install.config
- if [ "$ROOT" == "/" ] ; then
- /usr/bin/mysql_install_db
- /etc/rc.d/init.d/mysql start
- sleep 5
- /usr/bin/mysqladmin password $MySQLpass
- fi
echo "Setting up symlinks..."
${ROOT}/usr/sbin/rc-update add mysql
}
+
diff --git a/dev-util/yacc/files/digest b/dev-util/yacc/files/digest
new file mode 100644
index 000000000000..0fbb5ecdd357
--- /dev/null
+++ b/dev-util/yacc/files/digest
@@ -0,0 +1 @@
+MD5 3bcf50bece4ef1d0fbaf479e25790437 yacc-1.9.1.tar.Z
diff --git a/dev-util/yacc/yacc-1.9.1-r1.ebuild b/dev-util/yacc/yacc-1.9.1-r1.ebuild
new file mode 100644
index 000000000000..d26f4c632f5e
--- /dev/null
+++ b/dev-util/yacc/yacc-1.9.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-util/yacc/yacc-1.9.1-r1.ebuild,v 1.1 2000/08/13 12:10:49 achim Exp $
+
+P=yacc-1.9.1
+A=${P}.tar.Z
+S=${WORKDIR}/${P}
+CATEGORY="dev-util"
+DESCRIPTION="Yacc"
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/devel/compiler-tools/${A}"
+
+src_unpack () {
+ unpack ${A}
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed -e "s:-O:${CFLAGS}:" Makefile.orig > Makefile
+}
+src_compile() {
+ make clean
+ make
+}
+
+src_install() {
+ into /usr
+ dobin yacc
+ doman yacc.1
+ dodoc 00README* ACKNOWLEDGEMENTS NEW_FEATURES NO_WARRANTY NOTES README*
+ ln -s /usr/lib/cvs/contrib ${D}/usr/doc/${P}/contrib
+}
+
+
+
+