summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2004-08-26 01:51:45 +0000
committerSeemant Kulleen <seemant@gentoo.org>2004-08-26 01:51:45 +0000
commit81b4dfef6e80d65edd787f71cf2cbfead7d228ca (patch)
tree671f8b43c1cb252df52b7a855b450fb6bb644d5c
parentfix DEPEND #61666 (diff)
downloadhistorical-81b4dfef6e80d65edd787f71cf2cbfead7d228ca.tar.gz
historical-81b4dfef6e80d65edd787f71cf2cbfead7d228ca.tar.bz2
historical-81b4dfef6e80d65edd787f71cf2cbfead7d228ca.zip
remove crufty ebuild
-rw-r--r--sys-apps/coreutils/Manifest2
-rw-r--r--sys-apps/coreutils/coreutils-5.0.91-r4.ebuild164
-rw-r--r--sys-apps/coreutils/files/digest-coreutils-5.0.91-r43
3 files changed, 0 insertions, 169 deletions
diff --git a/sys-apps/coreutils/Manifest b/sys-apps/coreutils/Manifest
index 7c7ab9495961..c664b2ea7a13 100644
--- a/sys-apps/coreutils/Manifest
+++ b/sys-apps/coreutils/Manifest
@@ -3,10 +3,8 @@ MD5 bf1b2c48440b42ed8176457c2428fcd4 coreutils-5.2.1.ebuild 4043
MD5 992f0ec91891e7ddbcf466dfce3dd857 coreutils-5.2.0-r2.ebuild 4172
MD5 1ce51fdb0c8a9ce07b454d66413e6d09 coreutils-5.0-r6.ebuild 2656
MD5 a8e396d61dd3eeea13e98e0354e1ea8f coreutils-5.2.1-r1.ebuild 4146
-MD5 b48125a80955256b99cb3fdb15d4dd3f coreutils-5.0.91-r4.ebuild 4209
MD5 6ab085a4d1749a9962658ca2d5aa3380 ChangeLog 21159
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 9e4492e1c7e9c927ad7c492239dbe029 files/digest-coreutils-5.0.91-r4 229
MD5 5a7d722a7600e8834bf39c24790caaa2 files/003_all_coreutils-gentoo-uname-s390.patch 3120
MD5 6a9f5a2ffa31d94987039066c5072982 files/digest-coreutils-5.2.0-r2 224
MD5 316d769e60be0f94af3e3c957a664aec files/digest-coreutils-5.2.1-r1 225
diff --git a/sys-apps/coreutils/coreutils-5.0.91-r4.ebuild b/sys-apps/coreutils/coreutils-5.0.91-r4.ebuild
deleted file mode 100644
index ded6c6abf21e..000000000000
--- a/sys-apps/coreutils/coreutils-5.0.91-r4.ebuild
+++ /dev/null
@@ -1,164 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.0.91-r4.ebuild,v 1.21 2004/06/28 18:32:47 vapier Exp $
-
-inherit eutils flag-o-matic
-
-PATCH_VER=1.4.7
-I18N_PATCH=i18n-0.2
-PATCHDIR=${WORKDIR}/patch
-
-DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls...), text utilities (sort, tr, head, wc..), and shell utilities (whoami, who,...)"
-HOMEPAGE="http://www.gnu.org/software/coreutils/"
-SRC_URI="mirror://gnu/coreutils/${P}.tar.bz2
- mirror://coreutils/${P}.tar.bz2
- http://www.openi18n.org/subgroups/utildev/patch/${P}-${I18N_PATCH}.patch.gz
- mirror://gentoo/${P}-gentoo-${PATCH_VER}.tar.bz2
- mirror://gentoo/${P}-gentoo-${PATCH_VER}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ~ppc sparc mips alpha hppa ~amd64 ia64 ppc64 s390"
-IUSE="nls build acl selinux static"
-
-RDEPEND="selinux? ( sys-libs/libselinux )
- acl? ( !hppa? ( sys-apps/acl sys-apps/attr ) )
- nls? ( sys-devel/gettext )
- >=sys-libs/ncurses-5.3-r5"
-DEPEND="${RDEPEND}
- virtual/libc
- >=sys-apps/portage-2.0.49
- >=sys-devel/automake-1.7.6
- >=sys-devel/autoconf-2.57
- >=sys-devel/m4-1.4-r1
- sys-apps/help2man"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
-
- if use acl && use selinux
- then
- ewarn "Both ACL and SELINUX are not supported together!"
- ewarn "Will Select SELINUX instead"
- fi
-
- # Mandrake's lsw patch caused issues on ia64 and amd64 with ls
- # Reported upstream, but we don't apply it for now
-# mv ${PATCHDIR}/mandrake/019* ${PATCHDIR}/excluded
-
- EPATCH_SUFFIX="patch" epatch ${PATCHDIR}/mandrake
- epatch ${WORKDIR}/${P}-${I18N_PATCH}.patch
-
- # ARM platform does not work well with the uname patch
- # (see below about it)
- if use arm
- then
- mv ${PATCHDIR}/003* ${PATCHDIR}/excluded
- fi
-
- # Apply the ACL patches.
- # WARNING: These CONFLICT with the SELINUX patches
- if use acl
- then
- #
- # This one also needs porting like the rest, but its a bit more involved,
- # so I will leave it for somebody that use i18n that can actually test it.
- #
- # if ! use nls ; then
- mv ${PATCHDIR}/acl/004* ${PATCHDIR}/excluded
- # fi
-
- # This test do seem to be fixed in another way, the acl guys
- # can just verify please ...
- mv ${PATCHDIR}/acl/006* ${PATCHDIR}/excluded
-
- use selinux || mv ${PATCHDIR}/{001*,002*,004*} ${PATCHDIR}/excluded
- use selinux || EPATCH_SUFFIX="patch" epatch ${PATCHDIR}/acl
- fi
-
- # patch to remove Stallman's su/wheel group rant (which doesn't apply,
- # since Gentoo's su is not GNU/su, but that from shadow.
- # do not include su infopage, as it is not valid for the su
- # from sys-apps/shadow that we are using.
- # Patch to add processor specific info to the uname output
-
- EPATCH_SUFFIX="patch" epatch ${PATCHDIR}
-
- use selinux && EPATCH_SUFFIX="patch" epatch ${PATCHDIR}/selinux
-
- use ppc64 && epatch ${FILESDIR}/coreutils-5.0.91-ppc64-1.patch
-}
-
-src_compile() {
- local myconf=
- use nls || myconf="--disable-nls"
-
- if use acl
- then
- if ! use selinux
- then
- if [ -z "`which cvs 2>/dev/null`" ]
- then
- # Fix issues with gettext's autopoint if cvs is not installed,
- # bug #28920.
- export AUTOPOINT="/bin/true"
- fi
- mv m4/inttypes.m4 m4/inttypes-eggert.m4
- fi
- fi
-
- export WANT_AUTOMAKE=1.7
-
- aclocal -I ${S}/m4 || die
- autoconf || die
- automake || die
-
- econf \
- --bindir=/bin \
- ${myconf} || die
-
- if use static
- then
- emake LDFLAGS=-static || die
- else
- emake || die
- fi
-}
-
-src_install() {
- einstall \
- bindir=${D}/bin || die
-
- cd ${D}
- dodir /usr/bin
- rm -rf usr/lib
-
- # move non-critical packages into /usr
- mv bin/{csplit,expand,factor,fmt,fold,install,join,md5sum,nl,od} usr/bin
- mv bin/{paste,pathchk,pinky,pr,printf,sha1sum,shred,sum,tac} usr/bin
- mv bin/{tail,test,tsort,unexpand,users} usr/bin
- cd usr/bin
- ln -s ../../bin/* .
-
- cd ../../bin
- ln -s ../usr/bin/install .
-
- if ! use build
- then
- cd ${S}
- dodoc AUTHORS ChangeLog* COPYING NEWS README* THANKS TODO
- else
- rm -rf ${D}/usr/share
- fi
-}
-
-pkg_postinst() {
- # hostname does not get removed as it is included with older stage1
- # tarballs, and net-tools installs to /bin
- if [ -e ${ROOT}/usr/bin/hostname ] && [ ! -L ${ROOT}/usr/bin/hostname ]
- then
- rm -f ${ROOT}/usr/bin/hostname
- fi
-}
diff --git a/sys-apps/coreutils/files/digest-coreutils-5.0.91-r4 b/sys-apps/coreutils/files/digest-coreutils-5.0.91-r4
deleted file mode 100644
index ee1ff6d1cdeb..000000000000
--- a/sys-apps/coreutils/files/digest-coreutils-5.0.91-r4
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 e62c18cde8b254c2512e47dd0c47c332 coreutils-5.0.91.tar.bz2 4183673
-MD5 816c0a3ebdf9f66d004d822dd94b3864 coreutils-5.0.91-i18n-0.2.patch.gz 26150
-MD5 28f196ba038e9524c50d3d606f178bac coreutils-5.0.91-gentoo-1.4.7.tar.bz2 85653