summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2003-07-13 09:08:26 +0000
committerDan Armak <danarmak@gentoo.org>2003-07-13 09:08:26 +0000
commit94542e2b920d3ba2888d3a3f9342a507c363bf61 (patch)
tree4bfa75707bd9df646f34c83a5e184fb744e1ce20
parentversion bump (diff)
downloadhistorical-94542e2b920d3ba2888d3a3f9342a507c363bf61.tar.gz
historical-94542e2b920d3ba2888d3a3f9342a507c363bf61.tar.bz2
historical-94542e2b920d3ba2888d3a3f9342a507c363bf61.zip
support for the new kde-i18n live cvs ebuilds. shouldn't affect anything else in any way.
-rw-r--r--eclass/kde-i18n.eclass46
-rw-r--r--eclass/kde-source.eclass48
2 files changed, 71 insertions, 23 deletions
diff --git a/eclass/kde-i18n.eclass b/eclass/kde-i18n.eclass
index a62704c7fa97..b33e4e3c6a3f 100644
--- a/eclass/kde-i18n.eclass
+++ b/eclass/kde-i18n.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde-i18n.eclass,v 1.44 2003/02/22 08:36:54 carpaski Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde-i18n.eclass,v 1.45 2003/07/13 09:08:26 danarmak Exp $
#
# Author Dan Armak <danarmak@gentoo.org>
@@ -38,17 +38,31 @@ case "$PV" in
KEYWORDS="x86 ppc";;
3*) SRC_PATH="stable/${PV}/src/kde-i18n/${P}.tar.bz2"
KEYWORDS="x86 ppc";;
+ 5) KEYWORDS="x86";;
esac
-if [ "$PN" == "kde-i18n" ]; then
+if [ "$PV" == "5" ]; then
+ S=${WORKDIR}/kde-i18n
+elif [ "$PN" == "kde-i18n" ]; then
SRC_PATH=${SRC_PATH/src\/kde-i18n\//src\//}
S=${WORKDIR}/${RP}
fi
-SRC_URI="$SRC_URI mirror://kde/$SRC_PATH"
+# for cvs ebuilds we don't need to fetch tarballs
+if [ "$PV" != "5" ]; then
+ SRC_URI="$SRC_URI mirror://kde/$SRC_PATH"
+fi
kde-i18n_src_unpack() {
- base_src_unpack
+
+ if [ "$PV" == "5" ]; then
+ KCVS_MODULE=kde-i18n
+ [ "$PN" != "kde-i18n" ] && KCVS_SUBDIR="${PN//kde-i18n-}"
+ KCVS_SUBDIR_NODOC=true
+ kde-source_src_unpack
+ else
+ base_src_unpack
+ fi
for dir in ${S} `cat ${S}/subdirs`; do
if [ -f "$dir/docs/common/Makefile.in" ]; then
@@ -58,13 +72,35 @@ kde-i18n_src_unpack() {
sed -e 's:(kde_htmldir)/en/common:(kde_libs_htmldir)/en/common:g' Makefile.in.orig > Makefile.in
fi
done
+
+ if [ "$PV" == "5" -a "$PN" != "kde-i18n" ]; then
+ cd $S
+ echo ${PN//kde-i18n-/} > subdirs
+ fi
+
}
kde-i18n_src_compile() {
kde_src_compile myconf
myconf="$myconf --prefix=$KDEDIR"
- kde_src_compile configure make
+
+ # enable caching because that makes running all the configure scripts in the subdirs faster
+ # (for cvs i18n packages)
+ myconf="$myconf -C"
+
+ kde_src_compile configure
+
+ # wierd, but this is apparently equired by what's in kde i18n cvs nowadays
+ if [ "$PV" == "5" ]; then
+ for x in `cat subdirs`; do
+ cd $S/$x
+ test -f ./configure && ( ./configure --cache-file=../config.cache $myconf || die "configure failed" )
+ done
+ fi
+
+ cd $S
+ kde_src_compile make
}
diff --git a/eclass/kde-source.eclass b/eclass/kde-source.eclass
index 32860105b149..46310338d701 100644
--- a/eclass/kde-source.eclass
+++ b/eclass/kde-source.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde-source.eclass,v 1.15 2003/04/19 11:52:50 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde-source.eclass,v 1.16 2003/07/13 09:08:26 danarmak Exp $
#
# Author Dan Armak <danarmak@gentoo.org>
#
@@ -33,23 +33,18 @@ INHERITED="$INHERITED $ECLASS"
[ -z "$ECVS_SERVER" ] && ECVS_SERVER="anoncvs.kde.org:/home/kde"
[ -z "$ECVS_AUTH" ] && ECVS_AUTH="pserver"
-# ECVS_SUBDIR reimplementation
-if [ -n "$KCVS_SUBDIR" ]; then
- ECVS_MODULE="$KCVS_MODULE/$KCVS_SUBDIR"
- S="$WORKDIR/$KCVS_MODULE"
-elif [ -n "$KCVS_MODULE" ]; then
- ECVS_MODULE="$KCVS_MODULE"
- S="$WORKDIR/$KCVS_MODULE"
-else
- # default for kde-base ebuilds
- ECVS_MODULE="$PN"
- S="$WORKDIR/$ECVS_MODULE"
-fi
+# for apps living inside modules like kdenonbeta - see beginning of our _src_unpack
+# KCVS_SUBDIR=...
# If a tag is specified as ECVS_BRANCH, it will be used for the kde-common module
# as well. If that is wrong (fex when checking out kopete branch kopete_0_6_2_release),
# use KCVS_BRANCH instead.
+# you can set this variable (in your ebuild, of course) to disable fetching of <module>/doc/*
+# under the KCVS_SUBDIR scheme. this is appropriate for kde-i18n stuff, but not for
+# eg kdeextragear, kdenonbeta etc.
+# KCVS_SUBDIR_NODOC=true
+
# Other variables: see cvs.eclass
# we do this here and not in the very beginning because we need to keep
@@ -73,7 +68,19 @@ kde-source_src_unpack() {
debug-print-function $FUNCNAME $*
- cvs_src_unpack
+ if [ -n "$KCVS_SUBDIR" ]; then
+ ECVS_MODULE="$KCVS_MODULE/$KCVS_SUBDIR"
+ S="$WORKDIR/$KCVS_MODULE"
+ elif [ -n "$KCVS_MODULE" ]; then
+ ECVS_MODULE="$KCVS_MODULE"
+ S="$WORKDIR/$KCVS_MODULE"
+ else
+ # default for kde-base ebuilds
+ ECVS_MODULE="$PN"
+ S="$WORKDIR/$ECVS_MODULE"
+ fi
+
+ cvs_src_unpack
# subdirs of kde modules get special treatment that is designed for
# subdirs which are separate selfcontained apps and only need
@@ -81,23 +88,28 @@ kde-source_src_unpack() {
# this fits for apps from kdenonbeta, kdeextragear modules etc.
# So, if we just fetched a module's subdir, fetch the top directory
# of the module (non-recursively) and make it build only the subdirectory
- # we need
+ # we need.
+ # ECVS_LOCALNAME note: disabled when KCVS_SUBDIR is enabled because the logic
+ # of how it should work is unclear and I don't see any need for it here anyway
if [ -n "$KCVS_SUBDIR" ]; then
if [ -n "$KCVS_BRANCH" ]; then
ECVS_BRANCH2="$ECVS_BRANCH"
ECVS_BRANCH="$KCVS_BRANCH"
fi
-
+
ECVS_MODULE="$KCVS_MODULE" ECVS_LOCAL=yes cvs_src_unpack
# we need the <module>/doc/<name> directory too,
# and we need the top-level doc/ directory fetched locally
ECVS_MODULE="${KCVS_MODULE}/doc" ECVS_LOCAL=yes cvs_src_unpack
+
# but, if such a directory doesn't exist on the cvs server and we're
# in offline mode cvs.eclass will abort, so only call this if we're
# in online mode or the dir is already fetched
- if [ -d "$ECVS_TOP_DIR/$KCVS_MODULE/doc/$KCVS_SUBDIR" -o "$ECVS_SERVER" != "offline" ]; then
+ # also, the ebuild might have disabled this functionality explicitly
+ # (kde-i18n stuff does this for now)
+ if [ -z "$KCVS_SUBDIR_NODOC" ] && [ -d "$ECVS_TOP_DIR/$KCVS_MODULE/doc/$KCVS_SUBDIR" -o "$ECVS_SERVER" != "offline" ]; then
ECVS_MODULE="${KCVS_MODULE}/doc/${KCVS_SUBDIR}" cvs_src_unpack
fi
@@ -107,7 +119,7 @@ kde-source_src_unpack() {
fi
- # typically for kde cvs, the admin subdir lives in the kde-common module
+ # typically for kde cvs apps, the admin subdir lives in the kde-common module
# which is also needed
if [ ! -d "$S/admin" ]; then
ECVS_MODULE="kde-common/admin" cvs_src_unpack