summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-06-29 23:17:13 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-06-29 23:17:13 +0000
commita10196b62eac547322773b38703eeb871a8ccda8 (patch)
treed687be1b508ad37cbeae728fde30c60c6fbb88d2
parentfix unmerge (diff)
downloadhistorical-a10196b62eac547322773b38703eeb871a8ccda8.tar.gz
historical-a10196b62eac547322773b38703eeb871a8ccda8.tar.bz2
historical-a10196b62eac547322773b38703eeb871a8ccda8.zip
update to use libtool.eclass
-rw-r--r--sys-devel/binutils/binutils-2.12.90.0.7.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/sys-devel/binutils/binutils-2.12.90.0.7.ebuild b/sys-devel/binutils/binutils-2.12.90.0.7.ebuild
index 25421e48365f..1910e7ff5884 100644
--- a/sys-devel/binutils/binutils-2.12.90.0.7.ebuild
+++ b/sys-devel/binutils/binutils-2.12.90.0.7.ebuild
@@ -2,19 +2,24 @@
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: System Team <system@gentoo.org>
# Author: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.12.90.0.7.ebuild,v 1.1 2002/04/25 20:27:26 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.12.90.0.7.ebuild,v 1.2 2002/06/29 23:17:13 azarah Exp $
# NOTE to Maintainer: ChangeLog states that it no longer use perl to build
# the manpages, but seems this is incorrect ....
+inherit libtool
+
S=${WORKDIR}/${P}
DESCRIPTION="Tools necessary to build programs"
SRC_URI="ftp://ftp.kernel.org/pub/linux/devel/binutils/${P}.tar.bz2"
+SLOT="0"
+
DEPEND="virtual/glibc
nls? ( sys-devel/gettext )"
-[ -z "`use build`" ] && [ -z "`use bootstrap`" ] && DEPEND="${DEPEND} sys-devel/perl"
+[ -z "`use build`" ] && [ -z "`use bootstrap`" ] && \
+ DEPEND="${DEPEND} sys-devel/perl"
src_compile() {
@@ -26,7 +31,7 @@ src_compile() {
# DO NOT LIBTOOLIZE, AS BINUTILS COME WITH ITS OWN VERSION
# OF LIBTOOL!!!!!!!
- libtoolize --copy --force
+ elibtoolize --portage
./configure --enable-shared \
--enable-64-bit-bfd \