summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2001-11-03 01:45:56 +0000
committerMartin Schlemmer <azarah@gentoo.org>2001-11-03 01:45:56 +0000
commitb60c77bf3eeb8f9aeb161fdce98490156a5a3b63 (patch)
treeaf2716a2dd885f671ccfcf7751d8a559cc726702
parentnew version (diff)
downloadhistorical-b60c77bf3eeb8f9aeb161fdce98490156a5a3b63.tar.gz
historical-b60c77bf3eeb8f9aeb161fdce98490156a5a3b63.tar.bz2
historical-b60c77bf3eeb8f9aeb161fdce98490156a5a3b63.zip
removed buggy gdk-pixbuf; updated bonobo and ORBit, but since it can cause problems with evolution, masked it
-rw-r--r--gnome-base/ORBit/ORBit-0.5.12.ebuild53
-rw-r--r--gnome-base/ORBit/files/digest-ORBit-0.5.121
-rw-r--r--gnome-base/bonobo/bonobo-1.0.14.ebuild53
-rw-r--r--gnome-base/bonobo/files/digest-bonobo-1.0.141
-rw-r--r--media-libs/gdk-pixbuf/files/digest-gdk-pixbuf-0.12.01
-rw-r--r--media-libs/gdk-pixbuf/gdk-pixbuf-0.12.0.ebuild30
-rw-r--r--profiles/package.mask6
7 files changed, 109 insertions, 36 deletions
diff --git a/gnome-base/ORBit/ORBit-0.5.12.ebuild b/gnome-base/ORBit/ORBit-0.5.12.ebuild
new file mode 100644
index 000000000000..dd770d5b1dd4
--- /dev/null
+++ b/gnome-base/ORBit/ORBit-0.5.12.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/ORBit/ORBit-0.5.12.ebuild,v 1.1 2001/11/03 01:45:56 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A high-performance, lightweight CORBA ORB aiming for CORBA 2.2 compliance"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.labs.redhat.com/orbit/"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )
+ >=sys-apps/tcp-wrappers-7.6
+ >=dev-libs/glib-1.2.8"
+
+RDEPEND="virtual/glibc
+ >=dev-libs/glib-1.2.8"
+
+
+src_compile() {
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ $myconf || die
+
+ make || die # Doesn't work with -j 4 (hallski)
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
+ dodoc docs/*.txt docs/IDEA1
+
+ docinto idl
+ cd libIDL
+ dodoc AUTHORS BUGS COPYING NEWS README*
+
+ docinto popt
+ cd ../popt
+ dodoc CHANGES COPYING README
+}
+
+
+
diff --git a/gnome-base/ORBit/files/digest-ORBit-0.5.12 b/gnome-base/ORBit/files/digest-ORBit-0.5.12
new file mode 100644
index 000000000000..4b08ca67bb4f
--- /dev/null
+++ b/gnome-base/ORBit/files/digest-ORBit-0.5.12
@@ -0,0 +1 @@
+MD5 ab66859c937a940da6bad2c84161c6aa ORBit-0.5.12.tar.gz 1294336
diff --git a/gnome-base/bonobo/bonobo-1.0.14.ebuild b/gnome-base/bonobo/bonobo-1.0.14.ebuild
new file mode 100644
index 000000000000..ee505fdaa207
--- /dev/null
+++ b/gnome-base/bonobo/bonobo-1.0.14.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/bonobo/bonobo-1.0.14.ebuild,v 1.1 2001/11/03 01:45:56 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A set of language and system independant CORBA interfaces"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/"
+
+
+RDEPEND=">=gnome-base/oaf-0.6.6-r1
+ >=gnome-base/ORBit-0.5.10-r1
+ >=gnome-base/gnome-print-0.30"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ sys-devel/perl
+ >=dev-util/intltool-0.11"
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ CFLAGS="${CFLAGS} `gnome-config --cflags print`"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ ${myconf} || die
+
+ make || die # make -j 4 didn't work
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog README
+ dodoc NEWS TODO
+}
+
+
+
+
+
diff --git a/gnome-base/bonobo/files/digest-bonobo-1.0.14 b/gnome-base/bonobo/files/digest-bonobo-1.0.14
new file mode 100644
index 000000000000..2ee9f5f64a94
--- /dev/null
+++ b/gnome-base/bonobo/files/digest-bonobo-1.0.14
@@ -0,0 +1 @@
+MD5 3bf9640162c5deba6e1a1c35fdcd981c bonobo-1.0.14.tar.gz 1277952
diff --git a/media-libs/gdk-pixbuf/files/digest-gdk-pixbuf-0.12.0 b/media-libs/gdk-pixbuf/files/digest-gdk-pixbuf-0.12.0
deleted file mode 100644
index dc19d5e262ac..000000000000
--- a/media-libs/gdk-pixbuf/files/digest-gdk-pixbuf-0.12.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 5c20bd2c0069e6440171f793e19f5910 gdk-pixbuf-0.12.0.tar.gz 524288
diff --git a/media-libs/gdk-pixbuf/gdk-pixbuf-0.12.0.ebuild b/media-libs/gdk-pixbuf/gdk-pixbuf-0.12.0.ebuild
deleted file mode 100644
index 39ad6001cfd1..000000000000
--- a/media-libs/gdk-pixbuf/gdk-pixbuf-0.12.0.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gdk-pixbuf/gdk-pixbuf-0.12.0.ebuild,v 1.1 2001/10/26 08:41:07 hallski Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="GNOME Image Library"
-SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${P}.tar.gz"
-
-DEPEND=">=x11-libs/gtk+-1.2.10-r4
- >=gnome-base/gnome-libs-1.4.1.2-r1"
-
-src_compile() {
-
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc/X11/gdk-pixbuf
-
- assert
-
- emake || die
-}
-
-src_install() {
- make prefix=${D}/usr \
- sysconfdir=${D}/etc/X11/gdk-pixbuf \
- install || die
-
- dodoc AUTHORS COPYING* ChangeLog INSTALL README NEWS TODO
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index e53daa64d53c..2ef39574ae5a 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -256,9 +256,5 @@ gnome-apps/gnapster
>=gnome-extra/gal-0.14
# Untested
-# Installed fine, everything looks ok -- Azarah
>=gnome-base/bonobo-1.0.11
-
-# Will break builds since headers is in different place
-# bonobo-conf is one example, allthough it worked later on !?
->=media-libs/gdk-pixbuf-0.13.0
+>=gnome-base/ORBit-0.5.12