summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Turk <satai@gentoo.org>2002-11-05 04:02:38 +0000
committerMatthew Turk <satai@gentoo.org>2002-11-05 04:02:38 +0000
commitf0e10baf1b9c252749027ca6072265a1ed94220d (patch)
treed0c877d67cf2b2196670d66eb2905a4bc3e73247
parentFixed some minor woes that cropped up during a new package addition... (diff)
downloadhistorical-f0e10baf1b9c252749027ca6072265a1ed94220d.tar.gz
historical-f0e10baf1b9c252749027ca6072265a1ed94220d.tar.bz2
historical-f0e10baf1b9c252749027ca6072265a1ed94220d.zip
Initial import. Very nice calendar package...
-rw-r--r--app-text/latex-calendar/ChangeLog9
-rw-r--r--app-text/latex-calendar/files/digest-latex-calendar-3.11
-rw-r--r--app-text/latex-calendar/latex-calendar-3.1.ebuild30
3 files changed, 40 insertions, 0 deletions
diff --git a/app-text/latex-calendar/ChangeLog b/app-text/latex-calendar/ChangeLog
new file mode 100644
index 000000000000..dea6c4b8c69c
--- /dev/null
+++ b/app-text/latex-calendar/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/latex-calendar/ChangeLog,v 1.1 2002/11/05 04:02:38 satai Exp $
+
+*latex-calendar-3.1 (04 Nov 2002)
+
+ 04 Nov 2002; Matthew Turk <satai@gentoo.org> latex-calendar-3.1.ebuild :
+ Initial import. A very useful and beautiful calendar creator package for
+ LaTeX. Very flexible.
diff --git a/app-text/latex-calendar/files/digest-latex-calendar-3.1 b/app-text/latex-calendar/files/digest-latex-calendar-3.1
new file mode 100644
index 000000000000..fc784d5f852c
--- /dev/null
+++ b/app-text/latex-calendar/files/digest-latex-calendar-3.1
@@ -0,0 +1 @@
+MD5 e24f06db67bfc8f6c16f1918efde7247 latex-calendar-3.1.tar.gz 108537
diff --git a/app-text/latex-calendar/latex-calendar-3.1.ebuild b/app-text/latex-calendar/latex-calendar-3.1.ebuild
new file mode 100644
index 000000000000..c4870331fdd6
--- /dev/null
+++ b/app-text/latex-calendar/latex-calendar-3.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/latex-calendar/latex-calendar-3.1.ebuild,v 1.1 2002/11/05 04:02:38 satai Exp $
+
+inherit latex-package
+
+MY_P="calendar"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="LaTeX package used to create Calendars. Very flexible and robust."
+SRC_URI="http://www.ibiblio.org/gentoo/distfiles/${P}.tar.gz"
+HOMEPAGE="ftp://ibiblio.org/pub/packages/TeX/macros/latex/contrib/supported/"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~sparc64 ~ppc"
+
+src_compile() {
+ debug-print function $FUNCNAME $*
+ cd ${S}
+ echo "Extracting from allcal.ins"
+ echo "y
+ y" | latex allcal.ins > /dev/null
+}
+
+src_install() {
+ cd ${S}
+ latex-package_src_doinstall styles fonts bin
+ dodoc README MANIFEST CATALOG
+ insinto /usr/share/doc/${P}/samples
+ doins bigdemo.tgz *.cfg *.tex *.cld
+}