summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2005-03-10 22:44:13 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2005-03-10 22:44:13 +0000
commit4c9f876b6db7c50d4390135cc312aca50be851b9 (patch)
treed58b0bea47b03857fc06e3f6adce473edd8b1962 /app-accessibility/dasher/dasher-3.2.15.ebuild
parentAdd support for using get_abi_CHOST as a prefix before CHOST. (diff)
downloadhistorical-4c9f876b6db7c50d4390135cc312aca50be851b9.tar.gz
historical-4c9f876b6db7c50d4390135cc312aca50be851b9.tar.bz2
historical-4c9f876b6db7c50d4390135cc312aca50be851b9.zip
New release (3.2.15)
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'app-accessibility/dasher/dasher-3.2.15.ebuild')
-rw-r--r--app-accessibility/dasher/dasher-3.2.15.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-accessibility/dasher/dasher-3.2.15.ebuild b/app-accessibility/dasher/dasher-3.2.15.ebuild
new file mode 100644
index 000000000000..178eebd3738b
--- /dev/null
+++ b/app-accessibility/dasher/dasher-3.2.15.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/dasher-3.2.15.ebuild,v 1.1 2005/03/10 22:44:13 leonardop Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="A text entry interface, driven by continuous pointing gestures"
+HOMEPAGE="http://www.inference.phy.cam.ac.uk/dasher/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~alpha ~hppa ~mips"
+
+IUSE="accessibility gnome"
+
+# The package claims to support 'qte', but it hasn't been tested.
+# Any patches from someone who can test it are welcome.
+# <leonardop@gentoo.org>
+RDEPEND="dev-libs/expat
+ >=dev-libs/glib-2
+ >=x11-libs/gtk+-2
+ >=gnome-base/gconf-2
+ >=gnome-base/libglade-2
+ >=x11-libs/libwnck-1
+ virtual/x11
+ gnome? ( >=gnome-base/libgnome-2
+ >=gnome-base/gnome-vfs-2
+ >=gnome-base/libgnomeui-2 )
+ accessibility? ( >=gnome-base/libbonobo-2
+ >=gnome-base/orbit-2
+ >=gnome-base/libgnomeui-2
+ app-accessibility/gnome-speech
+ >=gnome-extra/at-spi-1 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.18
+ dev-util/pkgconfig
+ app-text/scrollkeeper"
+
+G2CONF="${G2CONF} $(use_with gnome) \
+$(use_with accessibility a11y) $(use_with accessibility speech)"
+
+DOCS="ABOUT-NLS AUTHORS ChangeLog MAINTAINERS NEWS README"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Fix test phase for the xtst library
+ epatch ${FILESDIR}/${PN}-3.2.11-xtst_fix.patch
+ # Poor pointer management causes segfault at startup
+ epatch ${FILESDIR}/${P}-buildwindowtree.patch
+}