summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-04-21 22:12:01 +0000
committerJon Hood <squinky86@gentoo.org>2004-04-21 22:12:01 +0000
commitd1554984c652df43d50de98b4ef0b419194e9dbe (patch)
tree6240228f521b8744b7007dc176915f4c7357777e /app-accessibility/emacspeak/emacspeak-18.ebuild
parentfix typo (diff)
downloadhistorical-d1554984c652df43d50de98b4ef0b419194e9dbe.tar.gz
historical-d1554984c652df43d50de98b4ef0b419194e9dbe.tar.bz2
historical-d1554984c652df43d50de98b4ef0b419194e9dbe.zip
initial commit; #45058
Diffstat (limited to 'app-accessibility/emacspeak/emacspeak-18.ebuild')
-rw-r--r--app-accessibility/emacspeak/emacspeak-18.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-accessibility/emacspeak/emacspeak-18.ebuild b/app-accessibility/emacspeak/emacspeak-18.ebuild
new file mode 100644
index 000000000000..c09f982004a3
--- /dev/null
+++ b/app-accessibility/emacspeak/emacspeak-18.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/emacspeak/emacspeak-18.ebuild,v 1.1 2004/04/21 22:12:01 squinky86 Exp $
+
+DESCRIPTION="the emacspeak audio desktop"
+HOMEPAGE="http://emacspeak.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+RESTRICT="nomirror"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="virtual/emacs
+ >=dev-tcltk/tclx-8.3"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4.0.7"
+
+S=${WORKDIR}/${P}.0
+
+src_compile() {
+ make config SRC=`pwd` || die
+ make emacspeak || die
+}
+
+src_install() {
+ make \
+ prefix=${D}/usr \
+ install || die
+ sed -i -e "s@/.*image/@@" ${D}/usr/bin/emacspeak
+ dodoc README etc/NEWS* etc/FAQ etc/COPYRIGHT
+ dohtml -r install-guide user-guide
+}