summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-02-23 20:26:07 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-02-23 20:26:07 +0000
commitcbe24a452f95f7b25093c716c800ba49693155a0 (patch)
treeb5ebf08978c1afee589f13dd8c8d831c56d23003 /app-admin/apachetop/files
parentwhitespace (diff)
downloadhistorical-cbe24a452f95f7b25093c716c800ba49693155a0.tar.gz
historical-cbe24a452f95f7b25093c716c800ba49693155a0.tar.bz2
historical-cbe24a452f95f7b25093c716c800ba49693155a0.zip
fix #198553; remove old version
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'app-admin/apachetop/files')
-rw-r--r--app-admin/apachetop/files/CAN-2005-2660.patch20
-rw-r--r--app-admin/apachetop/files/apachetop-0.12.6-configure.patch101
2 files changed, 101 insertions, 20 deletions
diff --git a/app-admin/apachetop/files/CAN-2005-2660.patch b/app-admin/apachetop/files/CAN-2005-2660.patch
deleted file mode 100644
index cea26afa4c5b..000000000000
--- a/app-admin/apachetop/files/CAN-2005-2660.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- apachetop-0.12.5.orig/src/apachetop.cc 2005-09-27 20:48:10.000000000 -0400
-+++ apachetop-0.12.5/src/apachetop.cc 2005-09-27 20:49:26.000000000 -0400
-@@ -1105,7 +1105,16 @@
- FILE *d;
- va_list args;
-
-- if (cf.debug && (d = fopen(DEBUG_OUTPUT, "a")))
-+ static char fileName[1024] = {'\0'};
-+
-+ if ( !strlen( fileName ) )
-+ {
-+ strcpy( fileName, "/tmp/atop.XXXXXX" );
-+ mkdtemp( fileName );
-+ strncat( fileName, "/debug", sizeof(fileName ) );
-+ }
-+
-+ if (cf.debug && (d = fopen(fileName, "a")))
- {
- va_start(args, fmt);
- vfprintf(d, fmt, args);
diff --git a/app-admin/apachetop/files/apachetop-0.12.6-configure.patch b/app-admin/apachetop/files/apachetop-0.12.6-configure.patch
new file mode 100644
index 000000000000..38a1fc7f6a1a
--- /dev/null
+++ b/app-admin/apachetop/files/apachetop-0.12.6-configure.patch
@@ -0,0 +1,101 @@
+Index: apachetop-0.12.6/configure.ac
+===================================================================
+--- apachetop-0.12.6.orig/configure.ac
++++ apachetop-0.12.6/configure.ac
+@@ -52,48 +52,60 @@ AC_FUNC_VPRINTF
+ AC_CHECK_FUNCS([inet_aton memset strchr strdup kqueue strerror strstr])
+
+ # pcre {{{
+-AC_ARG_WITH(pcre,
+- [ --with-pcre=<path> prefix of pcre installation (eg /usr/local)],
+- [
+- CPPFLAGS="$CPPFLAGS -I $withval/include"
+- LDFLAGS="$LDFLAGS -L $withval/lib"
+- ]
+-)
+-
+-AC_CHECK_HEADERS(pcre.h,
+- AC_SEARCH_LIBS([pcre_compile], [pcre]) ,
+- AC_MSG_WARN([*** pcre.h not found -- consider using --with-pcre])
+-)
++AC_ARG_WITH([pcre],
++ [ --with-pcre=<path> prefix of pcre installation (eg /usr/local)],
++ [case "${withval}" in
++ yes) with_pcre="/usr";;
++ no) with_pcre="no";;
++ *) with_pcre="/usr";;
++ esac],
++ [with_pcre="/usr"])
++
++if test x$with_pcre != xno; then
++ CPPFLAGS="$CPPFLAGS -I $withval/include"
++ LDFLAGS="$LDFLAGS -L $withval/lib"
++ AC_CHECK_HEADERS(pcre.h,
++ AC_SEARCH_LIBS([pcre_compile], [pcre]),
++ AC_MSG_WARN([*** pcre.h not found -- consider using --with-pcre]))
++fi
+ # }}}
+
+ # fam {{{
+-AC_ARG_WITH(fam,
+- [ --with-fam=<path> prefix of fam installation (eg /usr/local)],
+- [
+- CPPFLAGS="$CPPFLAGS -I $withval/include"
+- LDFLAGS="$LDFLAGS -L $withval/lib"
+- ]
+-)
+-
+-AC_CHECK_HEADERS(fam.h,
+- AC_SEARCH_LIBS([FAMOpen], [fam]) ,
+- AC_MSG_WARN([*** fam.h not found -- consider using --with-fam])
+-)
++AC_ARG_WITH([fam],
++ [ --with-fam=<path> prefix of fam installation (eg /usr/local)],
++ [case "${withval}" in
++ yes) with_fam="/usr";;
++ no) with_fam="no";;
++ *) with_fam="/usr";;
++ esac],
++ [with_fam="/usr"])
++
++if test x$with_fam != xno; then
++ CPPFLAGS="$CPPFLAGS -I $with_fam/include"
++ LDFLAGS="$LDFLAGS -L $with_fam/lib"
++ AC_CHECK_HEADERS(fam.h,
++ AC_SEARCH_LIBS([FAMOpen], [fam]),
++ AC_MSG_WARN([*** fam.h not found -- consider using --with-fam]))
++fi
+ # }}}
+
+ # adns {{{
+-AC_ARG_WITH(adns,
+- [ --with-adns=<path> prefix of adns installation (eg /usr/local)],
+- [
+- CPPFLAGS="$CPPFLAGS -I $withval/include"
+- LDFLAGS="$LDFLAGS -L $withval/lib"
+- ]
+-)
+-
+-AC_CHECK_HEADERS(adns.h,
+- AC_SEARCH_LIBS([adns_submit], [adns]) ,
+- AC_MSG_WARN([*** adns.h not found -- consider using --with-adns])
+-)
++AC_ARG_WITH([adns],
++ [ --with-adns=<path> prefix of adns installation (eg /usr/local)],
++ [case "${withval}" in
++ yes) with_adns="/usr";;
++ no) with_adns="no";;
++ *) with_adns="/usr";;
++ esac],
++ [with_adns="/usr"])
++
++if test x$with_adns != xno; then
++ CPPFLAGS="$CPPFLAGS -I $with_adns/include"
++ LDFLAGS="$LDFLAGS -L $with_adns/lib"
++ AC_CHECK_HEADERS(adns.h,
++ AC_SEARCH_LIBS([adns_submit], [adns]),
++ AC_MSG_WARN([*** adns.h not found -- consider using --with-adns]))
++fi
+ # }}}
+
+ # --with-logfile {{{