summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2012-04-29 13:26:30 +0000
committerBenedikt Boehm <hollow@gentoo.org>2012-04-29 13:26:30 +0000
commitc37c5640f5a9b731d7b3c08e0ef59a635259705d (patch)
treed7fdac9d6f0ceed448ebf1bd20a0fc46992fd030 /app-admin/chef-expander
parentVersion bump (diff)
downloadhistorical-c37c5640f5a9b731d7b3c08e0ef59a635259705d.tar.gz
historical-c37c5640f5a9b731d7b3c08e0ef59a635259705d.tar.bz2
historical-c37c5640f5a9b731d7b3c08e0ef59a635259705d.zip
version bump to resolve dependency conflicts (see #410385)
Package-Manager: portage-2.2.0_alpha101/cvs/Linux x86_64
Diffstat (limited to 'app-admin/chef-expander')
-rw-r--r--app-admin/chef-expander/ChangeLog8
-rw-r--r--app-admin/chef-expander/chef-expander-0.10.10_beta1.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/app-admin/chef-expander/ChangeLog b/app-admin/chef-expander/ChangeLog
index fcc1bd91bcf9..8627769176ae 100644
--- a/app-admin/chef-expander/ChangeLog
+++ b/app-admin/chef-expander/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/chef-expander
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/chef-expander/ChangeLog,v 1.3 2012/01/29 12:17:26 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/chef-expander/ChangeLog,v 1.4 2012/04/29 13:21:15 hollow Exp $
+
+*chef-expander-0.10.10_beta1 (29 Apr 2012)
+
+ 29 Apr 2012; Benedikt Böhm <hollow@gentoo.org>
+ +chef-expander-0.10.10_beta1.ebuild:
+ version bump to resolve dependency conflicts (see #410385)
*chef-expander-0.10.8 (29 Jan 2012)
diff --git a/app-admin/chef-expander/chef-expander-0.10.10_beta1.ebuild b/app-admin/chef-expander/chef-expander-0.10.10_beta1.ebuild
new file mode 100644
index 000000000000..ff67c72da26c
--- /dev/null
+++ b/app-admin/chef-expander/chef-expander-0.10.10_beta1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/chef-expander/chef-expander-0.10.10_beta1.ebuild,v 1.1 2012/04/29 13:21:15 hollow Exp $
+
+EAPI="4"
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_VERSION=${PV/_beta/.beta.}
+
+inherit ruby-fakegem
+
+DESCRIPTION="Configuration management tool"
+HOMEPAGE="http://wiki.opscode.com/display/chef"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+
+ruby_add_rdepend "~app-admin/chef-${PV}
+ >=dev-ruby/amqp-0.6.7
+ <dev-ruby/amqp-0.7
+ >=dev-ruby/bunny-0.6.0
+ <dev-ruby/bunny-0.7
+ >=dev-ruby/em-http-request-0.2.11
+ <dev-ruby/em-http-request-0.3
+ >=dev-ruby/eventmachine-0.12.10
+ <dev-ruby/eventmachine-0.13
+ >=dev-ruby/fast_xs-0.7.3
+ <dev-ruby/fast_xs-0.8
+ >=dev-ruby/highline-1.6.1
+ <dev-ruby/highline-1.7
+ >=dev-ruby/mixlib-log-1.2.0
+ >=dev-ruby/uuidtools-2.1.1
+ <dev-ruby/uuidtools-2.2
+ >=dev-ruby/yajl-ruby-0.7.7"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doinitd "${FILESDIR}/initd/chef-expander"
+ doconfd "${FILESDIR}/confd/chef-expander"
+
+ keepdir /etc/chef /var/{lib,log,run}/chef
+ fowners chef:chef /var/{lib,log,run}/chef
+}