summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-10-27 14:08:19 +0000
committerMichael Weber <xmw@gentoo.org>2011-10-27 14:08:19 +0000
commitf4f20d892136c143fd0e69a06ed4505093b0f261 (patch)
tree22cfc7bc8408155618744bce78ebea115f086954 /app-admin/conkyforecast/conkyforecast-2.20.ebuild
parentChanges to pydoc conf.d and init.d files wrt bug #361867. Patch by Arfrever (diff)
downloadhistorical-f4f20d892136c143fd0e69a06ed4505093b0f261.tar.gz
historical-f4f20d892136c143fd0e69a06ed4505093b0f261.tar.bz2
historical-f4f20d892136c143fd0e69a06ed4505093b0f261.zip
Version bump
Package-Manager: portage-2.1.10.11/cvs/Linux x86_64
Diffstat (limited to 'app-admin/conkyforecast/conkyforecast-2.20.ebuild')
-rw-r--r--app-admin/conkyforecast/conkyforecast-2.20.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-admin/conkyforecast/conkyforecast-2.20.ebuild b/app-admin/conkyforecast/conkyforecast-2.20.ebuild
new file mode 100644
index 000000000000..b30fa16cfe15
--- /dev/null
+++ b/app-admin/conkyforecast/conkyforecast-2.20.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conkyforecast/conkyforecast-2.20.ebuild,v 1.1 2011/10/27 14:08:19 xmw Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit distutils
+
+DESCRIPTION="Conky weather forecast script with support for language files"
+HOMEPAGE="https://launchpad.net/~conky-companions"
+SRC_URI="https://launchpad.net/~conky-companions/+archive/ppa/+files/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-admin/conky"
+
+S=${WORKDIR}/src
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ sed -i -e "s:/usr/bin/python:$(PYTHON -a):" conkyForecast || die
+ distutils_src_prepare
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog "You have to define a partner id and registration code for "
+ elog "the weather.com xoap. You need to copy the template from"
+ elog "/usr/share/conkyforecast/conkyForecast.config into you account"
+ elog "as ~/.conkyForecast.config and edit the respective fields."
+ elog
+ elog "More details can be found in the README file."
+}