summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-28 13:34:26 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-28 13:34:26 +0000
commit96bb345c5d1243d7a07289256dd13c0d14954c9f (patch)
tree41bd5377257faaa2b560d869dd42fb46752afd64 /app-admin/ec2-api-tools/ec2-api-tools-1.3.46266.ebuild
parentBump to 3.1.2 (diff)
downloadhistorical-96bb345c5d1243d7a07289256dd13c0d14954c9f.tar.gz
historical-96bb345c5d1243d7a07289256dd13c0d14954c9f.tar.bz2
historical-96bb345c5d1243d7a07289256dd13c0d14954c9f.zip
Version bump, also don't use version for the install path and don't use symlinks to /usr/bin. This means that you won't need to re-source the profile at each upgrade, but just after the first install. And it won't pollute your inode space.
Package-Manager: portage-2.2_rc61/cvs/Linux x86_64
Diffstat (limited to 'app-admin/ec2-api-tools/ec2-api-tools-1.3.46266.ebuild')
-rw-r--r--app-admin/ec2-api-tools/ec2-api-tools-1.3.46266.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-admin/ec2-api-tools/ec2-api-tools-1.3.46266.ebuild b/app-admin/ec2-api-tools/ec2-api-tools-1.3.46266.ebuild
new file mode 100644
index 000000000000..9c4464105cce
--- /dev/null
+++ b/app-admin/ec2-api-tools/ec2-api-tools-1.3.46266.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ec2-api-tools/ec2-api-tools-1.3.46266.ebuild,v 1.1 2010/01/28 13:34:26 flameeyes Exp $
+
+inherit versionator
+
+EC2_VERSION=$(get_version_component_range 1-2)
+EC2_PATCHLEVEL=$(get_version_component_range 3)
+
+DESCRIPTION="These command-line tools serve as the client interface to the Amazon EC2 web service."
+HOMEPAGE="http://developer.amazonwebservices.com/connect/entry.jspa?externalID=351&categoryID=88"
+SRC_URI="http://s3.amazonaws.com/ec2-downloads/${PN}-${EC2_VERSION}-${EC2_PATCHLEVEL}.zip"
+
+S=${WORKDIR}/${PN}-${EC2_VERSION}-${EC2_PATCHLEVEL}
+
+LICENSE="Amazon"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="app-arch/unzip"
+RDEPEND="virtual/jre"
+
+src_unpack() {
+ unpack ${A}
+ cd "${WORKDIR}/${PN}-${EC2_VERSION}-${EC2_PATCHLEVEL}"
+ find . -name *.cmd -exec rm {} \;
+}
+
+src_install() {
+ dodir /opt/${PN}
+ insinto /opt/${PN}/lib
+ doins -r "${S}"/lib/*
+ exeinto /opt/${PN}/bin
+ doexe "${S}"/bin/*
+
+ dodir /etc/env.d
+ cat - > "${T}"/99${PN} <<EOF
+EC2_HOME=/opt/${PN}
+PATH=/opt/${PN}/bin
+EOF
+ doenvd "${T}"/99${PN}
+
+ dodoc THIRDPARTYLICENSE.TXT
+}
+
+pkg_postinst() {
+ ewarn "Remember to run: env-update && source /etc/profile if you plan"
+ ewarn "to use these tools in a shell before logging out (or restarting"
+ ewarn "your login manager)"
+ elog ""
+ elog ""
+ elog "You need to put the following in your ~/.bashrc replacing the"
+ elog "values with the full paths to your key and certificate."
+ elog " "
+ elog " export EC2_PRIVATE_KEY=/path/to/pk-HKZYKTAIG2ECMXYIBH3HXV4ZBZQ55CLO.pem"
+ elog " export EC2_CERT=/path/to/cert-HKZYKTAIG2ECMXYIBH3HXV4ZBZQ55CLO.pem"
+}