summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2012-09-27 11:02:15 +0000
committerFabio Erculiani <lxnay@gentoo.org>2012-09-27 11:02:15 +0000
commitf2af90c6c0381e47be5269107c97122d2d499102 (patch)
tree7b366dec465e3e1a7ddb40f48f0a8a177edce79a /app-admin/equo/equo-144.ebuild
parentkeyword ~ppc, bug #436396 (diff)
downloadhistorical-f2af90c6c0381e47be5269107c97122d2d499102.tar.gz
historical-f2af90c6c0381e47be5269107c97122d2d499102.tar.bz2
historical-f2af90c6c0381e47be5269107c97122d2d499102.zip
version bump
Package-Manager: portage-2.2.0_alpha123/cvs/Linux x86_64
Diffstat (limited to 'app-admin/equo/equo-144.ebuild')
-rw-r--r--app-admin/equo/equo-144.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-admin/equo/equo-144.ebuild b/app-admin/equo/equo-144.ebuild
new file mode 100644
index 000000000000..37b8325737bc
--- /dev/null
+++ b/app-admin/equo/equo-144.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/equo-144.ebuild,v 1.1 2012/09/27 10:59:44 lxnay Exp $
+
+EAPI=3
+PYTHON_DEPEND="2"
+inherit eutils python bash-completion-r1
+
+DESCRIPTION="Entropy Package Manager text-based client"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+
+S="${WORKDIR}/entropy-${PV}"
+
+DEPEND="~sys-apps/entropy-${PV}"
+RDEPEND="${DEPEND} sys-apps/file[python]"
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/lib" equo-install || die "make install failed"
+ newbashcomp "${S}/misc/equo-completion.bash" equo
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/lib/entropy/client"
+ echo
+ elog "If you would like to allow users in the 'entropy' group"
+ elog "to update available package repositories, please consider"
+ elog "to install sys-apps/rigo-daemon"
+ echo
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/entropy/client"
+}