summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2012-02-12 07:25:11 +0000
committerFabio Erculiani <lxnay@gentoo.org>2012-02-12 07:25:11 +0000
commitc7f0d806bf228937f0a1315d8b7d16ec94b43a9f (patch)
tree68e436d6d3825b668fc54bda21caaaa6b566467b /app-admin/equo
parent2.2.0_alpha86 version bump. This includes all of the fixes in (diff)
downloadhistorical-c7f0d806bf228937f0a1315d8b7d16ec94b43a9f.tar.gz
historical-c7f0d806bf228937f0a1315d8b7d16ec94b43a9f.tar.bz2
historical-c7f0d806bf228937f0a1315d8b7d16ec94b43a9f.zip
version bump
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64
Diffstat (limited to 'app-admin/equo')
-rw-r--r--app-admin/equo/ChangeLog9
-rw-r--r--app-admin/equo/equo-1.0_rc87.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/app-admin/equo/ChangeLog b/app-admin/equo/ChangeLog
index 2836a9cb8d2e..55b4466d7c88 100644
--- a/app-admin/equo/ChangeLog
+++ b/app-admin/equo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/equo
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/ChangeLog,v 1.17 2011/12/22 17:51:12 lxnay Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/ChangeLog,v 1.18 2012/02/12 07:24:16 lxnay Exp $
+
+*equo-1.0_rc87 (12 Feb 2012)
+
+ 12 Feb 2012; Fabio Erculiani <lxnay@gentoo.org> +equo-1.0_rc87.ebuild:
+ version bump
*equo-1.0_rc80 (22 Dec 2011)
diff --git a/app-admin/equo/equo-1.0_rc87.ebuild b/app-admin/equo/equo-1.0_rc87.ebuild
new file mode 100644
index 000000000000..9c01c55d3eba
--- /dev/null
+++ b/app-admin/equo/equo-1.0_rc87.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/equo-1.0_rc87.ebuild,v 1.1 2012/02/12 07:24:16 lxnay Exp $
+
+EAPI=3
+PYTHON_DEPEND="2"
+inherit eutils python bash-completion-r1
+
+DESCRIPTION="Entropy Package Manager text-based client"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+
+S="${WORKDIR}/entropy-${PV}"
+
+DEPEND="~sys-apps/entropy-${PV}"
+RDEPEND="${DEPEND} sys-apps/file[python]"
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/lib" equo-install || die "make install failed"
+ newbashcomp "${S}/misc/equo-completion.bash" equo
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/lib/entropy/client"
+ echo
+ elog "If you would like to allow users in the 'entropy' group"
+ elog "to update available package repositories, please consider"
+ elog "to install sys-apps/entropy-client-services"
+ echo
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/entropy/client"
+}