summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-11-06 21:37:40 +0000
committerUlrich Müller <ulm@gentoo.org>2009-11-06 21:37:40 +0000
commit6d7d4f403b57cad63a0fca22bd82abd8d0a2d52f (patch)
tree0b15a079deacfac90b0dee9e5d78c80e35d94dc4 /app-admin/eselect-mpost
parentcleanup unused use flags (diff)
downloadhistorical-6d7d4f403b57cad63a0fca22bd82abd8d0a2d52f.tar.gz
historical-6d7d4f403b57cad63a0fca22bd82abd8d0a2d52f.tar.bz2
historical-6d7d4f403b57cad63a0fca22bd82abd8d0a2d52f.zip
Version bump, bug 292107.
Package-Manager: portage-2.2_rc46/cvs/Linux i686
Diffstat (limited to 'app-admin/eselect-mpost')
-rw-r--r--app-admin/eselect-mpost/ChangeLog8
-rw-r--r--app-admin/eselect-mpost/eselect-mpost-0.2.ebuild29
-rw-r--r--app-admin/eselect-mpost/files/mpost.eselect-0.2148
3 files changed, 184 insertions, 1 deletions
diff --git a/app-admin/eselect-mpost/ChangeLog b/app-admin/eselect-mpost/ChangeLog
index d68a7392062b..a467a6afadf7 100644
--- a/app-admin/eselect-mpost/ChangeLog
+++ b/app-admin/eselect-mpost/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/eselect-mpost
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-mpost/ChangeLog,v 1.12 2009/03/18 18:38:57 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-mpost/ChangeLog,v 1.13 2009/11/06 21:37:38 ulm Exp $
+
+*eselect-mpost-0.2 (06 Nov 2009)
+
+ 06 Nov 2009; Ulrich Mueller <ulm@gentoo.org> +files/mpost.eselect-0.2,
+ +eselect-mpost-0.2.ebuild:
+ Version bump, bug 292107.
18 Mar 2009; Raúl Porcel <armin76@gentoo.org> eselect-mpost-0.1.ebuild:
alpha/arm/ia64/s390/sh stable wrt #253551
diff --git a/app-admin/eselect-mpost/eselect-mpost-0.2.ebuild b/app-admin/eselect-mpost/eselect-mpost-0.2.ebuild
new file mode 100644
index 000000000000..213816deebf5
--- /dev/null
+++ b/app-admin/eselect-mpost/eselect-mpost-0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-mpost/eselect-mpost-0.2.ebuild,v 1.1 2009/11/06 21:37:38 ulm Exp $
+
+inherit eutils
+
+DESCRIPTION="mpost module for eselect"
+HOMEPAGE="http://www.gentoo.org/proj/en/eselect/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+# Depend on texlive-core-2008 that allows usage of this module, otherwise it
+# will not work so nicely.
+RDEPEND=">=app-admin/eselect-1.2.3
+ >=app-text/texlive-core-2008"
+
+src_install() {
+ local MODULEDIR="/usr/share/eselect/modules"
+ local MODULE="mpost"
+ dodir ${MODULEDIR}
+ insinto ${MODULEDIR}
+ newins "${FILESDIR}/${MODULE}.eselect-${PVR}" ${MODULE}.eselect \
+ || die "failed to install"
+}
diff --git a/app-admin/eselect-mpost/files/mpost.eselect-0.2 b/app-admin/eselect-mpost/files/mpost.eselect-0.2
new file mode 100644
index 000000000000..decb00ce8010
--- /dev/null
+++ b/app-admin/eselect-mpost/files/mpost.eselect-0.2
@@ -0,0 +1,148 @@
+# -*-eselect-*- vim: ft=eselect
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id: mpost.eselect-0.2,v 1.1 2009/11/06 21:37:39 ulm Exp $
+
+DESCRIPTION="Manage /usr/bin/mpost implementations"
+MAINTAINER="ml@gentoo.org"
+SVN_DATE='$Date: 2009/11/06 21:37:39 $'
+VERSION=$(svn_date_to_version "${SVN_DATE}" )
+
+# find a list of mpost symlink targets, best first
+find_targets() {
+ local f
+ for f in "${ROOT}"/usr/bin/mpost-*; do
+ if [[ -f ${f} ]] ; then
+ echo "${f##*/mpost-}"
+ fi
+ done | sort
+}
+
+# find version number of currently symlinked version
+identify_target() {
+ local f
+ f="$(canonicalise "${ROOT}"/usr/bin/mpost)"
+ echo "${f##*/mpost-}"
+}
+
+# try to remove the mpost symlink
+remove_symlinks() {
+ rm -f "${ROOT}"/usr/bin/mpost &>/dev/null
+}
+
+# set the mpost symlink
+set_symlinks() {
+ local target="${1}" targets
+ if is_number "${target}" && [[ ${target} -ge 1 ]] ; then
+ targets=( $(find_targets ) )
+ target=${targets[$(( ${target} - 1 ))]}
+ fi
+ if [[ -f "${ROOT}/usr/bin/mpost-${target}" ]] ; then
+ remove_symlinks
+ ln -s "mpost-${target}" "${ROOT}/usr/bin/mpost" || \
+ die "Could not set ${target} /usr/bin/mpost symlink"
+ echo "Updating TeX formats"
+ [ -z "${ROOT}" ] && fmtutil-sys --all &>/dev/null || write_warning_msg "Could not update TeX formats for some reason, mpost may not work properly."
+ else
+ die -q "Target \"${target}\" doesn't appear to be valid!"
+ fi
+}
+
+### show action ###
+
+describe_show() {
+ echo "Show the current mpost version"
+}
+
+do_show() {
+ [[ -z "${@}" ]] || die -q "Too many parameters"
+
+ write_list_start "Current mpost verson:"
+ if [[ -L "${ROOT}/usr/bin/mpost" ]] ; then
+ write_kv_list_entry "$(identify_target)" ""
+ elif [[ -e "${ROOT}/usr/bin/mpost" ]] ; then
+ write_kv_list_entry "(not a symlink)" ""
+ else
+ write_kv_list_entry "(unset)" ""
+ fi
+}
+
+### list action ###
+
+describe_list() {
+ echo "List available mpost versions"
+}
+
+do_list() {
+ [[ -z "${@}" ]] || die -q "Too many parameters"
+
+ local i targets current
+ targets=( $(find_targets ) )
+ current=$(identify_target)
+ for (( i = 0; i < ${#targets[@]}; i++ )); do
+ [[ ${targets[i]} = ${current} ]] \
+ && targets[i]=$(highlight_marker "${targets[i]}")
+ done
+ write_list_start "Available mpost versions:"
+ write_numbered_list -m "(none found)" "${targets[@]}"
+}
+
+### set action ###
+
+describe_set() {
+ echo "Set a new mpost version"
+}
+
+describe_set_options() {
+ echo "target : Target version number or index from 'list' action"
+}
+
+describe_set_parameters() {
+ echo "<target>"
+}
+
+do_set() {
+ if [[ -z "${1}" ]] ; then
+ die -q "You didn't give me a version number"
+
+ elif [[ -n "${2}" ]] ; then
+ die -q "Too many parameters"
+
+ elif [[ -L "${ROOT}/usr/bin/mpost" ]] ; then
+ if ! remove_symlinks ; then
+ die -q "Can't remove existing version symlink"
+ elif ! set_symlinks "${1}" ; then
+ die -q "Can't set new version"
+ fi
+
+ elif [[ -e "${ROOT}/usr/bin/mpost" ]] ; then
+ die -q "${ROOT}/usr/bin/mpost seems to be from an old ebuild, please remove manually"
+ else
+ set_symlinks "${1}" || die -q "Can't set new version"
+ fi
+}
+
+### update action ###
+
+describe_update() {
+ echo "Automatically update the mpost version number"
+}
+
+describe_update_options() {
+ echo "--if-unset : Do not override currently selected version"
+}
+
+do_update() {
+ [[ -z "${1}" ]] || ( [[ -z "${2}" ]] && [[ "${1}" == "--if-unset" ]] ) || \
+ die -q "Usage error"
+
+ if [[ -L "${ROOT}/usr/bin/mpost" ]] ; then
+ [[ ${1} == "--if-unset" ]] && return
+ remove_symlinks || die -q "Can't remove existing symlink"
+ fi
+ if [[ -e "${ROOT}/usr/bin/mpost" ]] ; then
+ die -q "${ROOT}/usr/bin/mpost seems to be from an old ebuild, please remove manually"
+ elif ! [[ -z $(find_targets ) ]] ; then
+ set_symlinks 1 || die -q "Can't set a new version"
+ fi
+}