summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2004-03-16 19:21:54 +0000
committerSeemant Kulleen <seemant@gentoo.org>2004-03-16 19:21:54 +0000
commit64f530fc62d9ff4927bb32284b3d0e22ef797879 (patch)
treed226070073d3f0668d4d0843f942639bd1216443 /app-admin/hpasm
parentMinor edit (diff)
downloadhistorical-64f530fc62d9ff4927bb32284b3d0e22ef797879.tar.gz
historical-64f530fc62d9ff4927bb32284b3d0e22ef797879.tar.bz2
historical-64f530fc62d9ff4927bb32284b3d0e22ef797879.zip
switch to using rpm.eclass, which fixes bug #32872 by JF Burdet <jean-francois.burdet@adm.unige.ch>. Also, fixed up MY_P to make this more resilient to version bumps upstream. I have no idea what bug #22015 is all about though. Additionally, the install is a bit changed, no need to explicitly install stuff when a cp -a will do.
Diffstat (limited to 'app-admin/hpasm')
-rw-r--r--app-admin/hpasm/ChangeLog11
-rw-r--r--app-admin/hpasm/Manifest4
-rw-r--r--app-admin/hpasm/hpasm-6.30.0.12-r1.ebuild43
3 files changed, 26 insertions, 32 deletions
diff --git a/app-admin/hpasm/ChangeLog b/app-admin/hpasm/ChangeLog
index 0bb7c13cda40..bf185c011c45 100644
--- a/app-admin/hpasm/ChangeLog
+++ b/app-admin/hpasm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/hpasm
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/hpasm/ChangeLog,v 1.1 2003/06/25 01:38:00 method Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/hpasm/ChangeLog,v 1.2 2004/03/16 19:21:54 seemant Exp $
+
+ 16 Mar 2004; Seemant Kulleen <seemant@gentoo.org> hpasm-6.30.0.12-r1.ebuild:
+ switch to using rpm.eclass, which fixes bug #32872 by JF Burdet
+ <jean-francois.burdet@adm.unige.ch>. Also, fixed up MY_P to make this more
+ resilient to version bumps upstream. I have no idea what bug #22015 is all
+ about though. Additionally, the install is a bit changed, no need to
+ explicitly install stuff when a cp -a will do.
*hpasm-6.30.0.12-r1 (24 Jun 2003)
diff --git a/app-admin/hpasm/Manifest b/app-admin/hpasm/Manifest
index 5033f4106e5b..d34317b1e1b1 100644
--- a/app-admin/hpasm/Manifest
+++ b/app-admin/hpasm/Manifest
@@ -1,3 +1,3 @@
-MD5 5a4e9579b3899b3acaa5d09cee9fdc06 ChangeLog 401
-MD5 3b44742222a736ef37666b90e2c90854 hpasm-6.30.0.12-r1.ebuild 2913
+MD5 96a43d0aa2146ee6a9e85da9f3a166dd hpasm-6.30.0.12-r1.ebuild 2382
+MD5 365f3bfddfb573a15b2e2cc0aee0b901 ChangeLog 822
MD5 abbf2c075cd154e71c9cb90ad061b39e files/digest-hpasm-6.30.0.12-r1 80
diff --git a/app-admin/hpasm/hpasm-6.30.0.12-r1.ebuild b/app-admin/hpasm/hpasm-6.30.0.12-r1.ebuild
index 422f7e32efaf..59b116466d8c 100644
--- a/app-admin/hpasm/hpasm-6.30.0.12-r1.ebuild
+++ b/app-admin/hpasm/hpasm-6.30.0.12-r1.ebuild
@@ -1,44 +1,39 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/hpasm/hpasm-6.30.0.12-r1.ebuild,v 1.6 2004/03/12 10:45:38 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/hpasm/hpasm-6.30.0.12-r1.ebuild,v 1.7 2004/03/16 19:21:54 seemant Exp $
+inherit rpm
+
+MY_P=${P%.*}-${PV##*.}
+S=${WORKDIR}
DESCRIPTION="hp Server Management Drivers and Agents"
HOMEPAGE="http://h18000.www1.hp.com/products/servers/linux/documentation.html"
-SRC_URI="ftp://ftp.compaq.com/pub/products/servers/supportsoftware/linux/RedHat/hpasm-6.30.0-12.Redhat8_0.i386.rpm"
+SRC_URI="ftp://ftp.compaq.com/pub/products/servers/supportsoftware/linux/RedHat/${MY_P}.Redhat8_0.i386.rpm"
LICENSE="hp-value"
SLOT="0"
KEYWORDS="x86"
RDEPEND="snmp? ( net-analyzer/net-snmp )"
+
DEPEND="${RDEPEND}
virtual/linux-sources
net-mail/mailx
app-arch/rpm2targz"
-S=${WORKDIR}
-
src_unpack() {
- rpm2targz ${DISTDIR}/hpasm-6.30.0-12.Redhat8_0.i386.rpm || die
- tar zxf ${S}/hpasm-6.30.0-12.Redhat8_0.i386.tar.gz || die
- rm ${S}/opt/compaq/hpasm/addon/libcpqci.so || die
- rm ${S}/opt/compaq/hpasm/addon/libcpqci.so.1 || die
+ rpm_src_unpack
+ cd ${S}
+ find ./ -type l | xargs rm -f
}
src_install() {
- HPASM_HOME="/opt/compaq"
-
- dodir ${HPASM_HOME}
+
+ cp -a ${WORKDIR}/* ${D}
- cp -Rdp opt/compaq/* ${D}${HPASM_HOME}
+ dosym libcpqci.so.1.0 /opt/compaq/hpasm/addon/libcpqci.so.1
+ dosym libcpqci.so.1.0 /opt/compaq/hpasm/addon/libcpqci.so
- into /
- dosbin sbin/bootcfg
-
- dosym /opt/compaq/hpasm/addon/libcpqci.so.1.0 /opt/compaq/hpasm/addon/libcpqci.so.1
- dosym /opt/compaq/hpasm/addon/libcpqci.so.1.0 /opt/compaq/hpasm/addon/libcpqci.so
-
- dodir /usr/share/pixmaps
dosym /opt/compaq/cpqhealth/cpqasm/hplogo.xbm /usr/share/pixmaps/hplogo.xbm
dosym /opt/compaq/cpqhealth/cpqasm/m_blue.gif /usr/share/pixmaps/m_blue.gif
dosym /opt/compaq/cpqhealth/cpqasm/m_fail.gif /usr/share/pixmaps/m_fail.gif
@@ -65,15 +60,7 @@ src_install() {
dosym /usr/lib/libssl.so.0.9.6 /usr/lib/libssl.so.2
fi
- dodir /var/spool/compaq
-
- exeinto /etc/init.d
- doexe etc/init.d/hpasm
-
- doman usr/share/man/man4/cpqhealth.4.gz usr/share/man/man4/hpasm.4.gz \
- usr/share/man/man8/cpqimlview.8.gz usr/share/man/man8/hplog.8.gz \
- usr/share/man/man8/hpuid.8.gz
-
+ keepdir /var/spool/compaq
}
pkg_postinst() {