summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-05-02 19:04:01 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-05-02 19:04:01 +0000
commit73ad2a793ab49e51d6fbd2f79a0016a4cb3a5b2e (patch)
tree9588696ead4180a74820a82a26e1cf702c2dce61 /app-admin/sabayon/sabayon-2.25.0.ebuild
parentEnable ck-based policy; bug #268223 (diff)
downloadhistorical-73ad2a793ab49e51d6fbd2f79a0016a4cb3a5b2e.tar.gz
historical-73ad2a793ab49e51d6fbd2f79a0016a4cb3a5b2e.tar.bz2
historical-73ad2a793ab49e51d6fbd2f79a0016a4cb3a5b2e.zip
New version for GNOME 2.26. Migrated to GIO, updated translations.
Package-Manager: portage-2.2_rc31/cvs/Linux x86_64
Diffstat (limited to 'app-admin/sabayon/sabayon-2.25.0.ebuild')
-rw-r--r--app-admin/sabayon/sabayon-2.25.0.ebuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/app-admin/sabayon/sabayon-2.25.0.ebuild b/app-admin/sabayon/sabayon-2.25.0.ebuild
new file mode 100644
index 000000000000..a3dddfc0db69
--- /dev/null
+++ b/app-admin/sabayon/sabayon-2.25.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sabayon/sabayon-2.25.0.ebuild,v 1.1 2009/05/02 19:04:00 eva Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit gnome2 eutils python multilib
+
+DESCRIPTION="Tool to maintain user profiles in a GNOME desktop"
+HOMEPAGE="http://www.gnome.org/projects/sabayon/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# Unfortunately the configure.ac is wildly insufficient, so dependencies have
+# to be got from the RPM .spec file...
+COMMON_DEPEND=">=dev-lang/python-2.4
+ >=x11-libs/gtk+-2.6.0
+ >=dev-python/pygtk-2.5.3
+ >=dev-python/pygobject-2.15
+ x11-libs/pango
+ dev-python/python-ldap
+ x11-base/xorg-server[-minimal]"
+
+RDEPEND="${COMMON_DEPEND}
+ dev-python/pyxdg
+ dev-libs/libxml2[python]
+ >=gnome-base/gconf-2.8.1
+ >=dev-python/gconf-python-2.6
+ x11-libs/gksu"
+
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40"
+
+DOCS="AUTHORS ChangeLog ISSUES NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-static
+ --with-distro=gentoo
+ --with-prototype-user=${PN}-admin
+ --enable-console-helper=no"
+
+ einfo "Adding user '${PN}-admin' as the prototype user"
+ # I think /var/lib/sabayon is the correct directory to use here.
+ enewgroup ${PN}-admin
+ enewuser ${PN}-admin -1 -1 "/var/lib/sabayon" "${PN}-admin"
+ # Should we delete the user/group on unmerge?
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Switch gnomesu to gksu; bug #197865
+ sed -i 's/Exec=/Exec=gksu /' admin-tool/sabayon.desktop || die "gksu sed failed"
+ sed -i 's/Exec=/Exec=gksu /' admin-tool/sabayon.desktop.in || die "gksu sed failed"
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_mod_optimize $(python_get_sitedir)/sabayon
+
+ # unfortunately /etc/gconf is CONFIG_PROTECT_MASK'd
+ elog "To apply Sabayon defaults and mandatory settings to all users, put"
+ elog ' include "$(HOME)/.gconf.path.mandatory"'
+ elog "in /etc/gconf/2/local-mandatory.path and put"
+ elog ' include "$(HOME)/.gconf.path.defaults"'
+ elog "in /etc/gconf/2/local-defaults.path."
+ elog "You can safely create these files if they do not already exist."
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/sabayon
+}