summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-31 22:54:29 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-31 22:54:29 +0000
commit3bdb5b2ee1e5f7bfd5df64b79bc4260bcb7cad22 (patch)
treed13cb6d06879ecdc08b42396dc26c493b208d316 /app-admin/showconsole/showconsole-1.07.ebuild
parentmerge fixes from current ~arch ebuild (diff)
downloadhistorical-3bdb5b2ee1e5f7bfd5df64b79bc4260bcb7cad22.tar.gz
historical-3bdb5b2ee1e5f7bfd5df64b79bc4260bcb7cad22.tar.bz2
historical-3bdb5b2ee1e5f7bfd5df64b79bc4260bcb7cad22.zip
integrate blogd with baselayout
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'app-admin/showconsole/showconsole-1.07.ebuild')
-rw-r--r--app-admin/showconsole/showconsole-1.07.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/app-admin/showconsole/showconsole-1.07.ebuild b/app-admin/showconsole/showconsole-1.07.ebuild
index 20507ea852d4..95a63d1549f5 100644
--- a/app-admin/showconsole/showconsole-1.07.ebuild
+++ b/app-admin/showconsole/showconsole-1.07.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/showconsole/showconsole-1.07.ebuild,v 1.1 2005/03/05 00:38:39 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/showconsole/showconsole-1.07.ebuild,v 1.2 2005/05/31 22:54:29 vapier Exp $
inherit eutils toolchain-funcs
@@ -11,19 +11,16 @@ SRC_URI="mirror://gentoo/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND=""
-#RDEPEND=""
-
-S=${WORKDIR}/${P}
src_unpack() {
unpack ${P}.tar.bz2
- cd ${S}
- epatch ${DISTDIR}/${P}-suse-update.patch.bz2
- epatch ${FILESDIR}/${PV}-no-TIOCGDEV.patch
+ cd "${S}"
+ epatch "${DISTDIR}"/${P}-suse-update.patch.bz2
+ epatch "${FILESDIR}"/${PV}-no-TIOCGDEV.patch
}
src_compile() {
@@ -32,6 +29,8 @@ src_compile() {
src_install() {
make install DESTDIR="${D}" || die "install failed"
+ insinto /$(get_libdir)/rcscripts/addons
+ doins "${FILESDIR}"/bootlogger.sh || die "rcscript addon"
rmdir "${D}"/usr/lib/lsb
dodoc showconsole-1.07.lsm README
}