summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2007-01-04 11:05:10 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2007-01-04 11:05:10 +0000
commit6152cbb76c95de32dd032d585ca4c8ed0b921ccb (patch)
treeef581f66cc1314a44bf71cdf40e99cde8ec5e7cf /app-admin
parentMarked stable on x86. (diff)
downloadhistorical-6152cbb76c95de32dd032d585ca4c8ed0b921ccb.tar.gz
historical-6152cbb76c95de32dd032d585ca4c8ed0b921ccb.tar.bz2
historical-6152cbb76c95de32dd032d585ca4c8ed0b921ccb.zip
Added webapp-config-1.50.16 to the tree. Fixes bugs #104652, #149939,
#133530, #146059, #139965. Package-Manager: portage-2.1.1
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/webapp-config/ChangeLog10
-rw-r--r--app-admin/webapp-config/files/digest-webapp-config-1.50.163
-rw-r--r--app-admin/webapp-config/webapp-config-1.50.16.ebuild58
3 files changed, 70 insertions, 1 deletions
diff --git a/app-admin/webapp-config/ChangeLog b/app-admin/webapp-config/ChangeLog
index f5fe991e8be7..d7e5bea46218 100644
--- a/app-admin/webapp-config/ChangeLog
+++ b/app-admin/webapp-config/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-admin/webapp-config
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/ChangeLog,v 1.49 2007/01/02 23:08:46 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/ChangeLog,v 1.50 2007/01/04 11:05:10 wrobel Exp $
+
+*webapp-config-1.50.16 (04 Jan 2007)
+
+ 04 Jan 2007; <wrobel@gentoo.org> -webapp-config-1.50.10.ebuild,
+ -webapp-config-1.50.13.ebuild, -webapp-config-1.50.14.ebuild,
+ +webapp-config-1.50.16.ebuild:
+ Added webapp-config-1.50.16 to the tree. Fixes bugs #104652, #149939,
+ #133530, #146059, #139965.
02 Jan 2007; Renat Lumpau <rl03@gentoo.org> webapp-config-1.50.15.ebuild:
einfo->elog, bug #139814
diff --git a/app-admin/webapp-config/files/digest-webapp-config-1.50.16 b/app-admin/webapp-config/files/digest-webapp-config-1.50.16
new file mode 100644
index 000000000000..c0d0cea0a270
--- /dev/null
+++ b/app-admin/webapp-config/files/digest-webapp-config-1.50.16
@@ -0,0 +1,3 @@
+MD5 58977a47e0b269d2df2e0b972f09e1a0 webapp-config-1.50.16.tar.gz 103576
+RMD160 d3ab1b27d9b279241d2c9ff3b764ac0b9699b0a0 webapp-config-1.50.16.tar.gz 103576
+SHA256 cd5cf95d0abc9b469b08e6fffa885df10d3651d558164d35efe8e45df1fc8a5f webapp-config-1.50.16.tar.gz 103576
diff --git a/app-admin/webapp-config/webapp-config-1.50.16.ebuild b/app-admin/webapp-config/webapp-config-1.50.16.ebuild
new file mode 100644
index 000000000000..cadaacda1490
--- /dev/null
+++ b/app-admin/webapp-config/webapp-config-1.50.16.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-1.50.16.ebuild,v 1.1 2007/01/04 11:05:10 wrobel Exp $
+
+inherit eutils distutils
+
+DESCRIPTION="Gentoo's installer for web-based applications"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="http://build.pardus.de/downloads/${PF}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+S=${WORKDIR}/${PF}
+
+DEPEND=""
+
+src_install() {
+
+ # According to this discussion:
+ # http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
+ # distutils does not provide for specifying two different script install
+ # locations. Since we only install one script here the following should
+ # be ok
+ distutils_src_install --install-scripts="/usr/sbin"
+
+ dodir /etc/vhosts
+ cp config/webapp-config ${D}/etc/vhosts/
+ keepdir /usr/share/webapps
+ keepdir /var/db/webapps
+ dodoc examples/phpmyadmin-2.5.4-r1.ebuild AUTHORS.txt TODO.txt CHANGES.txt examples/postinstall-en.txt
+ doman doc/webapp-config.5 doc/webapp-config.8 doc/webapp.eclass.5
+ dohtml doc/webapp-config.5.html doc/webapp-config.8.html doc/webapp.eclass.5.html
+}
+
+src_test() {
+ cd ${S}
+ distutils_python_version
+ if [[ $PYVER_MAJOR > 1 ]] && [[ $PYVER_MINOR > 3 ]] ; then
+ elog "Running webapp-config doctests..."
+ if ! PYTHONPATH="." ${python} WebappConfig/tests/dtest.py; then
+ eerror "DocTests failed - please submit a bug report"
+ die "DocTesting failed!"
+ fi
+ else
+ elog "Python version below 2.4! Disabling tests."
+ fi
+}
+
+pkg_postinst() {
+ echo
+ elog "Now that you have upgraded webapp-config, you **must** update your"
+ elog "config files in /etc/vhosts/webapp-config before you emerge any"
+ elog "packages that use webapp-config."
+ echo
+ epause 5
+}