summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2002-04-25 23:27:06 +0000
committerThilo Bangert <bangert@gentoo.org>2002-04-25 23:27:06 +0000
commit6fac394cbb78f629cd7903d7a900f38ec90abc27 (patch)
tree0c1a595c43176fa03a27cd14b1bf387073636e07 /app-admin
parentFix for remote vulnerability (diff)
downloadhistorical-6fac394cbb78f629cd7903d7a900f38ec90abc27.tar.gz
historical-6fac394cbb78f629cd7903d7a900f38ec90abc27.tar.bz2
historical-6fac394cbb78f629cd7903d7a900f38ec90abc27.zip
new sudo ebuild - security fix (see bugtraq)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/sudo/files/digest-sudo-1.6.61
-rw-r--r--app-admin/sudo/sudo-1.6.6.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-admin/sudo/files/digest-sudo-1.6.6 b/app-admin/sudo/files/digest-sudo-1.6.6
new file mode 100644
index 000000000000..ae32e3bf568e
--- /dev/null
+++ b/app-admin/sudo/files/digest-sudo-1.6.6
@@ -0,0 +1 @@
+MD5 4da4bf6cf31634cc7a17ec3b69fdc333 sudo-1.6.6.tar.gz 333074
diff --git a/app-admin/sudo/sudo-1.6.6.ebuild b/app-admin/sudo/sudo-1.6.6.ebuild
new file mode 100644
index 000000000000..24e2d197a7a4
--- /dev/null
+++ b/app-admin/sudo/sudo-1.6.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sudo/sudo-1.6.6.ebuild,v 1.1 2002/04/25 23:27:06 bangert Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Allows certain users/groups to run commands as root"
+SRC_URI="ftp://ftp.sudo.ws/pub/sudo/${P}.tar.gz"
+HOMEPAGE="http://www.sudo.ws/"
+
+DEPEND="virtual/glibc pam? ( >=sys-libs/pam-0.73-r1 )"
+
+src_compile() {
+ local myconf
+ if [ "`use pam`" ]
+ then
+ myconf="--with-pam"
+ else
+ myconf="--without-pam"
+ fi
+ ./configure --prefix=/usr --host=${CHOST} --mandir=/usr/share/man --sysconfdir=/etc --with-all-insults --disable-path-info $myconf || die
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr sysconfdir=${D}/etc mandir=${D}/usr/share/man install || die
+ dodoc BUGS CHANGES HISTORY LICENSE PORTING README RUNSON TODO TROUBLESHOOTING UPGRADE sample.*
+ insinto /etc/pam.d
+ doins ${FILESDIR}/sudo
+}